Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    Junior Member
    Join Date
    Dec 2011
    Posts
    6

    My Touch is malfunctioning. Need some assistance.

    Greetings all,
    I have had the Squeezebox Touch for about 10 years now, and it has worked without incident until now. I went away for 2 weeks and unplugged the Touch from the back while away. When I returned, I plugged it in, noticed at some point it had turned on. The little circle was going, searching for Dac, which then got slower and slower and then stopped, faded to black and stopped powering on. From reading here, I assumed the power supply might have failed and bought another off of Amazon, though it did not fix it.. The little red light behind the optical door does turn on briefly when plugged in.So, I am back to using the original plug now. I have reset the device several times with the little button on the back. From reading here, I have held down the + button and or the 1 button to try that out too. Now when I plug it in, it shows the Enhanced digital output screen, then to feel your music, then to, choose language. However, the screen does not respond to touch, the remote does not work either. Nor can I access it through the remote control using my iPod Touch. So, those are the facts, is it dead or can it be resurrected. I would appreciate any help as I miss the little guy.
    Last edited by Shivaji; 2017-10-09 at 15:43.

  2. #2
    Senior Member Apesbrain's Avatar
    Join Date
    Jun 2005
    Location
    East Coast, USA
    Posts
    1,105
    You might try rewriting the firmware. Put the BIN file on a USB or SD drive, unplug the Touch, insert drive, plug back in. With luck it will post to the point of reading the drive and asking to update firmware.

    Touch is "fab4":
    http://update.slimdevices.com/update/firmware/

  3. #3
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    1,076
    Quote Originally Posted by Fizbin View Post
    Time for a new PSU. (Hopefully that'll do it)
    You haven't read the original post.

    Sent from my SM-G900F using Tapatalk

  4. #4
    Member JoeMuc2009's Avatar
    Join Date
    Jan 2009
    Location
    Marktoberdorf, Germany
    Posts
    96
    Sorry to disappoint you but this sounds to me like it's a hardware failure. Squeezebox devices were not deliberately time-bombed but - in my experience - there is something in each model that fails sooner or later.
    I suggest you open the unit (if you dare), and inspect the board closely. Another Touch-related case is currently ongoing here: http://forums.slimdevices.com/showth...uch-burned-u25
    You might find a similar failure in your board.

    Cheers,
    Joe


    PN me if your Boom / Classic / Transporter display has issues!

    LMS 7.9.0 on Windows Server 2012
    1x Squezeebox Classic SB2
    7x Squeezebox Classic SB3 (one waiting for repair)
    7x Squeezebox Boom (two waiting for repair)
    1x Transporter
    2x Controller (one waiting for repair)
    3x Touch (two waiting for repair)
    1x Radio

  5. #5
    Junior Member
    Join Date
    Dec 2011
    Posts
    6
    Hey Guys,

    thanks for the responses, does not sound too promising, unless a usb drive fix will have the desired result. I guess, my units particular failure is not common. On another note, if it is fried, what is a good replacement these days, buy another Touch on the used market, or another device that betters it by quite a bit. As far as streaming music goes, as said, I have been using the Touch for quite a while now and have been happy with it. Now, my Oppo 93 is my go to streaming device, which has its limitations, as it only does Pandora, though it does it quite well.

  6. #6
    Senior Member Apesbrain's Avatar
    Join Date
    Jun 2005
    Location
    East Coast, USA
    Posts
    1,105
    Quote Originally Posted by Shivaji View Post
    On another note, if it is fried, what is a good replacement these days, buy another Touch on the used market, or another device that betters it by quite a bit.
    If you don't mind doing your controlling via phone/tablet/web, I'd suggest a Raspberry Pi running piCorePlayer. Has analog and HDMI output, or you can purchase an add-on board to provide S/PDIF output or a better analog output. Worst case, about $120 and just as capable as the Touch it replaces.
    Last edited by Apesbrain; 2017-10-10 at 08:33.

  7. #7
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    2,355
    Add a RPi screen and you can control from the player too . .

    https://www.youtube.com/watch?v=wlo9XE4Oec0
    Study/Server - LMS 7.9.1 - Raspberry Pi3/Pi screen/HiFiBerry DAC+/piCorePlayer 3.22/jivelite, 25K library on WDMyCloud, cache and playlists on a USB stick (formatted ntfs).
    Lounge - RPi 2/Max2Play > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Boom
    Garage - Radio
    In car - LMS 7.9.1 > RPi3/Max2Play/Access Point plugin > HiFiBerry DAC+ > car's hifi (files on a 2TB portable USB drive)
    Spares - 1xTouch, 1xSB3

  8. #8
    Junior Member
    Join Date
    Dec 2011
    Posts
    6
    Quote Originally Posted by kidstypike View Post
    Add a RPi screen and you can control from the player too . .

    https://www.youtube.com/watch?v=wlo9XE4Oec0
    That looks pretty cool.

  9. #9
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    2,355
    Quote Originally Posted by Shivaji View Post
    That looks pretty cool.
    Yes, I use that setup as my LMS server, study player and controller. (top line of sig)

    It's a bit slicker than the video makes out, I think the operator needs some practise
    Study/Server - LMS 7.9.1 - Raspberry Pi3/Pi screen/HiFiBerry DAC+/piCorePlayer 3.22/jivelite, 25K library on WDMyCloud, cache and playlists on a USB stick (formatted ntfs).
    Lounge - RPi 2/Max2Play > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Boom
    Garage - Radio
    In car - LMS 7.9.1 > RPi3/Max2Play/Access Point plugin > HiFiBerry DAC+ > car's hifi (files on a 2TB portable USB drive)
    Spares - 1xTouch, 1xSB3

  10. #10
    Member JoeMuc2009's Avatar
    Join Date
    Jan 2009
    Location
    Marktoberdorf, Germany
    Posts
    96
    Quote Originally Posted by Shivaji View Post
    I guess, my units particular failure is not common.
    True, never heard of this exact behavior. I would love to help, however, with me being in the EU it's too much hassle to send the device around. If you consider this, let me know.


    PN me if your Boom / Classic / Transporter display has issues!

    LMS 7.9.0 on Windows Server 2012
    1x Squezeebox Classic SB2
    7x Squeezebox Classic SB3 (one waiting for repair)
    7x Squeezebox Boom (two waiting for repair)
    1x Transporter
    2x Controller (one waiting for repair)
    3x Touch (two waiting for repair)
    1x Radio

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •