Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Apr 2013
    Posts
    10

    How to upgrade on Linux

    Hello,
    stupid question but i didn't find the answer since the repository is not anymore available and before doing a mistake, i wanted to know how to upgrade my installation from 7.8 to 7.9.1, i've download the zip logitechmediaserver_7.9.1-1505480690_all.deb and push it to my linux server but now, what should i do?
    By the way, i'm doing this because my SBTouch is not anymore able to install EDO plugin, it says everytime (reinstall) but nothing happens, the kernel is not updating and the USB option not available.
    i was thinking that updating the server would also provide a new version of the player and then resolve my problem.

  2. #2
    Senior Member
    Join Date
    Jul 2009
    Location
    Bristol, UK
    Posts
    482
    For what it is worth, what I do on my Ubuntu Server using the terminal (or rather, using putty from a Windows PC), is:

    Code:
    sudo wget http://downloads.slimdevices.com/nightly/7.8/sc/89c295b/logitechmediaserver_7.8.1~1406278657_all.deb
    sudo dpkg -i logitechmediaserver_7.8.1~1406278657_all.deb
    The first command downloads the deb package, the second command installs it.

    I use a Windows PC together with the "putty" software to open a terminal window on the Ubuntu Server. I get the URL by finding the package I want to install (using my Windows browser), right click on it and select "Copy link address".

    Whether of not it is the best method, it has worked for me.

    (Of course that is an old example (for 7.8.1) - the URL and the filename would have to reflect the package you install.)
    Last edited by JohnB; 2017-09-27 at 15:55.
    Touch, Meridian G92, Bryston B4 SST2, PMC OB1i speakers, HP Proliant Microserver/Ubuntu, PC/Windows 7, iPad 4, iPeng, Squeezepad.

  3. #3
    Senior Member DJanGo's Avatar
    Join Date
    Sep 2005
    Location
    Germany
    Posts
    2,403
    Quote Originally Posted by jayce996 View Post
    Hello,
    stupid question but i didn't find the answer since the repository is not anymore available and before doing a mistake, i wanted to know how to upgrade my installation from 7.8 to 7.9.1
    Hi,
    please remove the old repository from your sources and follow the step on the wiki

  4. #4
    Junior Member
    Join Date
    Apr 2013
    Posts
    10
    thank you very much, this worked like a charm

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •