Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1
    Senior Member
    Join Date
    Jun 2009
    Posts
    173

    SSL error with 7.9.1 on 219+ (1/2 podcasts don't work now)

    So I just installed 7.9.1 from 7.9.0 and now it does not load in SSL mode. And it's causing a lot of warnings and errors, the most prominent is that 1/2 of my podcasts no longer work due to SSL errors.

    "Unable to load IO::Socket::SSL, will try connecting to SSL servers in non-SSL mode"

    I am wondering if I installed the right package from the LMS downloads page. Any ideas on how to troubleshoot this? please keep in mind that my only experience in Linux is installing LMS on my QNAP so extremely novice would be an understatement.

    thanks.. darien
    LMS 7.9.1 on QNAP 219P+
    3 wired Touch End Points
    Jolida Tube DAC III
    Marantz 2270 to Boston Acoustics Slimlines
    Marantz 7010 to B&W CM10 S2

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,761

    SSL error with 7.9.1 on 219+ (1/2podcasts don't work now)

    > "Unable to load IO::Socket::SSL, will try connecting to SSL servers in
    > non-SSL mode"


    The problem is not LMS - it's only telling you about the problem. You
    need to install that module.

    --

    Michael

  3. #3
    Senior Member
    Join Date
    Jun 2009
    Posts
    173
    thanks michael. my attempts thus far have been frustrating. here is what I did:

    1. purchased a SSL certificate from QNAP as i read it might be a certificate thing. Nope, that didn't work. Now I'm out 44 bucks
    2. saw a thread about installing SSL from CPAN. http://forums.slimdevices.com/showth...l=1#post890362 but i need the command "ipkg" installed so followed this wiki https://wiki.qnap.com/wiki/Install_O...ion_using_QPKG and ran into problems: 1) when trying to find "Opware" via the App Center within 4.3.3 qnap management, there was no application of that name and nothing close to it in Developers Tools and 2) when trying to install manually which has a a ton of steps, i was able to connect to optware-ipkg but it did not find the file "ipkg-opt_0.99.163-10_arm.ipk" and i don't know how to search that remote location. i am assuming there is an updated file name (a newer version).

    in the mean time with the above my SSOTS stopped working and i had to reinstall which at least one other person had the same problem trying to install ipkg. i am a bit frustrated. at one time, this wasn't an issue. now after upgrading it's an issue. i don't have the components (ipkg) i need to fix the issue nor do i have the confidence that installing SSL from CNAP will work, and when following the wiki directions to install, it doesn't work via two different methods.

    my ignorance is certainly an issue: i don't know what SSL is or why it's important (i read it's a secure way to systems to communicate but I have no idea what that really means), my only experience with Linux is with installing updates to LMS and troubleshooting when something goes wrong so i really have zero idea on how to even attack this or if what i am doing is right. i'm in the matrix!!!!

    anyway... any guidance from you would be greatly appreciated.
    LMS 7.9.1 on QNAP 219P+
    3 wired Touch End Points
    Jolida Tube DAC III
    Marantz 2270 to Boston Acoustics Slimlines
    Marantz 7010 to B&W CM10 S2

  4. #4
    Senior Member
    Join Date
    Jun 2009
    Posts
    173
    ok an update. I searched around for the specific "IO:Socket:SSL" and spun my wheel till I installed the Perl Developer package on the QNAP and that gave me the missing "ipkg" command. I went through the commands here: http://forums.slimdevices.com/showth...l=1#post890362 but still having a problem. When I get to the line to go to "../../bin/perl MakeFile.PL" I get the error "../../bin/perl: Director Does Not Exist" Any ideas?

    thanks much... darien
    LMS 7.9.1 on QNAP 219P+
    3 wired Touch End Points
    Jolida Tube DAC III
    Marantz 2270 to Boston Acoustics Slimlines
    Marantz 7010 to B&W CM10 S2

  5. #5
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,761

    SSL error with 7.9.1 on 219+ (1/2podcasts don't work now)

    > but still having a problem. When I get to the line to go to
    > "../../bin/perl MakeFile.PL" I get the error "../../bin/perl: Director
    > Does Not Exist" Any ideas?


    Just make sure you point to the actual perl executable file. "which
    perl" might tell you where it is.

    --

    Michael

  6. #6
    Senior Member
    Join Date
    Jun 2009
    Posts
    173
    ok I understand. I tried which but that didn't work so I tried find -name "perl" and found it that way. (see, I am learning a little) ok so I think I am in the home stretch. One more error please: so when entering the line "OPENSSL_PREFIX=/opt ../../bin/perl Makefile.PL" I get the error "Unresolvable external dependency. This package requires a C complier. NA: Unable to build a distribution on this platform"

    your help is extremely grateful.

    darien
    LMS 7.9.1 on QNAP 219P+
    3 wired Touch End Points
    Jolida Tube DAC III
    Marantz 2270 to Boston Acoustics Slimlines
    Marantz 7010 to B&W CM10 S2

  7. #7
    Senior Member
    Join Date
    Jun 2009
    Posts
    173
    so this might be a strange question... with gcc and compilers in general, do I have to run a command to actually start/initiate the compiler. I did find a how to document and it lists a compiler at http://qnas.pl/tools/arm/qnap_arm_na...-0.16-8.tar.gz but when I try and get it, I get the error file not found so I am wondering if there is an updated version. is there any easy way to query that location to see if there is an updated file which would have a different name?
    LMS 7.9.1 on QNAP 219P+
    3 wired Touch End Points
    Jolida Tube DAC III
    Marantz 2270 to Boston Acoustics Slimlines
    Marantz 7010 to B&W CM10 S2

  8. #8
    Senior Member Tony T's Avatar
    Join Date
    Nov 2009
    Posts
    828
    Is 7.9.1 a nightly, or a stable?
    I'm on 7.9, should I upgrade to 7.9.1? (I'/m on 7.9.1 on pCP, but 7.9.0 on my Mac mini server)
    Tony
     SBTouch ♪ SBRadio ♬

  9. #9
    Senior Member
    Join Date
    Jun 2009
    Posts
    173
    Quote Originally Posted by Tony T View Post
    Is 7.9.1 a nightly, or a stable?
    I'm on 7.9, should I upgrade to 7.9.1? (I'/m on 7.9.1 on pCP, but 7.9.0 on my Mac mini server)
    if it's working well, my personal feeling is don't touch it.
    LMS 7.9.1 on QNAP 219P+
    3 wired Touch End Points
    Jolida Tube DAC III
    Marantz 2270 to Boston Acoustics Slimlines
    Marantz 7010 to B&W CM10 S2

  10. #10
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    1,977
    Quote Originally Posted by dhallag View Post
    thanks michael. my attempts thus far have been frustrating. here is what I did:

    1. purchased a SSL certificate from QNAP as i read it might be a certificate thing. Nope, that didn't work. Now I'm out 44 bucks

    anyway... any guidance from you would be greatly appreciated.

    That money would have gotten a rpi3b and saved all the heartache.

    Give up on the Qnap and LMS, get a pi and point the LMS at the files on the Qnap.

    Kushti

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •