Home of the Squeezebox™ & Transporter® network music players.
Page 40 of 44 FirstFirst ... 303839404142 ... LastLast
Results 391 to 400 of 437
  1. #391
    Junior Member
    Join Date
    Feb 2012
    Posts
    21
    Mherger,

    First of all a BIG thank you for, not only, adding spotify connect to our beloved Squeezebox environment, but implementing it correctly where is feels perfectly part of LMS/Squeezebox. And with gapless support, no less!

    Big Kudos to you - this works better than squeezelite and librespot on the side.

    One small request - can we change the names that spotify connect reports for the players? I really don't like the MAC address being visible.

    Thanks!

  2. #392
    Senior Member
    Join Date
    Feb 2008
    Posts
    4,180
    Quote Originally Posted by TonioRoffo View Post

    One small request - can we change the names that spotify connect reports for the players? I really don't like the MAC address being visible.

    Thanks!
    +1
    Touch, Logitech Radio, Logitech UE Radio, O2 Joggler + SqpOS
    UPnPBridge - 2 paired Sonos Play1 speakers; Rocki - Sony SRS-BTM8 speaker; Pioneer WX-SMA1 speaker; - PURE One Flow internet radio: PURE Jongo S3x ; Jongo T2; Libratone Zipp
    Castbridge - Chromecast 1 + Chromecast Audio
    AirplayBridge - Loewe Airspeaker
    SB Player - Fire TV
    ------------------------------------------------------------------------------------

  3. #393
    Senior Member jasell's Avatar
    Join Date
    May 2008
    Posts
    123
    It can't be said too many times, thanks Micheal for doing this!!

    I noticed that you released a 1.9.7, I installed it without problem.

    First of all I don't need to rename the pv-files as I used to, it just works!

    There is a major difference in behavior in the /tmp folder.
    I see lots of .tmp???? files appearing, files with the same size create at the exact same time and with a few seconds difference, for some songs it 3 files for others there are 10+ files. Some are deleted, some are left behind.
    It takes a long time before first songs starts to play.
    Sometimes the song plays nicely, sometimes the player starts and stops, on the same song or skips to the next.

    Over all a step back but I'm sure you are working something out...

    Let me know if there is something I should test.
    NAS: QNAP TS-459U+ QTS 4.2.6 (4x 2TB, RAID5)
    Services: LMS 7.9.1 , SSOTS 4.14
    Squeezebox: 6x Reciever, 3x Boom, 2x SB3 Classic
    Other: iPeng on iPad and iPhone

  4. #394
    Senior Member
    Join Date
    Feb 2008
    Posts
    4,180
    Quote Originally Posted by jasell View Post
    It can't be said too many times, thanks Micheal for doing this!!

    I noticed that you released a 1.9.7, I installed it without problem.

    First of all I don't need to rename the pv-files as I used to, it just works!

    There is a major difference in behavior in the /tmp folder.
    I see lots of .tmp???? files appearing, files with the same size create at the exact same time and with a few seconds difference, for some songs it 3 files for others there are 10+ files. Some are deleted, some are left behind.
    It takes a long time before first songs starts to play.
    Sometimes the song plays nicely, sometimes the player starts and stops, on the same song or skips to the next.

    Over all a step back but I'm sure you are working something out...

    Let me know if there is something I should test.
    Interesting ... I see the same behaviour on a Touch with 1.9.7
    Touch, Logitech Radio, Logitech UE Radio, O2 Joggler + SqpOS
    UPnPBridge - 2 paired Sonos Play1 speakers; Rocki - Sony SRS-BTM8 speaker; Pioneer WX-SMA1 speaker; - PURE One Flow internet radio: PURE Jongo S3x ; Jongo T2; Libratone Zipp
    Castbridge - Chromecast 1 + Chromecast Audio
    AirplayBridge - Loewe Airspeaker
    SB Player - Fire TV
    ------------------------------------------------------------------------------------

  5. #395
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,779

    [Announce] Spotty v1.9.0 - now withexperimental Spotify Connect support!

    > There is a major difference in behavior in the /tmp folder.

    There should be less of those files than before. I assume you didn't pay
    any attention before?

    > I see lots of .tmp???? files appearing, files with the same size create
    > at the exact same time and with a few seconds difference, for some songs
    > it 3 files for others there are 10+ files. Some are deleted, some are
    > left behind.


    This usually happens when a track is being skipped or otherwise not
    played to the end. I can easily produce those files by hitting the FWD
    button quickly. But the files should be cleaned up every now and then.
    The next update will be even more thorough cleaning up.

    > It takes a long time before first songs starts to play.
    > Sometimes the song plays nicely, sometimes the player starts and stops,
    > on the same song or skips to the next.


    Connect mode or regular playback through LMS?

    --

    Michael

  6. #396
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,779

    [Announce] Spotty v1.9.0 - now withexperimental Spotify Connect support!

    > One small request - can we change the names that spotify connect reports
    > for the players? I really don't like the MAC address being visible.


    I'll have to review this. At some point I needed it to make transcoding
    or something work. The Connect implementation is complicated, and hacky...

    --

    Michael

  7. #397
    Senior Member jasell's Avatar
    Join Date
    May 2008
    Posts
    123

    [Announce] Spotty v1.9.0 - now with experimental Spotify Connect support!

    Quote Originally Posted by mherger View Post
    > ...

    > It takes a long time before first songs starts to play.
    > Sometimes the song plays nicely, sometimes the player starts and stops,
    > on the same song or skips to the next.


    Connect mode or regular playback through LMS?

    --

    Michael
    Connect


    Sent from my iPhone using Tapatalk
    NAS: QNAP TS-459U+ QTS 4.2.6 (4x 2TB, RAID5)
    Services: LMS 7.9.1 , SSOTS 4.14
    Squeezebox: 6x Reciever, 3x Boom, 2x SB3 Classic
    Other: iPeng on iPad and iPhone

  8. #398
    Senior Member jasell's Avatar
    Join Date
    May 2008
    Posts
    123

    [Announce] Spotty v1.9.0 - now with experimental Spotify Connect support!

    Quote Originally Posted by mherger View Post
    > There is a major difference in behavior in the /tmp folder.

    There should be less of those files than before. I assume you didn't pay
    any attention before?

    > I see lots of .tmp???? files appearing, files with the same size create
    > at the exact same time and with a few seconds difference, for some songs
    > it 3 files for others there are 10+ files. Some are deleted, some are
    > left behind.


    This usually happens when a track is being skipped or otherwise not
    played to the end. I can easily produce those files by hitting the FWD
    button quickly. But the files should be cleaned up every now and then.
    The next update will be even more thorough cleaning up.
    --

    Michael
    I checked this from the 1.9.6 release, and that had fewer, always 2 files per song and sometimes 1 of them was left behind.
    In 1.9.7 I can get up to 10 files per song were several are left behind on regular basis.

    This is fills my /tmp after listening to 2-5 songs and Spotty stops. I need to manually clear /tmp to continue listening.

    Since I saw this changed behavior I thought something is cooking and thought better give some feedback while you are at it.


    Sent from my iPhone using Tapatalk
    Last edited by jasell; 2017-11-15 at 01:08.
    NAS: QNAP TS-459U+ QTS 4.2.6 (4x 2TB, RAID5)
    Services: LMS 7.9.1 , SSOTS 4.14
    Squeezebox: 6x Reciever, 3x Boom, 2x SB3 Classic
    Other: iPeng on iPad and iPhone

  9. #399
    Junior Member
    Join Date
    Apr 2017
    Posts
    2
    Just updated to 1.9.7 too. I am trying to find any log where I can see Spotty references inside the lms settings pages, am I missing something? Just want to check once in a while if I see strange things happening.

    I did find the server.log there. Funny thing: since update to 1.9.7 suddenly I see the following line a LOT:
    Code:
    [17-11-15 13:08:59.0293] Slim::Player::StreamingController::_eventAction (273) 00:04:20:23:47:a4: StatusHeartbeat in PLAYING-STREAMING -> Slim::Player::StreamingController::_CheckSync
    Is this by design? Thanx Michael

  10. #400
    Junior Member
    Join Date
    Feb 2012
    Posts
    21
    Since 1.9.7, I start a track (android - spotify connect) - it plays 5 seconds to 10, skips to the next track, keeps playing but indicates on android as "stopped" as soon as it skips.

    edit: fixed - somehow, auto upgrade plugins re-enabled Triode's spotify plugin.
    Last edited by TonioRoffo; 2017-11-15 at 07:27.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •