Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 6 of 6
  1. #1

    Audio::Scan: 0.93 in LMSUpdate 7.9.1 for Synology DS 216play

    @mherger

    I have installed the latest version of the LMSUpdate Synology (my NAS is DS 216play) package, but Audio::Scan is still on an older version 0.93.

    For DSD playback or transcoding I need it to be 0.94 or higher - which it should be, afaik, within this newest LMS version.

    Logitech Media Server Version: 7.9.1 - 1503129892 @ Sat Aug 19 09:00:13 UTC 2017
    Hostname: DiskStation
    Server IP Address: 192.168.1.51
    Server HTTP Port Number: 9002
    Operating system: Synology DiskStation - EN - utf8
    Platform Architecture: armle-linux
    Perl Version: 5.24.0 - armle-linux
    Audio::Scan: 0.93
    Database Version: DBD::SQLite 1.34_01 (sqlite 3.7.7.1)
    Total Players Recognized: 4

    Please help. I have some basic Linux knowhow if required.

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,803

    Audio::Scan: 0.93 in LMSUpdate7.9.1 for Synology DS 216play

    > For DSD playback or transcoding I need it to be 0.94 or higher - which
    > it should be, afaik, within this newest LMS version.


    You'll need dev tools on your NAS. Try to get them (gcc, make etc.)

    Once you have this, head over to
    https://github.com/Logitech/slimserv...ublic/7.9/CPAN,
    download that folder. Then run "./buildme.sh Audio::Scan".

    --

    Michael

  3. #3
    Quote Originally Posted by mherger View Post
    >
    Once you have this, head over to
    https://github.com/Logitech/slimserv...ublic/7.9/CPAN,
    download that folder. Then run "./buildme.sh Audio::Scan".

    --

    Michael
    Thank you, Michael,

    installed GCC via Entware-ng oPKG. Also installed "NAMS" by compiling with GCC. The AudioScan compilation starts successfully but I'm stuck with this error message:

    root@DiskStation:/volume1/homes/Gerhard/LINUX/slimserver-vendor-public-7.9/CPAN# ./buildme.sh Audio::Scan
    /usr/bin/env: error while loading shared libraries: /opt/lib/libc.so.6: internal error

    root@DiskStation:/opt/lib# ls -l libc.so.6
    lrwxrwxrwx 1 0 0 12 Sep 22 19:21 libc.so.6 -> libc-2.23.so

    root@DiskStation:/opt/lib# file libc-2.23.so
    libc-2.23.so: ELF 32-bit LSB shared object, ARM, EABI5 version 1 (GNU/Linux), dynamically linked, interpreter /lib/ld-linux.so.3, for GNU/Linux 2.6.32, stripped


    Do you have an idea what could be causing this?

    On another note, LMS 7.9.0 beta from Synology does in fact run with Audio::Scan 0.95.
    Makes me wonder why it's not the same in 7.9.1 LMSUpdate...
    Last edited by Ge Ba; 2017-09-28 at 17:04. Reason: additional details

  4. #4
    Quote Originally Posted by Ge Ba View Post
    ...The AudioScan compilation starts successfully but I'm stuck with this error message:

    root@DiskStation:/volume1/homes/Gerhard/LINUX/slimserver-vendor-public-7.9/CPAN# ./buildme.sh Audio::Scan
    /usr/bin/env: error while loading shared libraries: /opt/lib/libc.so.6: internal error
    Seems this got solved by installing two more libraries, libgd and libtools.

    Next stop is here.

    root@DiskStation:/volume1/homes/Gerhard/LINUX/slimserver-vendor-public-7.9/CPAN# ./buildme.sh Audio::Scan
    RUN_TESTS:1 CLEAN:1 USE_HINTS:1 target Audio::Scan
    Building for Linux / armle-linux
    Building with Perl 5.24 at /opt/bin/perl
    building only Audio::Scan
    build_module run tests:0 clean:1 hints 1 Sub-Uplevel-0.22
    tar zxvf Sub-Uplevel-0.22.tar.gz
    tar done
    Can't locate ExtUtils/MakeMaker.pm in @INC (you may need to install the ExtUtils::MakeMaker module) (@INC contains: /volume1/homes/Gerhard/LINUX/slimserver-vendor-public-7.9/CPAN/build/5.24/lib/perl5 /opt/lib/perl5/5.24 .) at Makefile.PL line 3.
    BEGIN failed--compilation aborted at Makefile.PL line 3.
    make: *** No targets specified and no makefile found. Stop.
    make failed, aborting

  5. #5
    Senior Member pinkdot's Avatar
    Join Date
    Nov 2009
    Location
    The Netherlands
    Posts
    881
    Quote Originally Posted by Ge Ba View Post
    Seems this got solved by installing two more libraries, libgd and libtools.

    Next stop is here.

    root@DiskStation:/volume1/homes/Gerhard/LINUX/slimserver-vendor-public-7.9/CPAN# ./buildme.sh Audio::Scan
    RUN_TESTS:1 CLEAN:1 USE_HINTS:1 target Audio::Scan
    Building for Linux / armle-linux
    Building with Perl 5.24 at /opt/bin/perl
    building only Audio::Scan
    build_module run tests:0 clean:1 hints 1 Sub-Uplevel-0.22
    tar zxvf Sub-Uplevel-0.22.tar.gz
    tar done
    Can't locate ExtUtils/MakeMaker.pm in @INC (you may need to install the ExtUtils::MakeMaker module) (@INC contains: /volume1/homes/Gerhard/LINUX/slimserver-vendor-public-7.9/CPAN/build/5.24/lib/perl5 /opt/lib/perl5/5.24 .) at Makefile.PL line 3.
    BEGIN failed--compilation aborted at Makefile.PL line 3.
    make: *** No targets specified and no makefile found. Stop.
    make failed, aborting
    Still don't understand why you take this route. The correct version of the Audio::Scan is in both lms variants, the Synology Beta and LmsUpdate. As already pointed out in PM, there are 2 locations in the Synology package that look for the Audio::Scan: the one in lib and the one in Cpan. Try to figure out what change is working for you.
    -LMS on Raspian Stretch -> 2x Radio
    -RPI 3 (Mopidy + Raspotify), Allo Boss DAC- Exposure 3010S2 - PMC FB1i

  6. #6
    Quote Originally Posted by pinkdot View Post
    Still don't understand why you take this route. The correct version of the Audio::Scan is in both lms variants, the Synology Beta and LmsUpdate. As already pointed out in PM, there are 2 locations in the Synology package that look for the Audio::Scan: the one in lib and the one in Cpan. Try to figure out what change is working for you.
    yes I understand.. I did try everything I could think of with those two Scan.pm files in CPAN and lib but it never solved the problem.
    So I think there must be something else causing this..

    plus I needed to setup a development environment anyway
    Server: LMS 7.9.1-166 Synology @ Sept 04 2017 on DS216Play. SOX mansr ARMv7 & C-3PO. Players: SB Radio, Freecom MusicPal. Multiroom HiFi: Denon AVR-X4000, AVM M30, Nubert NuLine/NuVero 5.1+2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •