Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23
  1. #11
    Senior Member
    Join Date
    Feb 2012
    Posts
    115
    Here are the audio properties of one of the files which won't play

    Artist Stephen Farr
    Title Kyrie, Gott Vater in Ewigkeit, BWV 672
    Album J.S. Bach: Clavier-▄bung III
    Track 5
    Disc
    Genre Classique
    Year 2013
    Rating
    Composer Johann Sebastian Bach
    Size 28.25 MB (55% Compressed)
    Original Size 62.4 MB
    Length 1 minute 53 seconds
    Channels 2 (stereo)
    Sample Rate 96 KHz{CR}
    Sample Size 24 bit
    Bit Rate 4,608 kbps (DVD)
    Encoder FLAC reference libFLAC 1.3.1 20141125
    Encoder Settings
    Audio Quality Perfect (Lossless)
    Contains CRC, ID Tag [Vorbis Comments]
    Channel Mapping
    File 05. Kyrie, Gott Vater in Ewigkeit, BWV 672
    Type VLC media file (.flac) [.flac]
    And one of the files which will play

    Artist Gustav Leonhardt
    Title 01 1. C-dur, BWV 870
    Album J.S. Bach WTC 2 CD 1 (SACD)
    Track 1
    Disc 1
    Genre Classical
    Year 1973
    Rating
    Composer Johann Sebastian Bach
    Size 26.2 MB (41% Compressed)
    Original Size 43.99 MB
    Length 4 minutes 21 seconds
    Channels 2 (stereo)
    Sample Rate 44.1 KHz{CR}
    Sample Size 16 bit
    Bit Rate 1,411 kbps
    Encoder FLAC reference libFLAC 1.2.1 20070917
    Encoder Settings
    Audio Quality Perfect (Lossless)
    Contains Album Art, CRC, ID Tag [Vorbis Comments]
    Channel Mapping
    File 01 Gustav Leonhardt SACD - Dur BWV 870
    Type VLC media file (.flac) [.flac]

  2. #12
    Senior Member
    Join Date
    Apr 2013
    Location
    UK
    Posts
    1,005
    So Sox is refusing to convert it? What's the CPU you are asking to do this downsample job?


    Transcoded from Matt's brain by Tapatalk
    --
    Hardware: 3x Touch, 1x Radio, 2x Receivers, 1 HP Microserver NAS with Debian+LMS 7.9.0
    Music: ~1300 CDs, as 450 GB of 16/44k FLACs. No less than 3x 24/44k albums..

  3. #13
    Senior Member
    Join Date
    Feb 2012
    Posts
    115
    AMD E-350 Processor

  4. #14
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,319
    I think LMS will be trying to resample the stream from 96Khz to 48Khz (as that is max for Sb2) which means it will be applying the "flc flc transcode *" rule and not the "flc flc * *" rule.

    You need to add a "flc flc transcode 00:00:00:00:00" simialr to your your "flc flc * 00:00:00:00:00" rule.

    To be sure you understand and can see what is really happening enable logging player.source to INFO.

  5. #15
    Senior Member
    Join Date
    Feb 2012
    Posts
    115
    Quote Originally Posted by bpa View Post
    I think LMS will be trying to resample the stream from 96Khz to 48Khz (as that is max for Sb2) which means it will be applying the "flc flc transcode *" rule and not the "flc flc * *" rule.

    You need to add a "flc flc transcode 00:00:00:00:00" simialr to your your "flc flc * 00:00:00:00:00" rule.

    To be sure you understand and can see what is really happening enable logging player.source to INFO.
    Thanks for thinking about this.

    So should I delete my existing conf file and replace it with this?

    Code:
    flc flc transcode 00:00:00:00:00
    	# FT:{START=--skip=%t}U:{END=--until=%v}
    	[flac] -dcs $START$ $END$ -- $FILE$ | [sox] -q -t wav - -t flac -C 0 -b 16 -r 44100 -
    And how do I enable logging player.source to INFO?

  6. #16
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,319
    Quote Originally Posted by mandryka View Post
    Thanks for thinking about this.

    So should I delete my existing conf file and replace it with this?
    No it should be in addition to the existing "Flc flc " in your custom-convert.conf

    Code:
    flc flc transcode 00:00:00:00:00
    	# FT:{START=--skip=%t}U:{END=--until=%v}
    	[flac] -dcs $START$ $END$ -- $FILE$ | [sox] -q -t wav - -t flac -C 0 -b 16 -r 44100 -
    Looks OK but I haven't double checked. Rememebr the MAC addres is the address of your player not 00:00...

    And how do I enable logging player.source to INFO?
    WebUI Settings/Advanced/Logging

  7. #17
    Senior Member
    Join Date
    Feb 2012
    Posts
    115
    Quote Originally Posted by bpa View Post
    No it should be in addition to the existing "Flc flc " in your custom-convert.conf

    Code:
    flc flc transcode 00:00:00:00:00
    	# FT:{START=--skip=%t}U:{END=--until=%v}
    	[flac] -dcs $START$ $END$ -- $FILE$ | [sox] -q -t wav - -t flac -C 0 -b 16 -r 44100 -
    Looks OK but I haven't double checked. Rememebr the MAC addres is the address of your player not 00:00...



    WebUI Settings/Advanced/Logging
    Well I don't know if this is what you meant, but replacing the file with this doesn't solve the problem.

    Code:
    flc flc * 00:00:00:00:00:00
    	# FT:{START=--skip=%t}U:{END=--until=%v}
    	[flac] -dcs $START$ $END$ -- $FILE$ | [sox] -q -t wav - -t flac -C 0 -b 16 -r 44100 -
    
    flc flc transcode * 00:00:00:00:00:00
    	# FT:{START=--skip=%t}U:{END=--until=%v}
    	[flac] -dcs $START$ $END$ -- $FILE$ | [sox] -q -t wav - -t flac -C 0 -b 16 -r 44100 -

  8. #18
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,319
    The "00:00:00:00:00:00" must match the MAC address of your player - it is on the label of your SB2 playter. The rule will only apply to players whose MAC address matches.

    IIRC The address 00:00:00:00:00:00 is technically invalid but many users of softplayers will use it incorrectly.
    Last edited by bpa; 2017-09-10 at 05:13.

  9. #19
    Senior Member Apesbrain's Avatar
    Join Date
    Jun 2005
    Location
    East Coast, USA
    Posts
    1,105
    Quote Originally Posted by bpa View Post
    The "00:00:00:00:00:00" must match the MAC address of your player...
    And the code OP pasted above has an extraneous "*" in the "transcode" line.

  10. #20
    Senior Member
    Join Date
    Feb 2012
    Posts
    115
    Quote Originally Posted by Apesbrain View Post
    And the code OP pasted above has an extraneous "*" in the "transcode" line.
    I've left the * in there, it is working to transcode down to a sample rate of 44.1 kHz. As far as I can see the problem is only with files with a bit rate of 4,608 kHz

    It has the correct MAC address!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •