Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 5 of 5
  1. #1

    Can I disable html call to opml.radiotime.com?

    Hi.

    One of my LMS (latest 7.9.1 nightly, macOS 10.12) has no internet connection. To make debugging easier and my log less cluttered, I would very much like to get rid of the error messages that complain (every couple of minutes or so) about timed out connection attempts:

    Code:
    Connect timed out: 
    [17-09-08 17:36:10.0633] Slim::Plugin::InternetRadio::Plugin::_gotRadioError (67) Unable to retrieve radio directory from SN: Connect timed out: 
    [17-09-08 17:37:05.0670] Slim::Formats::XML::gotErrorViaHTTP (310) Error: getting http://opml.radiotime.com/Index.aspx?partnerId=16
    If there is no option in the settings (I didn't find one), I'd gladly settle for a little hack or someting like this.
    Thank you.

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,779

    Can I disable html call toopml.radiotime.com?

    > One of my LMS (latest 7.9.1 nightly, macOS 10.12) has no internet
    > connection. To make debugging easier and my log less cluttered, I would
    > very much like to get rid of the error messages that complain (every
    > couple of minutes or so) about timed out connection attempts:


    Don't use the Radios menu. Or accept those messages as another potential
    pointer to your issue? If you get an error complaining about connection
    time outs every few minutes, then you've got a networking issue.


    --

    Michael

  3. #3
    Quote Originally Posted by mherger View Post
    you've got a networking issue.
    Ok, what I meant was "has no internet connection" because it's by design, like a stand-alone setup, only LAN with a local server. I don't use the Radio Menu, was just curious if it's possible to disable what seems to be downloading a radio station list or something. I figured the error messages would go away then. Well, nevermind...

  4. #4
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,322
    A hack that might work you would be to edit the install.xml file in the plugin/InternetRadio directory. Change MaxVersion from "*" to 7.3, save and restart LMS. This will break loading of the InternetRadio plugin. I don't know whether LMS will work OK without the plugin as it seems to be one that cannot be disabled in the Plugins tab..

  5. #5
    Thank you very much, bpa. Really appreciate your help however stupid my little problem may seem. In the end I just disabled/commented most of the retry subfunction in the plugin.pm file. This way the plugin is not broken and it won't endlessly retry to connect to the internet in vain. Sure, I'll have to edit this file after every update. I'll just update less often then. So thank you very much.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •