Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24
  1. #11
    Senior Member
    Join Date
    Mar 2006
    Location
    London
    Posts
    431
    Actually, none of their Ogg Vorbis streams work in VLC ...

  2. #12
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,318
    Quote Originally Posted by rbl View Post
    I am using the URLs listed here which includes FLAC streams. It does say at the bottom that it is a trial
    https://absoluteradio.co.uk/listen/links/

    The FLAC streams don't work in VLC (64bit) either ...
    I forgot to post thelink in my message but you located the same page. Funny thing about this page is that I can;t find it easily from AbsoluteUK home page so I'm guessing it is is out of date.

    So possibilities are Ogg/Flac streams have been turned off or player is not right.

    Rune users seems to be playing them OK on Oct 2016 - so perhaps VLC version/build may not be not right.

    Have you tried mplayer ? mplayer used to be good at odd formats.

    In VLC - open Message window (usually under Tools) and set message level to 2 - then try to stream. The reason for failure should show up.

  3. #13
    Senior Member
    Join Date
    Mar 2006
    Location
    London
    Posts
    431
    Quote Originally Posted by bpa View Post
    In VLC - open Message window (usually under Tools) and set message level to 2 - then try to stream. The reason for failure should show up.
    It output a lot of stuff which made no sense to me whatsoever!

    VLC debug output.txt

  4. #14
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,318
    The first URL is a playlist and VLC retrieves it OK
    Code:
    core debug: art not found for http://network.absoluteradio.co.uk/core/audio/oggflac/live.pls?service=ac
    core debug: connection succeeded (socket = 2184)
    http debug: protocol 'HTTP' answer code 206
    http debug: resource size=139
    http debug: Content-Type: audio/x-scpls
    http debug: Pragma: no-cache
    http debug: Server: Apache/2.2.15 (CentOS)
    http debug: response body size=139
    http debug: Connection: Close
    core debug: using access module "http"
    core debug: Using stream method for AStream*
    core debug: starting pre-buffering
    core debug: received first data after 0 ms
    core debug: pre-buffering done 139 bytes in 0s - 135742 KiB/s
    core debug: looking for stream_filter module matching "any": 6 candidates
    core debug: no stream_filter modules matched
    core debug: looking for stream_filter module matching "record": 6 candidates
    core debug: using stream_filter module "record"
    core debug: creating demux: access='http' demux='any' location='network.absoluteradio.co.uk/core/audio/oggflac/live.pls?service=ac' file='\\network.absoluteradio.co.uk\core\audio\oggflac\live.pls?service=ac'
    core debug: looking for demux module matching "any": 66 candidates
    pls debug: found valid PLS playlist file
    Then VLC tries to play the URL in the playlist but it fails with 404 - so the URL is not active - VLC cannot even get any data to look at.
    Code:
    http debug: protocol 'HTTP' answer code 404
    http error: error: HTTP/1.1 404 Not Found
    http debug: switching to HTTP version 1.0
    core debug: net: connecting to icecast.timlradio.co.uk port 80
    core debug: connection succeeded (socket = 2116)
    http debug: protocol 'HTTP' answer code 404
    http error: error: HTTP/1.1 404 Not Found
    core debug: net: connecting to icecast.timlradio.co.uk port 80
    core debug: connection succeeded (socket = 2116)
    access_mms error: error: HTTP/1.1 404 Not Found
    core debug: no access modules matched
    core error: open of `http://icecast.timlradio.co.uk/absoluteradio.co.uk/acflac.ogg' failed
    core debug: dead input

  5. #15
    Senior Member
    Join Date
    Mar 2006
    Location
    London
    Posts
    431
    Well that settles that one then!

    Thanks all for your help. I have emailed Absolute Radio - I have any luck I'll post something here...

  6. #16
    Senior Member
    Join Date
    Mar 2006
    Location
    London
    Posts
    431
    I just received an email from Absolute Radio saying that the FLAC links have just been restored. And indeed they now work in VLC, but they still don't work on my 3 SB3s and LMS 7.9.0. Here are the FLAC URLs for anyone that is interested..

    https://absoluteradio.co.uk/listen/links/

  7. #17
    Senior Member
    Join Date
    Dec 2005
    Location
    Sutton Coldfield, UK
    Posts
    529
    I can get Absolute Radio Noughties on this URL:

    http://icecast-beta.timlradio.co.uk/...teradio00s.ogg

    Derived from the VLC information page.

    However the Sixties stream seems to be the same.

    Is that correct?

    Edit: They just stated that the Breakfast Show goes across all the Absolute Radio Stations
    Last edited by ian_heys; 2017-10-16 at 00:05.
    Music Store: Synology DS215J NAS
    Home Server/Player:
    LMS 7.9.1 on Pi 3B piCorePlayer v3.22 Server/IQAudio DAC+/Amp+
    Portable Server/Player: LMS 7.9.1 on HP-DV2700 Laptop/Ubuntu 17.10 with synced music drive.
    Homeplug LAN Players: Pi 3B piCorePlayer v3.22/HDMI/Jivelite, Squeezelite on Windows 10 PC
    UPNP Wifi Players: Chromecast Audio, Revo Super-Connect Radio, GGMM-E5 portable
    VPN Player: SqueezePlayer on Android Phone

  8. #18
    Senior Member
    Join Date
    Mar 2006
    Location
    London
    Posts
    431
    Quote Originally Posted by ian_heys View Post
    I can get Absolute Radio Noughties on this URL:

    http://icecast-beta.timlradio.co.uk/...teradio00s.ogg
    Sure that works, but I don't think it is the FLAC stream that we are trying to get to work..

  9. #19
    Senior Member
    Join Date
    Dec 2005
    Location
    Sutton Coldfield, UK
    Posts
    529
    Quote Originally Posted by rbl View Post
    Sure that works, but I don't think it is the FLAC stream that we are trying to get to work..
    If you put the URI into VLC it plays and you can look at the codec tab and see that it is indeed the FLAC stream.

    Edit. Even though it says the file type is OGG

    Edit 2

    Name:  AB60S.JPG
Views: 63
Size:  19.9 KB
    Last edited by ian_heys; 2017-10-16 at 02:58.
    Music Store: Synology DS215J NAS
    Home Server/Player:
    LMS 7.9.1 on Pi 3B piCorePlayer v3.22 Server/IQAudio DAC+/Amp+
    Portable Server/Player: LMS 7.9.1 on HP-DV2700 Laptop/Ubuntu 17.10 with synced music drive.
    Homeplug LAN Players: Pi 3B piCorePlayer v3.22/HDMI/Jivelite, Squeezelite on Windows 10 PC
    UPNP Wifi Players: Chromecast Audio, Revo Super-Connect Radio, GGMM-E5 portable
    VPN Player: SqueezePlayer on Android Phone

  10. #20
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,318
    Quote Originally Posted by ian_heys View Post
    If you put the URI into VLC it plays and you can look at the codec tab and see that it is indeed the FLAC stream.

    Edit. Even though it says the file type is OGG
    OGG is the transport/container mechanism. It is typically used with Vorbis (which is audio compression) but with these stream it is used to contain Flac streams.

    Thinks of "OGG" in the same way as "HTTP" and that HTTP can be used to transport MP3 or AAC stream.

    edit:

    I can't play Absolut due to geoIP lokcing but the VLC messages show it tries to play Flac,
    Code:
    core debug: `http://icecast-beta.timlradio.co.uk/absoluteradio.ogg' successfully opened
    core debug: selecting program id=0
    core debug: looking for audio decoder module matching "any": 21 candidates
    core debug: using audio decoder module "flac"
    ogg warning: Consider increasing access caching variable from 1000 to >24146784
    core debug: Buffering 0%
    ogg warning: Invalid FLAC in ogg detected. Restarting ES with packetizer.
    core debug: killing decoder fourcc `flac'
    core debug: removing module "flac"
    core debug: Program doesn't contain anymore ES
    core debug: looking for packetizer module matching "any": 24 candidates
    core debug: using packetizer module "flac"
    core debug: looking for audio decoder module matching "any": 21 candidates
    core debug: using audio decoder module "flac"
    core debug: Buffering 28%
    flac debug: decode STREAMINFO
    flac debug: channels:2 samplerate:48000 bitspersamples:24
    flac debug: STREAMINFO decoded
    Last edited by bpa; 2017-10-16 at 03:37.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •