Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 35
  1. #11
    Senior Member erland's Avatar
    Join Date
    Dec 2005
    Location
    Sweden
    Posts
    11,010
    Quote Originally Posted by dermicha View Post
    After updating CustomClockHelper my custom themes are gone.
    Did you just update or did you delete something else ?
    Just updating shouldn't remove any styles as far as I know

    The styles are stored in customclockhelper.prefs file, so if you can get that from a backup it would be a solution.

    Quote Originally Posted by dermicha View Post
    They are on my radios and touches but not on the server. Any chance to restore them from the devices by ssh?
    Have to get back to you regarding this. In theory they are stored in the settings file for CustomClock on the device but I think the format differs so it might not be that easy to retrieve it.
    Erland Isaksson (My homepage)
    Lead platform developer of ickStream Music Platform - A world of music at your fingertips

    (Also developer of many plugins/applets)

  2. #12
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    981
    In the Custom Clock Applet for the Touch all I can see in settings is a list of Config#1, Config#2 etc. I was just wondering what these configs are and how to use them.

    Sent from my SM-G900F using Tapatalk

  3. #13
    Quote Originally Posted by erland View Post
    Did you just update or did you delete something else ?
    Just updating shouldn't remove any styles as far as I know

    The styles are stored in customclockhelper.prefs file, so if you can get that from a backup it would be a solution.


    Have to get back to you regarding this. In theory they are stored in the settings file for CustomClock on the device but I think the format differs so it might not be that easy to retrieve it.
    I only have the following in the prefs-file.

    Code:
    ---
    _ts_customitemsrefreshinterval: 1492450342
    _ts_customitemsstartuprefreshinterval: 1492450342
    _ts_titleformats: 1492450342
    _version: 2
    customitemsrefreshinterval: 300
    customitemsstartuprefreshinterval: 60
    titleformats: []
    Where are the predefined styles?
    2x Transporter, 4x Touch, 5x Radio, H/K Onyx (AirPlay-Bridge), Marantz Consolette (AirPlay-Bridge), iPhone 6 (iPeng), iMac-5k (SqueezePlay)

  4. #14
    Senior Member erland's Avatar
    Join Date
    Dec 2005
    Location
    Sweden
    Posts
    11,010
    Quote Originally Posted by slartibartfast View Post
    In the Custom Clock Applet for the Touch all I can see in settings is a list of Config#1, Config#2 etc. I was just wondering what these configs are and how to use them.
    You select style for each configuration in Settings/Screen/Screensavers/Custom Clock Settings

    If you want customize a style or create your own you do this through Custom Clock Helper plugin in LMS, see more information here:
    http://wiki.slimdevices.com/index.ph...m_Clock_applet
    Erland Isaksson (My homepage)
    Lead platform developer of ickStream Music Platform - A world of music at your fingertips

    (Also developer of many plugins/applets)

  5. #15
    Senior Member erland's Avatar
    Join Date
    Dec 2005
    Location
    Sweden
    Posts
    11,010
    Quote Originally Posted by dermicha View Post
    I only have the following in the prefs-file.

    Code:
    ---
    _ts_customitemsrefreshinterval: 1492450342
    _ts_customitemsstartuprefreshinterval: 1492450342
    _ts_titleformats: 1492450342
    _version: 2
    customitemsrefreshinterval: 300
    customitemsstartuprefreshinterval: 60
    titleformats: []
    Where are the predefined styles?
    Your customized styles are stored in a "styles" property in the customclockhelper.prefs file, since it doesn't exist in your setup you don't seem to have any customized styles in your setup or the customclockhelper.prefs file have been deleted during the upgrade process for some reason. It's not deleted automatically by LMS, at least that did not happen in my setup.

    The styles on the device is stored in /etc/squeezeplay/userpath/settings/CustomClock.lua, so if the style on the device is correct I suggest that you ASAP login via ssh and take a backup of this file. As I mentioned earlier it's based on a different format so it can't easily be imported in Custom Clock Helper but you can at least open it in a text editor and take the values from it when you configure a new style. If you format it with a JSON formatter its a bit easier to read.

    The predefined styles aren't bundled in the plugin/applet, they are downloaded from the following file online:
    http://erland.github.io/squeezebox-c...ckstyles7.json
    Erland Isaksson (My homepage)
    Lead platform developer of ickStream Music Platform - A world of music at your fingertips

    (Also developer of many plugins/applets)

  6. #16
    Senior Member bluetdi's Avatar
    Join Date
    Oct 2008
    Location
    Vienna
    Posts
    229
    I bought the lifetime license quite some time ago and it was worth every cent. Had so much fun making new clock styles, also Trackstat and Screen Switcher were really useful.
    Thank you for your work, Erland.
    Odroid U3+m2p+LMS | Pi3-7"+pCP+LMS | Transporter | 2x Touch | 2x Classic | 2x Boom | 2x Radio | iPeng

  7. #17
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    981
    Quote Originally Posted by erland View Post
    You select style for each configuration in Settings/Screen/Screensavers/Custom Clock Settings

    If you want customize a style or create your own you do this through Custom Clock Helper plugin in LMS, see more information here:
    http://wiki.slimdevices.com/index.ph...m_Clock_applet
    Maybe the problem is the clock styles are not downloading. How long should it take to fetch clock styles? I've been watching it for 5 minutes and still see "Fetching Clock Styles"

    Update. I found a thread from 6 years ago suggesting Custom Clock Helper was required. All working now.

    Sent from my SM-G900F using Tapatalk
    Last edited by slartibartfast; 2017-07-21 at 04:19.

  8. #18
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    2,547
    Thanks very much for all your work Erland - it's great that they are now compatible with LMS 7.9. I use your plugins many times every single day, and they make a big difference to how I access and play my music.
    LMS 7.9.1 on VortexBox Midi box, Xubuntu 17.04, FLACs 16->24 bit, 44.1->192kbps. Touch & EDO. 2nd Touch standard.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (to A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Alternatively Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 17.04 laptop firefox/upplay or Android 'phone with Squeeze-Commander/BubbleUPnP controls LMS/Minimserver.

  9. #19
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    2,547
    I recently re-installed the 'full text search' plugin, having updated Custom Browse etc yesterday (21st July). I've updated LMS to the latest I could find - Logitech Media Server Version: 7.9.1 - 1499900819 @ Thu Jul 13 04:20:16 UTC 2017.

    Using the LMS menu search function, the Advanced search works, but typing something into the initial search box never returns anything. I always get 'No search results'.

    I know there used to be a conflict with some of these plugins and "full text search', so I don't know if this behaviour is expected, or due to these latest plugin versions, or the 'full text search' plugin.
    LMS 7.9.1 on VortexBox Midi box, Xubuntu 17.04, FLACs 16->24 bit, 44.1->192kbps. Touch & EDO. 2nd Touch standard.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (to A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Alternatively Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 17.04 laptop firefox/upplay or Android 'phone with Squeeze-Commander/BubbleUPnP controls LMS/Minimserver.

  10. #20
    Same prob. If I disable the download of artist images while rescan in the artistinfo plugin it works.

    If download artist images is enabled while rescan no artist image is downloaded an rescan failed.
    2x Transporter, 4x Touch, 5x Radio, H/K Onyx (AirPlay-Bridge), Marantz Consolette (AirPlay-Bridge), iPhone 6 (iPeng), iMac-5k (SqueezePlay)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •