Home of the Squeezebox™ & Transporter® network music players.
Page 5 of 6 FirstFirst ... 3456 LastLast
Results 41 to 50 of 55
  1. #41
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    2,578
    Quote Originally Posted by Nojelc View Post
    Er thanks - but while I can manage to stop LMS, I do not have a clue how to do either of the other things. Can you supply a little more detail please?
    Well I know almost nothing about max2play and Docker either

    If LMS in the Docker is linux-based, then there should a directory called /var/lib/squeezeboxserver/cache. In there when LMS is stopped there should a file called cache.db, and a directory called DownloadedPlugins. Delete them if you can. This may require that you use sudo (i.e. "sudo rm cache.db" and "sudo rmdir DownloadedPlugins"). Hopefully that will just ask you for your normal linux password and it will work. If this doesn't work you may need to brush up on some linux skills, or maybe someone here will have more ideas. If your LMS is windows-based the two files will be the same, but the directory structure and permissions may well be different and it's too many years since I last mucked around with (and was mucked around by) Windows.
    LMS 7.9.1 on VortexBox Midi box, Xubuntu 17.10, FLACs 16->24 bit, 44.1->192kbps. Touch & EDO. 2nd Touch standard.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (to A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Alternatively Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 17.10 laptop firefox/upplay or Android 'phone with Squeeze-Commander/BubbleUPnP controls LMS/Minimserver.

  2. #42
    Senior Member
    Join Date
    Mar 2010
    Posts
    120
    Quote Originally Posted by Nojelc View Post
    Er thanks - but while I can manage to stop LMS, I do not have a clue how to do either of the other things. Can you supply a little more detail please?

    Edit : Plus this is a new/virgin copy of max2play on a PI, I would not have thought there was any detritus around that needed cleaning up. But happy to try anything to get this solved.
    n.b. I have installed other plugins i.e. iPlayer and Spoty without a problem, plus the fact that docterry is having the same problem with Erlands plugins as me would seem to indicate that this is a generic problem, not a problem with our specific systems.
    I was having the same problem. I needed to re-install SB and downloaded version 7.7 from logitech's site and then immediately upgraded to 7.9 When I tried install any of erlands plug-ins it would not install (similar response as other people have described). Installing other plug-ins worked fine. Then I decided to start from scratch (again) but this time download and install 7.7 only and then try installing erland's plug-ins. No problem! So, it looks to me that this issue popped up when trying to install his plug-ins with the latest 7.9 version. Anyone else get a different scenario?

  3. #43
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    2,578
    Quote Originally Posted by dbinder101 View Post
    I was having the same problem. I needed to re-install SB and downloaded version 7.7 from logitech's site and then immediately upgraded to 7.9 When I tried install any of erlands plug-ins it would not install (similar response as other people have described). Installing other plug-ins worked fine. Then I decided to start from scratch (again) but this time download and install 7.7 only and then try installing erland's plug-ins. No problem! So, it looks to me that this issue popped up when trying to install his plug-ins with the latest 7.9 version. Anyone else get a different scenario?
    As a matter of interest how long do you wait before restarting LMS? I vaguely recall people talking about the process needing a bit of time before the restart (this may, of course, be a false memory - I have quite a few of those...).

    You could also try adding this repo to the list at the bottom of the plugin page. I have it in my list - I don't remember why.

    "http://erland.github.io/squeezebox-downloads/repositories/latest.xml"
    LMS 7.9.1 on VortexBox Midi box, Xubuntu 17.10, FLACs 16->24 bit, 44.1->192kbps. Touch & EDO. 2nd Touch standard.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (to A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Alternatively Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 17.10 laptop firefox/upplay or Android 'phone with Squeeze-Commander/BubbleUPnP controls LMS/Minimserver.

  4. #44
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    2,578
    Have you tried including more logging? I'm not much good at that myself, but it might give a clue as to what is going wrong.

    Looking at the list of options (Settings, Advanced, Logging), network.repositories, plugin.extensions, server.plugins and so on may give some useful information. I'm sure others on this forum will know much more than I which are the right ones to pick. You will probably need to tick the box near the top to preserve the settings over a restart (many is the time I've forgotten to do that and wondered where the logs have gone),
    LMS 7.9.1 on VortexBox Midi box, Xubuntu 17.10, FLACs 16->24 bit, 44.1->192kbps. Touch & EDO. 2nd Touch standard.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (to A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Alternatively Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 17.10 laptop firefox/upplay or Android 'phone with Squeeze-Commander/BubbleUPnP controls LMS/Minimserver.

  5. #45
    Senior Member
    Join Date
    Dec 2007
    Posts
    126
    Quote Originally Posted by dbinder101 View Post
    No problem! So, it looks to me that this issue popped up when trying to install his plug-ins with the latest 7.9 version. Anyone else get a different scenario?
    So yes indeed. There we have it. I would say that has the problem isolated. But what can we do about it? Is there any way of manually loading these plugins? Well yes obviously - but any way for an average the techno-duffer like me to do it?

    I do not have the option of rolling back to 7.8, installing Custom Browse then going forward to 7.9 again. My version of Max2Play is not compatible with 7.8, the web interface warns me of this but I thought I would try and see if it would stand up long enough - I could not even open the web interface. So back on 7.9 now without Custom Browse boo-hoo.
    Last edited by Nojelc; 2017-11-01 at 15:02.

  6. #46
    Senior Member
    Join Date
    Dec 2007
    Posts
    126

    Yipee - cracked it!

    As the problem was first reported very recently it occurred to me that it must have been introduced recently too, and 7.9.0 has been around for a while. My max2play is happy with 7.9.0 so I tried that and yipee - it does implement Custom Browse OK.
    So if anyone else has this problem just go back to 7.9.0 and you should be OK. Phew!

  7. #47
    Senior Member erland's Avatar
    Join Date
    Dec 2005
    Location
    Sweden
    Posts
    11,014
    Quote Originally Posted by PasTim View Post
    You could also try adding this repo to the list at the bottom of the plugin page. I have it in my list - I don't remember why.

    "http://erland.github.io/squeezebox-downloads/repositories/latest.xml"
    The only reason to add this repository is if you want to get access to latest plugin versions immediately.
    This repository is included in LMS standard repository files, so if you accept to wait a few hours or a day until these have been updated you will get access to the latest plugin versions even if you haven't added my repository manually.
    Erland Isaksson (My homepage)
    Lead platform developer of ickStream Music Platform - A world of music at your fingertips

    (Also developer of many plugins/applets)

  8. #48
    Junior Member
    Join Date
    Oct 2014
    Posts
    11

    Confirm this post by Nojelc re: downgrading to v7.9.0

    Quote Originally Posted by Nojelc View Post
    As the problem was first reported very recently it occurred to me that it must have been introduced recently too, and 7.9.0 has been around for a while. My max2play is happy with 7.9.0 so I tried that and yipee - it does implement Custom Browse OK.
    So if anyone else has this problem just go back to 7.9.0 and you should be OK. Phew!
    I, too, was unable to get Custom Browse (or some other, but not all, Erland plugins) to load with version 7.9.1.x. I experienced the exact same behavior as posted in this thread and I emailed Erland about it a week ago. I also use Max2Play as the admin UI for my Raspberry Pi 2, which is designed, in case it's unknown, as a media platform that includes both LMS and SqueezeLite to create a contained media player running on the Raspberry Pi hardware. I personally have a Radio in my bedroom and a Classic in my livingroom connected via TOSLink cable to my AV receiver (I still *NEED* LOL my Maggies for my classical, jazz, and opera) as well as a HiFiBerry TOSlink capable RPi2 add-on board (which works quite well).

    I confirm Nojelc's reported behavior that down-grading Logitech Media Server Version: 7.9.1 - 1510044676 @ Tue Nov 7 15:33:55 UTC 2017 to Logitech Media Server Version: 7.9.0 - 1488878280 @ Wed Mar 8 14:18:44 UTC 2017 allows Custom Browse installation. So, something Michael changed in the SqueezeServer builds from last March has broken the ability to install Custom Browse. As I cannot live (Yes, cannot live :-) without Custom Browse and its "Genre Album" I will remain on v7.9.0 build 1488878280.

    I'm hoping that Erland and Michael have an opportunity to review what it may be that has compromised the install of Custom Browse. Or, perhaps I dare say, that the functionality of Custom Browse (or at the very least, from my perspective, the Genre Albums part) becomes a part of the standard SqueezeServer architecture. Frankly, I've never understood why the regular Genre Library view defaults to listing by Artist/Performer rather than Album. For folks with substantial classical libraries that really makes no sense as it often splits albums over multiple listings. And the Album view lists all albums in alphabetical order, and when one has nearly 3000 albums in some 30 genres, that, well, is useless as a method to find something. Custom Browse and its Genre Albums is *perfect*.

    And let me add my thanks to Erland for his LMS plugins. As other folks have said in this thread, I quickly opted to pay for the lifetime license in recognition of Erland's contribution the LMS community with his plugins. I'd do the same for Michael were it possible (sad that so many people do not understand that Michael is the SOLE developer of SqueezeServer -- take a look at the commit history and you can confirm this is true).

  9. #49
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,782

    Announce: Erlands commercial pluginsavailable for free

    > I, too, was unable to get Custom Browse (or some other, but not all,
    > Erland plugins) to load with version 7.9.1.x. I experienced the exact
    > same behavior as posted in this thread and I emailed Erland about it a
    > week ago.


    Found the culprit:
    https://github.com/Logitech/slimserv...34cbd9351e7b01

    I'll review that change. It seems to be some interaction between LMS and
    Erland's specific server configuration. I had that change running in my
    own systems for months before I merged it. Never encountered any issue...

    --

    Michael

  10. #50
    Senior Member erland's Avatar
    Join Date
    Dec 2005
    Location
    Sweden
    Posts
    11,014
    Quote Originally Posted by mherger View Post
    > I, too, was unable to get Custom Browse (or some other, but not all,
    > Erland plugins) to load with version 7.9.1.x. I experienced the exact
    > same behavior as posted in this thread and I emailed Erland about it a
    > week ago.


    Found the culprit:
    https://github.com/Logitech/slimserv...34cbd9351e7b01

    I'll review that change. It seems to be some interaction between LMS and
    Erland's specific server configuration. I had that change running in my
    own systems for months before I merged it. Never encountered any issue...

    --

    Michael
    Please let me know if I can do anything on my side to fix it.
    Erland Isaksson (My homepage)
    Lead platform developer of ickStream Music Platform - A world of music at your fingertips

    (Also developer of many plugins/applets)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •