Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Senior Member
    Join Date
    Jan 2008
    Posts
    352

    Problems with UPnP AGrundman plugin

    Hi,

    At some point as I have been updating the LMS version, the UPnP plugin has stopped working. I am currently running 7.9.1 - 1499358182 on Windows Server 2012R2.

    The library and the players never get offered, but from the server log it seems that the plugin fails becase it cannot fing Net/IPv4Addr.pm.

    Is this something I can fix?

    Code:
    [17-07-11 10:45:07.8847] Slim::Utils::PluginManager::load (393) Warning: Couldn't call Slim::Plugin::UPnP::Plugin->initPlugin: Can't locate Net/IPv4Addr.pm in @INC (@INC contains: C:\ProgramData\Squeezebox\Cache\InstalledPlugins C:\ProgramData\Squeezebox\Cache\InstalledPlugins\Plugins\SqueezeCloud\lib C:\ProgramData\Squeezebox\Cache\InstalledPlugins C:\PROGRA~2\SQUEEZ~1\server\Plugins\ShairTunes2W\lib C:\ProgramData\Squeezebox\Cache\InstalledPlugins\Plugins\ShairTunes2W\lib\5.14\MSWin32-x86-multi-thread C:\ProgramData\Squeezebox\Cache\InstalledPlugins\Plugins\ShairTunes2W\lib\5.14\MSWin32-x86-multi-thread\auto C:\ProgramData\Squeezebox\Cache\InstalledPlugins\Plugins\ShairTunes2W\lib C:\PROGRA~2\SQUEEZ~1\server\Plugins\MusicArtistInfo\lib C:\ProgramData\Squeezebox\Cache\InstalledPlugins\Plugins\MusicArtistInfo\lib C:\ProgramData\Squeezebox\Cache\InstalledPlugins\Plugins\MixCloud\lib C:\PROGRA~2\SQUEEZ~1\server\Plugins\Gallery C:\ProgramData\Squeezebox\Cache\InstalledPlugins\Plugins\Gallery C:\PROGRA~2\SQUEEZ~1\server\Plugins\Bandcamp\lib C:\ProgramData\Squeezebox\Cache\InstalledPlugins\Plugins\Bandcamp\lib C:\ProgramData\Squeezebox\Cache\InstalledPlugins\Plugins\BBCiPlayer\lib C:\ProgramData\Squeezebox\Cache\InstalledPlugins\Plugins\22tracks\lib C:\PROGRA~2\SQUEEZ~1\server\CPAN\arch\5.14\MSWin32-x86-multi-thread C:\PROGRA~2\SQUEEZ~1\server\CPAN\arch\5.14\MSWin32-x86-multi-thread\auto C:\PROGRA~2\SQUEEZ~1\server\CPAN\arch\5.14.1\MSWin32-x86-multi-thread C:\PROGRA~2\SQUEEZ~1\server\CPAN\arch\5.14.1\MSWin32-x86-multi-thread\auto C:\PROGRA~2\SQUEEZ~1\server\CPAN\arch\MSWin32-x86-multi-thread C:\PROGRA~2\SQUEEZ~1\server\CPAN\arch\5.14 C:\PROGRA~2\SQUEEZ~1\server\lib C:\PROGRA~2\SQUEEZ~1\server\CPAN C:/PROGRA~2/SQUEEZ~1/server C:\Users\streamer\AppData\Local\Temp\pdk-streamer-18620\ C:\PROGRA~2\SQUEEZ~1\server) at C:/PROGRA~2/SQUEEZ~1/server/Slim/Plugin/UPnP/Discovery.pm line 15.
    BEGIN failed--compilation aborted at C:/PROGRA~2/SQUEEZ~1/server/Slim/Plugin/UPnP/Discovery.pm line 15.
    Compilation failed in require at C:/PROGRA~2/SQUEEZ~1/server/Slim/Plugin/UPnP/Plugin.pm line 34.

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,781

    Problems with UPnP AGrundman plugin

    > The library and the players never get offered, but from the server log
    > it seems that the plugin fails becase it cannot fing Net/IPv4Addr.pm.


    I'm sorry about that. I thought I had fixed this a week ago. Turns out I
    forgot to push the change to github... I'll trigger new builds asap.

    --

    Michael

  3. #3
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,781

    Problems with UPnP AGrundman plugin

    > Is this something I can fix?

    New builds are up:
    http://downloads.slimdevices.com/nig...ex.php?ver=7.9 (build
    1499764307 or later).

    --

    Michael

  4. #4
    Senior Member
    Join Date
    Jan 2008
    Posts
    352
    Thanks. Works like a beauty again!

  5. #5
    Junior Member
    Join Date
    Aug 2017
    Posts
    1

    Same problem here...

    Quote Originally Posted by mherger View Post
    > Is this something I can fix?

    New builds are up:
    downloads.slimdevices.com/nightly/index.php?ver=7.9 (build 1499764307 or later).

    --

    Michael
    Hello Michael,

    I seem to have the exact same issue, but I have already installed LMSUpdate 7.9.1-1503129892 version on my Synology DS216play.

    Code:
    Slim::Utils::PluginManager::load (393) Warning: Couldn't call Slim::Plugin::UPnP::Plugin->initPlugin: Can't locate Net/IPv4Addr.pm in @INC (you may need to install the Net::IPv4Addr module) (@INC contains: /volume1/@appstore/SqueezeCenter/Cache/InstalledPlugins /volume1/@appstore/SqueezeCenter/CPAN/arch/5.24/arm-linux-gnueabi-thread-multi /volume1/@appstore/SqueezeCenter/CPAN/arch/5.24/arm-linux-gnueabi-thread-multi/auto /volume1/@appstore/SqueezeCenter/CPAN/arch/5.24.0/armle-linux /volume1/@appstore/SqueezeCenter/CPAN/arch/5.24.0/armle-linux/auto /volume1/@appstore/SqueezeCenter/CPAN/arch/5.24/armle-linux /volume1/@appstore/SqueezeCenter/CPAN/arch/5.24/armle-linux/auto /volume1/@appstore/SqueezeCenter/CPAN/arch/armle-linux /volume1/@appstore/SqueezeCenter/CPAN/arch/5.24 /volume1/@appstore/SqueezeCenter/lib /volume1/@appstore/SqueezeCenter/CPAN /volume1/@appstore/SqueezeCenter /volume1/@appstore/SqueezeCenter /usr/local/lib/perl5/site_perl /usr/local/share/perl5/site_perl /usr/local/lib/perl5/vendor_perl /usr/local/share/perl5/vendor_perl /usr/local/lib/perl5/core_perl /usr/local/share/perl5/core_perl .) at /volume1/@appstore/SqueezeCenter/Slim/Plugin/UPnP/Discovery.pm line 15.
    BEGIN failed--compilation aborted at /volume1/@appstore/SqueezeCenter/Slim/Plugin/UPnP/Discovery.pm line 15.
    Compilation failed in require at /volume1/@appstore/SqueezeCenter/Slim/Plugin/UPnP/Plugin.pm line 34.
    What do I need to do to solve this? Can you help me please?

    Thank you!
    Gerhard

  6. #6
    Junior Member
    Join Date
    Jul 2017
    Posts
    6

    LMS Repack last version (update) and same issue

    After update lmsrepack on ds215j synology i have this error

    [17-08-31 12:10:25.2798] Slim::Utils::PluginManager::load (393) Warning: Couldn't call Slim::Plugin::UPnP::Plugin->initPlugin: Can't locate Net/IPv4Addr.pm in @INC (you may need to install the Net::IPv4Addr module) (@INC contains: /volume1/@appstore/LmsRepack/Cache/InstalledPlugins/Plugins/TrackStatPlaylist/lib /volume1/@appstore/LmsRepack/Cache/InstalledPlugins/Plugins/TrackStat/lib /volume1/@appstore/LmsRepack/Cache/InstalledPlugins /volume1/@appstore/LmsRepack/Cache/InstalledPlugins/Plugins/SongLyrics/lib /volume1/@appstore/LmsRepack/Cache/InstalledPlugins/Plugins/SQLPlayList/lib /volume1/@appstore/LmsRepack/Plugins/RaopBridge/lib /volume1/@appstore/LmsRepack/Cache/InstalledPlugins/Plugins/RaopBridge/lib /volume1/@appstore/LmsRepack/Plugins/MusicArtistInfo/lib /volume1/@appstore/LmsRepack/Cache/InstalledPlugins/Plugins/MusicArtistInfo/lib /volume1/@appstore/LmsRepack/Cache/InstalledPlugins/Plugins/CustomScan/lib /volume1/@appstore/LmsRepack/CPAN/arch/5.24/arm-linux-gnueabi-thread-multi /volume1/@appstore/LmsRepack/CPAN/arch/5.24/arm-linux-gnueabi-thread-multi/auto /volume1/@appstore/LmsRepack/CPAN/arch/5.24.0/armle-linux /volume1/@appstore/LmsRepack/CPAN/arch/5.24.0/armle-linux/auto /volume1/@appstore/LmsRepack/CPAN/arch/5.24/armle-linux /volume1/@appstore/LmsRepack/CPAN/arch/5.24/armle-linux/auto /volume1/@appstore/LmsRepack/CPAN/arch/armle-linux /volume1/@appstore/LmsRepack/CPAN/arch/5.24 /volume1/@appstore/LmsRepack/lib /volume1/@appstore/LmsRepack/CPAN /volume1/@appstore/LmsRepack /usr/local/lib/perl5/site_perl /usr/local/share/perl5/site_perl /usr/local/lib/perl5/vendor_perl /usr/local/share/perl5/vendor_perl /usr/local/lib/perl5/core_perl /usr/local/share/perl5/core_perl .) at /volume1/@appstore/LmsRepack/Slim/Plugin/UPnP/Discovery.pm line 15.
    BEGIN failed--compilation aborted at /volume1/@appstore/LmsRepack/Slim/Plugin/UPnP/Discovery.pm line 15.


    I do not know if it's related but
    Spotify does not work since the update. It tells me that it can not open the file and it does not reproduce anything.

  7. #7
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,781
    Quote Originally Posted by competer View Post
    After update lmsrepack on ds215j synology i have this error

    [17-08-31 12:10:25.2798] Slim::Utils::PluginManager::load (393) Warning: Couldn't call Slim::Plugin::UPnP::Plugin->initPlugin: Can't locate Net/IPv4Addr.pm in @INC (you may need to install the Net::IPv4Addr module) (@INC contains: /volume1/@appstore/LmsRepack/Cache/InstalledPlugins/Plugins/TrackStatPlaylist/lib /volume1/@appstore/LmsRepack/Cache/InstalledPlugins/Plugins/TrackStat/lib /volume1/@appstore/LmsRepack/Cache/InstalledPlugins /volume1/@appstore/LmsRepack/Cache/InstalledPlugins/Plugins/SongLyrics/lib /volume1/@appstore/LmsRepack/Cache/InstalledPlugins/Plugins/SQLPlayList/lib /volume1/@appstore/LmsRepack/Plugins/RaopBridge/lib /volume1/@appstore/LmsRepack/Cache/InstalledPlugins/Plugins/RaopBridge/lib /volume1/@appstore/LmsRepack/Plugins/MusicArtistInfo/lib /volume1/@appstore/LmsRepack/Cache/InstalledPlugins/Plugins/MusicArtistInfo/lib /volume1/@appstore/LmsRepack/Cache/InstalledPlugins/Plugins/CustomScan/lib /volume1/@appstore/LmsRepack/CPAN/arch/5.24/arm-linux-gnueabi-thread-multi /volume1/@appstore/LmsRepack/CPAN/arch/5.24/arm-linux-gnueabi-thread-multi/auto /volume1/@appstore/LmsRepack/CPAN/arch/5.24.0/armle-linux /volume1/@appstore/LmsRepack/CPAN/arch/5.24.0/armle-linux/auto /volume1/@appstore/LmsRepack/CPAN/arch/5.24/armle-linux /volume1/@appstore/LmsRepack/CPAN/arch/5.24/armle-linux/auto /volume1/@appstore/LmsRepack/CPAN/arch/armle-linux /volume1/@appstore/LmsRepack/CPAN/arch/5.24 /volume1/@appstore/LmsRepack/lib /volume1/@appstore/LmsRepack/CPAN /volume1/@appstore/LmsRepack /usr/local/lib/perl5/site_perl /usr/local/share/perl5/site_perl /usr/local/lib/perl5/vendor_perl /usr/local/share/perl5/vendor_perl /usr/local/lib/perl5/core_perl /usr/local/share/perl5/core_perl .) at /volume1/@appstore/LmsRepack/Slim/Plugin/UPnP/Discovery.pm line 15.
    BEGIN failed--compilation aborted at /volume1/@appstore/LmsRepack/Slim/Plugin/UPnP/Discovery.pm line 15.


    I do not know if it's related but
    Spotify does not work since the update. It tells me that it can not open the file and it does not reproduce anything.
    I've opened a bug report for he missing Net::IPv4Addr issue (https://github.com/grofweg/LmsRepack/issues/2).

    There's another bug report for LMSRepack re. transcoding. That might cover your second issue.

    It's currently recommended to use LMSUpdate rather than LMSRepack (see related threads).
    Michael

    http://www.herger.net/slim-plugins - Spotty, MusicArtistInfo

  8. #8
    Senior Member pinkdot's Avatar
    Join Date
    Nov 2009
    Location
    The Netherlands
    Posts
    876
    Quote Originally Posted by GalaxyGe View Post
    Hello Michael,

    I seem to have the exact same issue, but I have already installed LMSUpdate 7.9.1-1503129892 version on my Synology DS216play.


    What do I need to do to solve this? Can you help me please?

    Thank you!
    Gerhard
    Package is updated to 7.9.1-1503129895 which should solve the issue.
    -LMS on Raspian Stretch -> 2x Radio
    -RPI 3 (Mopidy + Raspotify), Allo Boss DAC- Exposure 3010S2 - PMC FB1i

  9. #9
    should but didn't, at least with my DS..
    I was able to fix it like this: I looked for the IPv4Addr.pm file and found it in /volume1/@appstore/SqueezeCenter/CPAN/Network folder.
    copied it to the Net folder in CPAN and now UPnP is working.

    Sent from my E6653 using Tapatalk
    Server: LMS 7.9.1-166 Synology @ Sept 04 2017 on DS216Play. SOX mansr ARMv7 & C-3PO. Players: SB Radio, Freecom MusicPal. Multiroom HiFi: Denon AVR-X4000, AVM M30, Nubert NuLine/NuVero 5.1+2

  10. #10
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,781

    Problems with UPnP AGrundman plugin

    > should but didn't, at least with my DS..
    > I was able to fix it like this: I looked for the IPv4Addr.pm file and
    > found it in /volume1/@appstore/SqueezeCenter/CPAN/Network folder.
    > copied it to the Net folder in CPAN and now UPnP is working.


    This should be fixed in the latest LMSRepack/LMSUpdate packages for
    Synology.

    --

    Michael

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •