Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 20
  1. #1
    Senior Member
    Join Date
    May 2008
    Posts
    288

    Best place to download Squeezeplay?

    Can anyone recommend a version of Squeezeplay which works with Windows 10? I have an old beta version installed which often fails to refresh the "Now Playing" information, so was hoping that there was a version out there that has fixed this. I've tried downloading from the @Ralphy site, but it failed, saying that I needed authentication.
    ????

  2. #2
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    1,859
    This is the url to my current squeezeplay windows builds.

    https://sourceforge.net/projects/lms...eplay/windows/
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 1-UE Radio
    Squeezebox client builds donations always appreciated.

  3. #3
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    2,667
    Quote Originally Posted by ralphy View Post
    This is the url to my current squeezeplay windows builds.

    https://sourceforge.net/projects/lms...eplay/windows/
    I've tried the amd64 version for linux but it fails to run for one or more reasons on version 1006.

    1. The instructions say chmod on jive_alsa, but there's no such file - there is jive.
    2. When I run it it says it has an error loading libdirectfb-1.2.so:9 ... no such file. I seem to have version 1.7 on xubuntu 17.10.

    No matter, I'm happy to try and build myself, but where do I start? Where did the source come from?
    LMS 7.9.1 on VortexBox Midi box, Xubuntu 17.10, FLACs 16->24 bit, 44.1->192kbps. Touch & EDO. 2nd Touch standard.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (to A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Alternatively Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 17.10 laptop firefox/upplay or Android 'phone with Squeeze-Commander/BubbleUPnP controls LMS/Minimserver.

  4. #4
    Senior Member
    Join Date
    Aug 2012
    Location
    Austria
    Posts
    721
    Quote Originally Posted by PasTim View Post
    I've tried the amd64 version for linux but it fails to run for one or more reasons on version 1006.
    1. The instructions say chmod on jive_alsa, but there's no such file - there is jive.
    Probably because you are using the pulse audio version.

    2. When I run it it says it has an error loading libdirectfb-1.2.so:9 ... no such file. I seem to have version 1.7 on xubuntu 17.10.
    Use squeezeplay-7.8.0-984 amd64 instead

    No matter, I'm happy to try and build myself, but where do I start? Where did the source come from?
    github

  5. #5
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    2,667
    Quote Originally Posted by Roland0 View Post
    Probably because you are using the pulse audio version.


    Use squeezeplay-7.8.0-984 amd64 instead


    github
    Thanks.

    I managed to get the pulse version to work by downloading libdirectfb-1.2.so:9 (for ubuntu 16.04), and it runs, albeit using portaudio. I'll try the non-pulse version.

    I did find an older set of source files but there were a number of compilation failures beyond my ability to fix. I'll try ralphy's.
    LMS 7.9.1 on VortexBox Midi box, Xubuntu 17.10, FLACs 16->24 bit, 44.1->192kbps. Touch & EDO. 2nd Touch standard.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (to A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Alternatively Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 17.10 laptop firefox/upplay or Android 'phone with Squeeze-Commander/BubbleUPnP controls LMS/Minimserver.

  6. #6
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    2,667
    Quote Originally Posted by PasTim View Post
    Thanks.

    I managed to get the pulse version to work by downloading libdirectfb-1.2.so:9 (for ubuntu 16.04), and it runs, albeit using portaudio. I'll try the non-pulse version.

    I did find an older set of source files but there were a number of compilation failures beyond my ability to fix. I'll try ralphy's.
    I got the asla version running as well.

    I tried compiling Ralphy's from github but it complains that my CPU isn't 64 bit (it is). Strange, but of no concern now I have a running version.
    LMS 7.9.1 on VortexBox Midi box, Xubuntu 17.10, FLACs 16->24 bit, 44.1->192kbps. Touch & EDO. 2nd Touch standard.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (to A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Alternatively Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 17.10 laptop firefox/upplay or Android 'phone with Squeeze-Commander/BubbleUPnP controls LMS/Minimserver.

  7. #7
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    1,859
    Quote Originally Posted by PasTim View Post
    I got the asla version running as well.

    I tried compiling Ralphy's from github but it complains that my CPU isn't 64 bit (it is). Strange, but of no concern now I have a running version.
    Try changing -march=pentium4 to -march=core2 in Makefile.linux26. If that doesn't work, try removing the -march option completely.

    Also pull the latest changes from git as yesterday I fixed another issue compiling squeezeplay with newer versions of gcc.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 1-UE Radio
    Squeezebox client builds donations always appreciated.

  8. #8
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    2,667
    Quote Originally Posted by ralphy View Post
    Try changing -march=pentium4 to -march=core2 in Makefile.linux26. If that doesn't work, try removing the -march option completely.

    Also pull the latest changes from git as yesterday I fixed another issue compiling squeezeplay with newer versions of gcc.
    Thanks. I had to do the same to Makefile in zlib-1.2.7. I then had to add libtolua++5.1-dev, and assumed I should respond y to the 4 patch requests (is that correct?).

    But then after that I'm still missing the tolua++ command. tolua++5.1 does exist. I don't understand enough of the Makefile to know what to do about that - there's quite a bit of stuff about tolua++-1.0.92.

    Code:
    tolua++   -n jive -o src/ui/lua_jiveui.c src/ui/lua_jiveui.pkg
    /bin/bash: tolua++: command not found
    Makefile:1236: recipe for target 'src/ui/lua_jiveui.c' failed
    LMS 7.9.1 on VortexBox Midi box, Xubuntu 17.10, FLACs 16->24 bit, 44.1->192kbps. Touch & EDO. 2nd Touch standard.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (to A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Alternatively Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 17.10 laptop firefox/upplay or Android 'phone with Squeeze-Commander/BubbleUPnP controls LMS/Minimserver.

  9. #9
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    1,859
    Quote Originally Posted by PasTim View Post
    Thanks. I had to do the same to Makefile in zlib-1.2.7. I then had to add libtolua++5.1-dev, and assumed I should respond y to the 4 patch requests (is that correct?).

    But then after that I'm still missing the tolua++ command. tolua++5.1 does exist. I don't understand enough of the Makefile to know what to do about that - there's quite a bit of stuff about tolua++-1.0.92.

    Code:
    tolua++   -n jive -o src/ui/lua_jiveui.c src/ui/lua_jiveui.pkg
    /bin/bash: tolua++: command not found
    Makefile:1236: recipe for target 'src/ui/lua_jiveui.c' failed
    No you should not be asked about the patches and there should be no reason it should need to build tolua++ unless you changed src/squeezeplay/src/ui/lua_jiveui.c for some reason?

    I'd suggest cloning a completely new copy of the squeezeplay source and try the build again. That's likely the easiest way to get it working.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 1-UE Radio
    Squeezebox client builds donations always appreciated.

  10. #10
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    2,667
    Quote Originally Posted by ralphy View Post
    No you should not be asked about the patches and there should be no reason it should need to build tolua++ unless you changed src/squeezeplay/src/ui/lua_jiveui.c for some reason?

    I'd suggest cloning a completely new copy of the squeezeplay source and try the build again. That's likely the easiest way to get it working.
    Thanks. That worked cleanly with just the one pentium4 to core2 change in Makefile.linux26. I can only assume that repeated failed builds caused my previous problems.
    LMS 7.9.1 on VortexBox Midi box, Xubuntu 17.10, FLACs 16->24 bit, 44.1->192kbps. Touch & EDO. 2nd Touch standard.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (to A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Alternatively Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 17.10 laptop firefox/upplay or Android 'phone with Squeeze-Commander/BubbleUPnP controls LMS/Minimserver.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •