Home of the Squeezebox™ & Transporter® network music players.
Page 4 of 4 FirstFirst ... 234
Results 31 to 34 of 34
  1. #31
    Member
    Join Date
    Nov 2010
    Location
    Finland
    Posts
    43
    Quote Originally Posted by mherger View Post
    What interface? LMS' web UI?
    Yes. In the Squeezebox server (LMS) web interface.

  2. #32
    Quote Originally Posted by ascomm74 View Post
    Yes. In the Squeezebox server (LMS) web interface.
    I am trying Tidal for 30 days. Spotify has reached the end for me I think. It was a good run. It's way too much effort to keep it working. Tidal works right away.

    Sent from my SM-G925T using Tapatalk

  3. #33
    Junior Member
    Join Date
    Jun 2015
    Posts
    10
    Quote Originally Posted by mherger View Post
    > I still can't get the Spotify to show up on the interface.
    > Is there step-by-step guide available somewhere how to get Spotify (or
    > any other application) to visible in Squeezebox web interface from
    > mysqueezebox.com App Gallery?


    What interface? LMS' web UI?

    Please start your LMS with debugging enabled for network.squeezenetwork.
    Then post your server.log file.

    --

    Michael
    As I have the same 'spotify general transient error' error I started LMS with debug set as above, immediately got this message in server.log, presumably when I clicked 'Apply':

    [17-04-28 09:41:24.9428] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Networking::Async::HTTP::_http_read_body: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /usr/lib64/perl5/vendor_perl/Slim/Networking/IO/Select.pm line 134.

  4. #34
    Junior Member
    Join Date
    Apr 2017
    Posts
    4
    Quote Originally Posted by ascomm74 View Post
    I still can't get the Spotify to show up on the interface.
    Is there step-by-step guide available somewhere how to get Spotify (or any other application) to visible in Squeezebox web interface from mysqueezebox.com App Gallery?

    Should this "Player Settings" tab show something?

    Attachment 22601


    BTW: Spotify IS WORKING in my Squeezebox Classic 3 in it's own menu system, though.
    May be you are lucky if you follow my instructions below.

    if not already done, perform following steps on the LMS-Webinterface:
    uninstall the 3rd party spotify plugin from triode
    install the official spotify plugin
    install the spotify protocol handler
    enter your mysqueezebox account and password in the mysqueezebox.com tab of LMS settings

    then:

    go to https://mysqueezebox.com , log in, install spotify, enter your spotify credentials (account settings)
    log off
    go to http://mysqueezebox.com , log in, go to my apps, klick on spotify, klick on the button on the current account tab to authorize the mysqueezebox app in your spotify account
    on the popup-Window enter your spotify credentials and submit

    The authorization step did not work for me via https, so I entered and transmitted my mysqueezebox-password in clear text.
    if this was critical for you (like it was for me), go back to https://mysqueezebox.com and change your password.
    But if you changed your password, you have to re-enter it in LMS-Web interface. And this one has a bug: it just won't work!
    Until you remove the myqueezebox.com user name, save, restart LMS, enter your username and new password and save again.
    Restart LMS service. Then it should show up in the myapps tree of the webinterface or any other client
    Don't forget to enter your spotify credentials in the spotify protocol handler settings, also!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •