Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Mar 2017
    Posts
    1

    12v in on Touch :( can it be fixed?

    Plugged in the wrong 12v power supply for a few seconds...... looks dead, with the right 5v power supply i can see a red light in the optical out but nothing else, no screen, not showing up in server. Was loving my touch and the server so now looking at building a Raspberry Pi squeezebox replacement. Would just like to know if anything can be done with the touch before i go down that route.

    First post and all that take it easy on me, i have searched and found no answer, spoke to logitech too and no help there.

  2. #2
    Senior Member Stratmangler's Avatar
    Join Date
    Oct 2008
    Location
    Rossendale UK
    Posts
    501
    Es ist tot.
    Chris :)

  3. #3
    Senior Member
    Join Date
    Apr 2013
    Location
    UK
    Posts
    851
    I would say not much you can do other than replacing the entire innards, at which point you may as well bin it and get another.
    --
    Hardware: 3x Touch, 1x Radio, 2x Receivers, 1 HP Microserver NAS with Debian+LMS 7.9.0
    Music: ~1300 CDs, as 450 GB of 16/44k FLACs. No less than 3x 24/44k albums..

  4. #4
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    1,808
    Deader than a dead thing--chuck it in the recycle

  5. #5
    Senior Member
    Join Date
    Jul 2009
    Location
    USA
    Posts
    140
    You fried the internal power supplies. If you're going to toss it, I'll pay shipping and try to fix it. I hate to see good hardware that's not being made any more go to waste.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •