Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 3 123 LastLast
Results 1 to 10 of 24
  1. #1
    Junior Member
    Join Date
    Oct 2010
    Posts
    9

    Pandora stops playing after a couple songs

    I've had two Squeezebox Radios for about 6 years, and only use them to stream Pandora. About 3 or 4 months ago Pandora started randomly cutting off, usually in between songs, and sometimes after playing just one song. Nothing has changed in my house or with my internet provider. I have 50x5Mbps from Time Warner. I can work on a Amazon Web Services remote desktop all day with no problems, but Pandora can't seem to play more than a couple songs in a row (whether I'm on AWS or not). I even upgraded to Pandora Plus. According to the Radio, my wireless is 100%, but I've even plugged it into a network cable and switched it to Ethernet on the Radio to rule out the wireless. Both of my Radios have the same problem. I created a ticket with Pandora and they gave me some generic troubleshooting tips that I had already done, and told me that Squeezebox Radios are no longer officially supported by Pandora. BTW, my Radios connect to mysqueezebox.com and not to a LMS.

    Is anyone else having similar problems with Pandora? It's driving me nuts, and I'm considering having to buy a Grace Mondo, Sonos, or something else, but I absolutely love my Squeezebox Radio.

  2. #2
    Senior Member toby10's Avatar
    Join Date
    Jul 2007
    Location
    USA (home of the bottomless credit card)
    Posts
    9,097
    My Radio on MySB.com in US playing Pandora fine.

  3. #3
    Senior Member Mnyb's Avatar
    Join Date
    Feb 2006
    Location
    Vństerňs Sweden
    Posts
    16,163
    Actually try with LMS and set the player to proxied streamimg.

    Now nothing about pandora, it it helped other with flaky radio channels.

    But I'm on 100/100 fibre with an ISP that does no do traffic shaping or filtering of any sort .
    --------------------------------------------------------------------
    Main hifi: Touch + CIA PS +MeridianG68J MeridianHD621 MeridianG98DH 2 x MeridianDSP5200 MeridianDSP5200HC 2 xMeridianDSP3100 +Rel Stadium 3 sub.
    Bedroom/Office: Boom
    Kitchen: Touch + powered Fostex PM0.4
    Misc use: Radio (with battery)
    iPad1 with iPengHD & SqueezePad
    (spares Touch, SB3, reciever ,controller )
    server HP proliant micro server N36L with ClearOS Linux

    http://people.xiph.org/~xiphmont/demo/neil-young.html

  4. #4
    Senior Member toby10's Avatar
    Join Date
    Jul 2007
    Location
    USA (home of the bottomless credit card)
    Posts
    9,097
    Also try another station/service. A good one to use for testing is Linn radio. Radio > Internet Radio > Search > *linn*
    The first three on the search results are Linn 320k stations. Play one of those and see if there are any playback issues.

  5. #5
    Senior Member pippin's Avatar
    Join Date
    Oct 2007
    Location
    Berlin
    Posts
    14,185
    Pandora is not a radio station and has its own protocol handler in LMS/MySB
    ---
    learn more about iPeng, the iPhone and iPad remote for the Squeezebox and
    Logitech UE Smart Radio as well as iPeng Party, the free Party-App,
    at penguinlovesmusic.com
    New: iPeng 9, the Universal App for iPhone, iPad and Apple Watch

  6. #6
    Senior Member toby10's Avatar
    Join Date
    Jul 2007
    Location
    USA (home of the bottomless credit card)
    Posts
    9,097
    Yes, but if the issue is with his network or ISP (like bandwidth limiting/shaping/filtering) then streaming a 320k station would likely reveal that.

    Time Warner (his ISP) is going through some major changes nationally including even a name change. Whether these changes involve new streaming limitations or throttling I have no idea.

  7. #7
    Junior Member
    Join Date
    Feb 2017
    Posts
    3

    Pandora

    I have found the same issue within the past few weeks. I did a factory rest thinking someone changed a playback setting, did no good.

    Try this. Log in to the playerControl console and watch in-between songs.
    Name:  Capture.PNG
Views: 588
Size:  191.3 KB

    What I have noticed is that it appears a commercial attempts to play, but the device cannot play it so the station stops instead of continues to play. I can see the commercial trying to play in the remote control console but nothing appears on the actual device.

    My theory is that there are types of commercials that cannot be played on the squeezebox which is why it just stops.

    So a possible solution is to upgrade to a paid version of Pandora to determine if this will resolve the issue since I will no longer be having commercials or use another streaming application.

  8. #8
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,781

    Pandora stops playing after a couple songs

    > My theory is that there are types of commercials that cannot be played
    > on the squeezebox which is why it just stops.


    Now that's a great theory/finding! I'll have to double check with
    Pandora. Because for Pandora we are always expecting mp3. If they were
    to send AAC instead, this might indeed break playback.

    Thanks for your great first posting :-).

    --

    Michael

  9. #9
    Junior Member
    Join Date
    Oct 2010
    Posts
    9
    Just before the new year, I upgraded to Pandora Plus because I thought that might help. It has not helped. I brought my Squeezebox Radio to my office for a couple days. We have 100Mbps fiber and really good Wi-Fi. For better or worse, my Radio performed flawlessly at the office over both network and Wi-Fi. To troubleshoot my home further, I hard wired the Radio at my house and made sure I switched it to network instead of Wi-Fi on the Radio, and then from work, I setup a continuous ping to my cable modem at home. I didn't loose a single ping all day, but the music stopped a few times at home. I also used a website (can't find the exact one now) to ping the cable modem from various regions of the country. http://www.super-ping.com/ does this type of thing. From one region it dropped quite a few packets, but from others it was near flawless. Sometimes now I plug my iPad into the line-in on the Radio, and I can (over Wi-Fi on the iPad) stream Pandora all day long with no problems.
    I really don't know what to do from here. I feel like my problem is a combination of something in how the Radio streams Pandora versus how other devices (computers, iPad, etc.) do, and my internet connection. Google Fiber has been installing near my suburb and I'm probably only a couple months away from being hooked up with them, so that's what I'm holding out hope will finally resolve this issue for me.

  10. #10
    Junior Member
    Join Date
    Feb 2017
    Posts
    3
    Thank you for sharing PWB. I was going to try out a free trial of the paid subscription to see if my situation improves. (Will try to do this maybe over the weekend)

    Did you happen to notice when your playback stopped at home, was it randomly or at the end of a track that played fine the whole way though.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •