Home of the Squeezebox™ & Transporter® network music players.
Page 3 of 8 FirstFirst 12345 ... LastLast
Results 21 to 30 of 71
  1. #21
    Senior Member
    Join Date
    Mar 2014
    Posts
    210
    OK so I can delete this folder.

    Is it OK to clean the folder and send you again ?

  2. #22
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,800

    basic.html: not found

    I doubt it will make a difference for me: it's already been working here
    before. See my previous posting.

    --

    Michael

  3. #23
    Senior Member
    Join Date
    Mar 2014
    Posts
    210
    I have this error now, do you know what it mean ?

    [17-01-17 08:36:23.3367] Slim::Utils::Misc::msg (1244) Warning: [08:36:23.3365] Use of uninitialized value $ctime in string eq at /Template/Provider.pm line 885.
    [17-01-17 08:36:23.3368] Slim::Utils::Misc::msg (1244) Warning: [08:36:23.3367] Use of uninitialized value $ctime in concatenation (.) or string at /Template/Provider.pm line 886.
    [17-01-17 08:36:23.3370] Slim::Web::Template::SkinManager::_fillTemplate (337) Error: file error - invalid time:

  4. #24
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,800

    basic.html: not found

    >> [17-01-17 08:36:23.3367] Slim::Utils::Misc::msg (1244) Warning:
    >> [08:36:23.3365] Use of uninitialized value $ctime in string eq at
    >> /Template/Provider.pm line 885.
    >> [17-01-17 08:36:23.3368] Slim::Utils::Misc::msg (1244) Warning:
    >> [08:36:23.3367] Use of uninitialized value $ctime in concatenation (.)
    >> or string at /Template/Provider.pm line 886.
    >> [17-01-17 08:36:23.3370] Slim::Web::Template::SkinManager::_fillTemplate
    >> (337) Error: file error - invalid time:


    Aren't there related errors before or after these lines? Did you restart
    LMS after you removed the folder with templates?

    --

    Michael

  5. #25
    Senior Member
    Join Date
    Mar 2014
    Posts
    210
    Ok everything works well now, I delete the default folder.

    But it keeps going to add a menu to the web UI. If I delete the HTML folder, I no longer have the settings page for the plugin.

    How do I remove the menu entry but keep the setting page ?

  6. #26
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,800

    basic.html: not found

    > How do I remove the menu entry but keep the setting page ?

    No need to remove it. Just don't register it to start with ;-). Remove
    the Slim::Web::Pages->addPageLinks() call.


    --

    Michael

  7. #27
    Senior Member
    Join Date
    Mar 2014
    Posts
    210
    It works great ! Thanks !

  8. #28
    Senior Member
    Join Date
    Mar 2014
    Posts
    210
    I ask here because I don't want to open another post.

    - Is it possible to have a default value in an input and use it ?

    For example I have an input for the port of my software. Usually this port is 8888, so by default I want this value inside the input.

    But if the user change the port, he can write the new one in the input.

    - is it possible to make input "required" ? Or to write an error if the user don't fill the input ?

    Thanks

  9. #29
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,800

    basic.html: not found

    > In settings, is it possible to have a default value in input and use it
    > if the input is empty ?


    Yes, you can define default values in the init call:

    $prefs->init({ port => 888 });

    etc.

    See eg. Slim::Utils::Prefs

    https://github.com/Logitech/slimserv...Utils/Prefs.pm

    --

    Michael

  10. #30
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,800

    basic.html: not found

    > - is it possible to make input "required" ? Or to write an error if the
    > user don't fill the input ?


    That would be $prefs->setValidate(...)

    https://github.com/Logitech/slimserv...mespace.pm#L94

    --

    Michael

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •