Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 8 of 8
  1. #1
    Junior Member
    Join Date
    Jan 2017
    Posts
    3

    Can't start streaming on LMS with Spotify on Ubuntu

    I have a Duet with a receiver on wired ethernet. Installed Ubuntu linux and LMS. All works fine.

    I activated the new "Spotify protocoll handler plugin" and deactivated the Logitech "official" Spotify plugin.
    I have an active Spotify Premium account. I can see that the login process work in the status field in LMS.
    If I understand correctly, after restarting the LMS on the Ubuntu system, I should get a new Alternative "Spotify" in the LMS web interface.

    I dont get this menu into my LMS, so althoug LMS is connected to Spotify, I have no way of playing starting a stream.

    Any ideas?
    Is there a good guide somewhere? I have failed to find one...

  2. #2
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    2,069
    Quote Originally Posted by dboy View Post
    I have a Duet with a receiver on wired ethernet. Installed Ubuntu linux and LMS. All works fine.

    I activated the new "Spotify protocoll handler plugin" and deactivated the Logitech "official" Spotify plugin.
    I have an active Spotify Premium account. I can see that the login process work in the status field in LMS.
    If I understand correctly, after restarting the LMS on the Ubuntu system, I should get a new Alternative "Spotify" in the LMS web interface.

    I dont get this menu into my LMS, so althoug LMS is connected to Spotify, I have no way of playing starting a stream.

    Any ideas?
    Is there a good guide somewhere? I have failed to find one...
    You need the official Spotify plugin too.
    LMS 7.9 on a Raspberry Pi 3/piCorePlayer 3.20beta7, playlists and LMS cache on a USB stick, 25K+ music library on a WD MyCloud network drive,
    Rasberry Pi 2/piCorePlayer 3.02 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Raspberry Pi 3/piCorePlayer 3.20beta7/HiFiBerry DAC+ > Cambridge Audio Minx 5 (study)
    Rasberry Pi 2/piCorePlayer 3.02 > HiFiBerry DAC+ > Sharp micro system (garage)
    1 x Boom (dining room) - 1 x Touch (used for display and controller only) - 1 x SB3 (spare) - 1 x Radio (spare)

  3. #3
    Junior Member
    Join Date
    Jan 2017
    Posts
    3
    Yea, I tried that too, to no avail...
    I first tried with only the Spotify Control Handler, no show of an icon in LMS, then added the official plugin, but no change.
    Where should the menu icon for Spotify appear?

    Skickat frňn min D5803 via Tapatalk

  4. #4
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    2,069
    Quote Originally Posted by dboy View Post
    Yea, I tried that too, to no avail...
    I first tried with only the Spotify Control Handler, no show of an icon in LMS, then added the official plugin, but no change.
    Where should the menu icon for Spotify appear?

    Skickat frňn min D5803 via Tapatalk
    I don't use Spotify or mysqbox.com, so can't really help. Have you looked at Home > Radio > ?
    LMS 7.9 on a Raspberry Pi 3/piCorePlayer 3.20beta7, playlists and LMS cache on a USB stick, 25K+ music library on a WD MyCloud network drive,
    Rasberry Pi 2/piCorePlayer 3.02 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Raspberry Pi 3/piCorePlayer 3.20beta7/HiFiBerry DAC+ > Cambridge Audio Minx 5 (study)
    Rasberry Pi 2/piCorePlayer 3.02 > HiFiBerry DAC+ > Sharp micro system (garage)
    1 x Boom (dining room) - 1 x Touch (used for display and controller only) - 1 x SB3 (spare) - 1 x Radio (spare)

  5. #5
    Junior Member
    Join Date
    Jan 2017
    Posts
    3
    I think so but will double check.

    Skickat frňn min D5803 via Tapatalk

  6. #6
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    2,398
    1. Enable the official Spotify service at MySB.com with your Spotify credentials.
    2. Install and enable the Spotify protocol handler again with your credentials.

    Now the official Green icon should appear under My Apps. Launch Spotify from there. It should now work.
    Vortexbox LMS 7.9 music on QNAP TS419p via NFS iThingys/iPeng/Tablets
    Living Room - SB3 -> Onkyo TS606 - > Celestion Ditton F20s - Zone 2 -> Sony TA FE 320 -> Sennheiser RS 130 & B&W P7
    Office - RPi -> Sony TA FE320 -> Celestion F10s / SB3 -> Onkyo CRN 755 -> Wharfedale Modus Cubes
    Dining Room -> SB Boom Kitchen -> UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) - SB Touch -> Topping TP21 -> AKG Headphones Bedroom (TV) - Amazon Fire TV (SB Player) -> Topping TP20 -> Wharfedale Modus Cubes

  7. #7
    And you may need to disable Triode's plug-in. I'm not certain about that, buy my Spotify got all wonky a week or two ago and disabling Triode's plug-in plus the steps d6jg mentioned just above solved my issues.

  8. #8
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    2,398
    You don't need Triode's plugin any longer. The Spotify protocol handler does the playing and the official service provides the menu
    Vortexbox LMS 7.9 music on QNAP TS419p via NFS iThingys/iPeng/Tablets
    Living Room - SB3 -> Onkyo TS606 - > Celestion Ditton F20s - Zone 2 -> Sony TA FE 320 -> Sennheiser RS 130 & B&W P7
    Office - RPi -> Sony TA FE320 -> Celestion F10s / SB3 -> Onkyo CRN 755 -> Wharfedale Modus Cubes
    Dining Room -> SB Boom Kitchen -> UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) - SB Touch -> Topping TP21 -> AKG Headphones Bedroom (TV) - Amazon Fire TV (SB Player) -> Topping TP20 -> Wharfedale Modus Cubes

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •