Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Junior Member
    Join Date
    Dec 2009
    Posts
    9

    problem with non-Latin characters

    LMS and iPeng both are not displaying non-Latin characters correctly. I have LMS 7.9 on FreeBSd, which has UTF-8 installed, so it ought to be correct.

    My son SSHed into the service and discovered the following

    Your locale was detected as C, you may have problems with non-Latin filenames. Consider changing your LANG variable to the correct locale, i.e. en_US.utf8
    [16-12-27 14:04:28.7710] main::init (384) Starting Logitech Media Server (v7.9.0, TRUNK, UNKNOWN) perl 5.024001 - amd64-freebsd-thread-multi
    root@freebsd-server:/home/user # locale
    LANG=en_US.UTF-8
    LC_CTYPE="en_US.UTF-8"
    LC_COLLATE="en_US.UTF-8"
    LC_TIME="en_US.UTF-8"
    LC_NUMERIC="en_US.UTF-8"
    LC_MONETARY="en_US.UTF-8"
    LC_MESSAGES="en_US.UTF-8"
    LC_ALL=

  2. #2
    Junior Member
    Join Date
    Dec 2009
    Posts
    9

    re: problem with non-Latin characters

    Fixed already. My son found a post in another forum that gave a fix for this issue, changed a variable in LMS and now we're good. The post was at

    https://forums.freenas.org/index.php...er.7795/page-5

  3. #3
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,779

    problem with non-Latin characters

    > Fixed already. My son found a post in another forum that gave a fix for
    > this issue, changed a variable in LMS and now we're good. The post was
    > at


    Another (more elegant ;-)) solution would be to add --charset=utf8 to
    the set of startup options

    --

    Michael

  4. #4
    Junior Member
    Join Date
    May 2017
    Posts
    7

    -charset=utf8

    Quote Originally Posted by mherger View Post
    > Fixed already. My son found a post in another forum that gave a fix for
    > this issue, changed a variable in LMS and now we're good. The post was
    > at


    Another (more elegant ;-)) solution would be to add --charset=utf8 to
    the set of startup options

    --

    Michael
    How do you add --charset=utf8 to the set of startup options?

  5. #5
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,779
    Quote Originally Posted by mruano View Post
    How do you add --charset=utf8 to the set of startup options?
    This depends on your operating system.
    Michael

    http://www.herger.net/slim-plugins - Spotty, MusicArtistInfo

  6. #6
    Junior Member
    Join Date
    May 2017
    Posts
    7
    Quote Originally Posted by mherger View Post
    This depends on your operating system.
    I am running ARMBIAN 5.33 experimental Debian GNU/Linux 8 (jessie) 4.9.59-v7+ on a Raspberry PI 3

    Additional info:

    Logitech Media Server Version: 7.9.1 - 1508251793 @ Tue Oct 17 16:48:28 UTC 2017
    Operating system: Debian - EN - utf8
    Platform Architecture: armv7l-linux
    Perl Version: 5.20.2 - arm-linux-gnueabihf-thread-multi-64int
    Audio::Scan: 0.95
    Database Version: DBD::SQLite 1.34_01 (sqlite 3.7.7.1)


    Thanks in advance for your assistance.

    Miguel
    Last edited by mruano; 2017-10-31 at 09:09.

  7. #7
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,779

    problem with non-Latin characters

    > I am running ARMBIAN 5.33 experimental Debian GNU/Linux 8 (jessie)
    > 4.9.59-v7+ on a Raspberry PI 3


    You should have a /etc/defaults/logitechmediaserver file which defines a
    SLIMOPTIONS value. Add it in there.

    --

    Michael

  8. #8
    Junior Member
    Join Date
    May 2017
    Posts
    7

    --charset=utf8

    Quote Originally Posted by mherger View Post
    > I am running ARMBIAN 5.33 experimental Debian GNU/Linux 8 (jessie)
    > 4.9.59-v7+ on a Raspberry PI 3


    You should have a /etc/defaults/logitechmediaserver file which defines a
    SLIMOPTIONS value. Add it in there.

    --

    Michael
    Thanks, Michael

    Do I simply add it like this --charset=utf8 , with the two hyphens?

    Kind regards,

    Miguel

  9. #9
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,779
    Yes, that should be it.
    Michael

    http://www.herger.net/slim-plugins - Spotty, MusicArtistInfo

  10. #10
    Junior Member
    Join Date
    May 2017
    Posts
    7
    Quote Originally Posted by mherger View Post
    Yes, that should be it.
    Thanks again, Michael

    BTW, for other readers who may be reading this exchange, in my system the file is located in /etc/default/logitechmediaserver (not 'defaults' but 'default').

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •