Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1
    Junior Member
    Join Date
    Nov 2016
    Posts
    2

    Spotify playlists very slow to load

    Hi there,

    I am running LMS 7.9.0~1455395156 on Ubuntu with the Spotify Protocol Handler plugin and Triode Spotify plugin (version 2.3.9). It's been working fine for a while. However, a few weeks ago the playlists did not seem to load. After a bit of poking around I found that if you waited a couple of minutes, the playlists did eventually load although if you select to play them it doesn't seem to do anything.

    The Spotify connection is not broken in general because I can play Spotify radio stations.

    Here's a snippet from in /var/log/squeezeboxserver/spotifyd.log:

    [12:03:13.806074] main:619 req: playlists.json res: (null) par: (null) prot: HTTP/1.0 auth: (null)
    [12:03:13.806191] process_playlists:1155 process playlists: user
    [12:03:14.807521] process_playlists:1155 process playlists: user
    [12:03:15.808949] process_playlists:1155 process playlists: user
    [12:03:16.280675] process_playlists:1155 process playlists: user
    [12:03:17.282045] process_playlists:1155 process playlists: user
    [12:03:17.676830] process_playlists:1155 process playlists: user

    ...

    [12:03:43.880342] main:1739 timeout process_playlists
    [12:03:43.880505] process_playlists:1155 process playlists: user
    [12:03:43.884901] process_playlists:1249 bad playlist: 18 of 26 - unable to load

    I've also seen error messages of this form:

    [12:03:12.632896] log_message:81 log: 12:03:12.632 E [ap:4172] ChannelError(1, 1, playlist)
    [12:03:12.674954] log_message:81 log: 12:03:12.674 E [ap:4172] ChannelError(0, 0, playlist)


    I've also tried switching off Triode's plugin and using the Logitech plugin with the SPH and then I get an error about mysqueezebox.com not being setup, although I have entered my mysqueezebox.com username/password.

    I'd quite like to know a bit more about what the Spotify plugin is doing - I presume it's calling a web-services endpoint somewhere and then it's either not getting a timely response or it does get a timely response but does the wrong thing with it. Can I switch on more logging to see?

    Thanks,

    Peter

    Peter

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,803

    Spotify playlists very slow to load

    > I am running LMS 7.9.0~1455395156 on Ubuntu with the Spotify Protocol
    > Handler plugin and Triode Spotify plugin (version 2.3.9). It's been


    Don't use the SPH if you're using Triode's plugin. It's redundant in
    that case and wouldn't even initialize.

    > I've also tried switching off Triode's plugin and using the Logitech
    > plugin with the SPH and then I get an error about mysqueezebox.com not
    > being setup, although I have entered my mysqueezebox.com
    > username/password.


    Did you configure Spotify on mysqueezebox.com? You have to do this on
    the web site. Otherwise it won't work.

    --

    Michael

  3. #3
    Junior Member
    Join Date
    Nov 2016
    Posts
    2
    Quote Originally Posted by mherger View Post
    >
    Did you configure Spotify on mysqueezebox.com? You have to do this on
    the web site. Otherwise it won't work.
    That fixed it, thanks. And thanks for providing such great (free!) support for your software.

    By the way, I'm using Squeezer on Android devices and the Spotify search doesn't work. It looks like the UI doesn't know how to permit data entry and just queries with "{QUERY}". Nothing to do with you, of course, just thought I'd mention it in case anybody else had the same problem. You can search properly with the web client and I might shell out a few Euros for SqueezeCommander to see if the search works at some point.

    Peter

  4. #4
    Junior Member
    Join Date
    Nov 2006
    Posts
    10

    Playlists take very long to load - any ideas?

    I just started noticing this problem within the past 1-2 weeks or so. I'm pretty sure the plug-in has been at the same version for a while, but LMS gets updated weekly.
    I'm using the latest build of 7.9.0 on Ubuntu, and the Spotify plugin (with the Spotify Protocol Handler disabled, of course), and about after 30 seconds or longer, the playlists will display.
    I noticed these messages in the log file:

    [20:17:30.672918] process_playlists:1249 bad playlist: 0 of 89 - unable to load
    [20:18:36.511725] log_message:81 log: 01:18:36.511 E [ap:4172] ChannelError(0, 1, playlist)
    [20:19:08.443772] log_message:81 log: 01:19:08.443 E [ap:4172] ChannelError(0, 0, playlist)


    Helper App Location
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotify/Bin/i386-linux/spotifyd64

    Libspotify API
    12.1.51.g86c92b43 Release Linux-x86_64

  5. #5
    Senior Member
    Join Date
    May 2009
    Location
    Austin, Texas
    Posts
    122

    Are you using Triode's Plugin?

    I tried the regular Spotify plugin & the Protocol Handler and it loads faster.

    http://forums.slimdevices.com/showth...(Beta)/page613
    Last edited by Tex; 2017-01-19 at 19:55.
    (1) Pi 3 w/ HifiBerry Digi + Pro & piCorePlayer 3.22 LMS 7.9.1, (1) Touch, (1) Transporter, Samba w/ 2 TB USB Drive for files

  6. #6
    Junior Member
    Join Date
    Nov 2011
    Posts
    4
    I have the same issue with Triode.

    Does the regular spotify plugin handle multiple accounts? Right now we have three different spotify accounts on our Squeezeboxes (kids and grownups.. )

  7. #7
    Senior Member
    Join Date
    May 2009
    Location
    Austin, Texas
    Posts
    122

    Living on borroed time

    Hi Henrico

    You might read the other thread but it seems Spotify is losing interest in supporting Squeezebox. No the official app doesn't handle multiple accounts so you just have to suffer
    I recently was able to install Google Music which was good but I prefer Spotify, then there's Tidal... But to maintain your multiple accounts you need to stick with Triode's version.
    How long that will last...
    (1) Pi 3 w/ HifiBerry Digi + Pro & piCorePlayer 3.22 LMS 7.9.1, (1) Touch, (1) Transporter, Samba w/ 2 TB USB Drive for files

  8. #8
    Junior Member
    Join Date
    Nov 2006
    Posts
    10

    It is the Triode plugin

    Quote Originally Posted by Tex View Post
    I tried the regular Spotify plugin & the Protocol Handler and it loads faster.

    http://forums.slimdevices.com/showth...(Beta)/page613
    I'm not using the official Logitech plugin along with the protocol handler, because it doesn't work at all for me, since I have a Squeezebox 2.
    But thanks for the link to the other thread; I found plenty if information, and it looks like it is a recent problem that everyone is experiencing.
    Very likely a bug in a deprecated API, so also very likely to not get fixed. Not a problem at all -- I am not really a fan of Spotify, so it will be very easy for me to let go of it.

  9. #9
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,803

    Spotify playlists very slow to load

    > I'm not using the official Logitech plugin along with the protocol
    > handler, because it doesn't work at all for me, since I have a
    > Squeezebox 2.


    Well, that protocol handler was specifically built to allow Spotify
    playback on your old SB. That's its purpose.


    --

    Michael

  10. #10
    Junior Member
    Join Date
    Apr 2010
    Posts
    14

    Playlists were working for me but now I'm getting an error too

    As of last night the Triode app was working for me. Playlists loaded albeit slowly. After reading this post, I checked mysqueezebox.com and found oddly enough that my account wasn't enabled. I enabled it and now I get this meassage:

    Error reading headers: Server closed connection without sending any data back at /usr/share/squeezeboxserver/CPAN/Net/HTTP/Methods.pm line 306.
    ...propagated at /usr/share/squeezeboxserver/CPAN/Net/HTTP/NB.pm line 32.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •