Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 41 FirstFirst 123412 ... LastLast
Results 11 to 20 of 402
  1. #11
    Junior Member
    Join Date
    Nov 2009
    Posts
    22

    Player visible but not playing on Windows WHS v1 (HomeServer) machine

    Hi Philippe,

    after I had shor time success with an old version of the plugin but unfortunately the latest 0.36 and 0.35.3 (forked) Versions do not work for me on a Windows Home Server WHSv1 anymore. - In a former thread I had issues with constantly reconnection of players which was solved by port opening of port 3483.

    What ist the situation now:

    1. All players show up in Itunes or iOS devices
    2. After selection of one player one Itunes says it cannot connect after roughly 30 seconds and does not play
    3. The iOS devices do not show error messages but cannot play either
    4. If I switch the logging for the plugin from "errors" to "debugging" LMS does not seem to save this setting. The logfile does not show enhanced information and the drop-down box for the debugging setting in LMS switches automatically back to "errors".
    5. Re-installation of the plugin has happened and it is shown as active in the plugin tab of LMS settings
    6. The repository link to shairtunes from disaster123 war once in the LMS Settings but I have deleted it (so another shairtunes Version should not be installed)
    7. The plugin folder of LMS shows only one folder "ShairTunes2W" no other shairtunes folder
    8. The shairport_helper-win.exe is dated 10th Spetember 2016 in "C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\Squeezebox\Cache\InstalledPl ugins\Plugins\ShairTunes2W\Bin"
    9. I have the impression as the plugin does not start properly. So I ran the shairport_helper-win.exe manuelly with causes the message FATAL: Must supply AES key and IV!
    10. Please see below the extract from the logfile. I cannot get more out of it for shairtunes2 even when I fiddle around with Itunes or Ios devices.

    Code:
    [16-10-27 09:43:20.7503] main::init (384) Starting Logitech Media Server (v7.9.0, 1477086729, Thu Oct 27 04:06:00 CUT 2016) perl 5.014001 - MSWin32-x86-multi-thread
    [16-10-27 09:43:43.3992] Slim::Web::JSONRPC::requestMethod (443) 00:04:20:17:43:ec: request not dispatchable!
    [16-10-27 09:43:43.5941] Plugins::ShairTunes2W::Plugin::publishPlayer (299) avahi-publish-player not in path
    [16-10-27 09:43:43.5973] Plugins::ShairTunes2W::Plugin::publishPlayer (302) start dns-sd "Touch Living Room"
    [16-10-27 09:43:43.7318] Plugins::ShairTunes2W::Plugin::playerSubscriptionChange (210) create client Slim::Player::SqueezePlay=ARRAY(0x83b9624) with proc Proc::Background=HASH(0x854d12c)
    [16-10-27 09:43:54.3501] Plugins::ShairTunes2W::Plugin::publishPlayer (299) avahi-publish-player not in path
    [16-10-27 09:43:54.3530] Plugins::ShairTunes2W::Plugin::publishPlayer (302) start dns-sd "Radio Steffi"
    [16-10-27 09:43:54.3628] Plugins::ShairTunes2W::Plugin::playerSubscriptionChange (210) create client Slim::Player::SqueezePlay=ARRAY(0x83bd26c) with proc Proc::Background=HASH(0x8908f1c)
    [16-10-27 09:43:56.0955] Plugins::ShairTunes2W::Plugin::publishPlayer (299) avahi-publish-player not in path
    [16-10-27 09:43:56.0998] Plugins::ShairTunes2W::Plugin::publishPlayer (302) start dns-sd "Radio Bedroom"
    [16-10-27 09:43:56.1107] Plugins::ShairTunes2W::Plugin::playerSubscriptionChange (210) create client Slim::Player::SqueezePlay=ARRAY(0x855d4cc) with proc Proc::Background=HASH(0x83bcffc)
    [16-10-27 09:43:56.7004] Plugins::ShairTunes2W::Plugin::publishPlayer (299) avahi-publish-player not in path
    [16-10-27 09:43:56.7040] Plugins::ShairTunes2W::Plugin::publishPlayer (302) start dns-sd "Radio Bathroom"
    [16-10-27 09:43:56.7134] Plugins::ShairTunes2W::Plugin::playerSubscriptionChange (210) create client Slim::Player::SqueezePlay=ARRAY(0x854dde4) with proc Proc::Background=HASH(0x8448cbc)
    [16-10-27 09:43:59.2619] Plugins::ShairTunes2W::Plugin::publishPlayer (299) avahi-publish-player not in path
    [16-10-27 09:43:59.2656] Plugins::ShairTunes2W::Plugin::publishPlayer (302) start dns-sd "Squeezebox Office"
    [16-10-27 09:43:59.2820] Plugins::ShairTunes2W::Plugin::playerSubscriptionChange (210) create client Slim::Player::Receiver=ARRAY(0x856a134) with proc Proc::Background=HASH(0x8df55c4)
    [16-10-27 09:44:01.9584] Plugins::ShairTunes2W::Plugin::publishPlayer (299) avahi-publish-player not in path
    [16-10-27 09:44:01.9629] Plugins::ShairTunes2W::Plugin::publishPlayer (302) start dns-sd "Squeezebox Boom"
    [16-10-27 09:44:01.9852] Plugins::ShairTunes2W::Plugin::playerSubscriptionChange (210) create client Slim::Player::Boom=ARRAY(0x857bbac) with proc Proc::Background=HASH(0x8f91944)
    [16-10-27 09:56:09.7735] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Player::Source::__ANON__: illegal file descriptor or filehandle (either no attached file descriptor or illegal value):  at /<C:\Programme\Squeezebox\server\SqueezeSvr.exe>Slim/Networking/IO/Select.pm line 134.
    ; fh=Slim::Player::Protocols::HTTP=GLOB(0x91f3524)

    Does anyone have an Idea what might be wrong? Do I probably have to deinstall the plugin manually and reinstall via LMS interface? If yes, how to uninstall?

    Thanks and best regards,
    Ludwig
    Last edited by ludwig.xiv; 2016-10-29 at 00:46.

  2. #12
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    3,113
    Quote Originally Posted by ludwig.xiv View Post
    Hi Philippe,

    9. I have the impression as the plugin does not start properly. So I ran the shairport_helper-win.exe manuelly with causes the message FATAL: Must supply AES key and IV!
    10. Please see below the extract from the logfile. I cannot get more out of it for shairtunes2 even when I fiddle around with Itunes or Ios devices.

    Does anyone have an Idea what might be wrong? Do I probably have to deinstall the plugin manually and reinstall via LMS interface? If yes, how to uninstall?

    Thanks and best regards,
    Ludwig
    9. This helper is not intented to run independentely. The Perl part has to launch it with the correct parameters it gathers from the setup of the connection with the iXXX device
    10. the logfile should contain much more than that when you set it to info or debug mode. Have you set the LMS logging system so that it's persistent to reboot?

    Remember that the helper must be allowed in the Win10 firewall. I don't understand why opening port 3483 would have changed anything in the past, or there is something with your configuration that I need to understand. Can you desribe it precisely (LMS system, VM or not, # of network interfaces, a bit of topology ...)
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express

  3. #13

    Shariplay on WD MyCloud Ex4?

    EDIT: I've deleted my question as I'd failed to notice that this thread was only dealing with the Windows version - sorry for that.
    Martin
    Last edited by streampunk; 2016-11-04 at 10:11.

  4. #14
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    3,113
    Quote Originally Posted by streampunk View Post
    EDIT: I've deleted my question as I'd failed to notice that this thread was only dealing with the Windows version - sorry for that.
    Martin
    no, this thread does not deal with Windows only, but it deals with the version that I've forked that brings Windows compatibility, amongst other things
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express

  5. #15
    Thanks Philippe, seems I've got a little bit confused by the different threads.
    Well, so I'm right here with my little problem: I've been sucessfully running SqueezeCenter 1.3 for a couple of days on my WD MyCloud Ex4 NAS (Arm. However, when it comes to installing ShairTunes, I get errors:

    When using http://downloads.sourceforge.net/pro...44/repo-sf.xml as repo, "ShairTunes2 (fork)" gets available for selection. After selecting and saving, "ShairTunes2 (fork)" v.35.3 appears (unselected) in the "Updateted plugins available" section.
    After selecting/activating and saving again, it appears in the plugin list with the comment "plugin could not be loaded".

    Reading the instructions in the documentation:
    Code:
    To install the plugin first - then install the dependancies:
    Linux:
    > apt-get install libcrypt-openssl-rsa-perl libio-socket-inet6-perl libwww-perl avahi-utils libio-socket-ssl-perl
    > wget http://www.inf.udec.cl/~diegocaro/rpi/libnet-sdp-perl_0.07-1_all.deb
    > dpkg -i libnet-sdp-perl_0.07-1_all.deb
    I suspect that the reason are missing perl modules, but as the WD Linux ("castrated" Debian/Busybox) comes without apt and my Linux skills are still to weak to install either apt or the required perl files manually, I'm lost.

    Can anybody give me a hint how to proceed?

    System information:
    Code:
    Logitech Media Server Version: 7.7.2 - r33893 @ Wed Mar 14 06:37:22 MDT 2012
    Hostname: WDMyCloudEX4
    IP address of server: 192.168.xxx.xxx
    Server-HTTP-Portnumber: 9001
    OS: Linux - DE - utf8
    Architecture arm-linux
    Perl-Version: 5.10.0 - arm-linux
    Database version: DBD::SQLite 1.34_01 (sqlite 3.7.7.1)
    Thanks in advance & best regards
    Martin

  6. #16
    Senior Member
    Join Date
    Feb 2008
    Posts
    4,114
    Quote Originally Posted by streampunk View Post
    After selecting/activating and saving again, it appears in the plugin list with the comment "plugin could not be loaded".
    Martin
    Get the same message when I tried to install ....
    Touch, Logitech Radio, Logitech UE Radio, O2 Joggler + SqpOS
    UPnPBridge - 2 paired Sonos Play1 speakers; Rocki - Sony SRS-BTM8 speaker; Pioneer WX-SMA1 speaker; - PURE One Flow internet radio: PURE Jongo S3x ; Jongo T2; Libratone Zipp
    Castbridge - Chromecast 1 + Chromecast Audio
    AirplayBridge - Loewe Airspeaker
    SB Player - Fire TV
    ------------------------------------------------------------------------------------

  7. #17
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    3,113

    announce: ShairTunes2W - Airtunes on LMS (forked version with Windows support)

    My version does not require any extra installation, but I think the problem is different. I assume the WD is a power PC CPU, right? If this is the case, the issue is that I don't have built a PowerPC version of the helper program or the libraries, hence it refuses to load. There in and endianness difference that makes things difficult for me here
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express

  8. #18
    Senior Member
    Join Date
    Feb 2008
    Posts
    4,114
    Quote Originally Posted by philippe_44 View Post
    My version does not require any extra installation, but I think the roblem is different. I assume the WD is a power PC CPU, right? If this is the case, the issue is that I don't have built a PowerPC version of the helper program or the libraries, hence it refuses to load
    So, must be same issue for me.

    Debian
    Platform Architecture: i686-linux

    on Jogggler ‎1.3GHz Intel Atom Z520
    Touch, Logitech Radio, Logitech UE Radio, O2 Joggler + SqpOS
    UPnPBridge - 2 paired Sonos Play1 speakers; Rocki - Sony SRS-BTM8 speaker; Pioneer WX-SMA1 speaker; - PURE One Flow internet radio: PURE Jongo S3x ; Jongo T2; Libratone Zipp
    Castbridge - Chromecast 1 + Chromecast Audio
    AirplayBridge - Loewe Airspeaker
    SB Player - Fire TV
    ------------------------------------------------------------------------------------

  9. #19
    Quote Originally Posted by philippe_44 View Post
    I assume the WD is a power PC CPU, right?
    Google says it's got Marvell Kirkwood 88F6282A1 @ 2.0 GHz (single-core) as CPU
    Regards
    Martin

  10. #20
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    3,113

    announce: ShairTunes2W - Airtunes on LMS (forked version with Windows support)

    So should be a different problem then. The plugin is quite large, did you wait a few minutes between installation and restart of lms? If not, then you have a corrupted partial download in the cache directory that you must manually delete. Set as well info or debug log in LMS for the plugin loader piece and post here what you see


    EnvoyÚ de mon iPad en utilisant Tapatalk
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •