Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 18 12311 ... LastLast
Results 1 to 10 of 175
  1. #1
    Senior Member wt0's Avatar
    Join Date
    Jul 2008
    Posts
    560

    Annouce: Squeeze Control is now available as a UWP app for Windows 10.

    Squeeze Control is now a Universal Windows Platform (UWP) app for Windows 10.

    This is also the support thread for this app, but only for the UWP version. For questions about the previous version, go here: http://forums.slimdevices.com/showth...indows-Phone-8


    This was developed with both the phone and the desktop mind. On the desktop, mouse control is fully supported and to a certain extent keyboard controls too.

    There are no device type restrictions on the package and so should work on all Windows 10 devices where apps can be used. I've marked it in the Windows Store as being available to all existing device types including "Holographic" devices (the HoloLens I guess*), the Xbox One and any future device types that Microsoft deems compatible.

    This version has all the same features as the existing Windows Phone 8 version except that it can no longer run under the lockscreen or change the lockscreen picture (API no longer allows it). It also includes some tweaks to bring it closer to parity with the Android version.

    There are two significant changes:

    First, the header and footer control bars of the previous version have now switched places. This is how I wanted the Windows Phone 8 version to look, but wasn't able to do so due to limitations of that platform.

    Second, song downloading is now more flexible. Not only can you select the download folder, but the entire download queue can run completely in the background without the app being open.



    *I don't have a HoloLens, so if anyone tries this on one, I would love to hear about it.
    Last edited by wt0; 2016-10-09 at 19:12.
    --------------
    Squeezebox apps for webOS, Android and Windows Phone, http://www.angrygoatapps.com

  2. #2
    Senior Member
    Join Date
    Jul 2005
    Posts
    294
    Just downloaded the trial to my desktop PC (the same PC running the server, in case that matters). The app finds the server, but just won't connect. I get the "Connecting..." message and associated spinner, endlessly.

    Love the app on Android, and looking forward to trying it out on my desktop as an alternative to Jivelite.

  3. #3

  4. #4
    Senior Member
    Join Date
    Jan 2008
    Posts
    344
    Looks nice!

    I will play around with it and come up with some comments. For the moment, I have a few ideas that would make my life easier.

    * there should be a way to clear the whole playlist for a player instead of track by track
    * a simpler way to sync/desync players in the player menu rather than goon through the LMS menus
    * ability to surface submenus in the server main menu and rearrange them independently of the LMS. For example I would like to be able to access my BBC Radio Live Non-UK right on the main menu or using some shortcut button
    * a playlist/cover/menu screen for Windows that are wide enough (eg my 4K screen)

    But looking great!

  5. #5
    Senior Member wt0's Avatar
    Join Date
    Jul 2008
    Posts
    560
    Quote Originally Posted by bwaldron View Post
    Just downloaded the trial to my desktop PC (the same PC running the server, in case that matters). The app finds the server, but just won't connect. I get the "Connecting..." message and associated spinner, endlessly.

    Love the app on Android, and looking forward to trying it out on my desktop as an alternative to Jivelite.
    Can you try manually specifying a server? I just want to see if it's the server discovery that's causing a problem.

    Sent from my Nexus 5 using Tapatalk
    --------------
    Squeezebox apps for webOS, Android and Windows Phone, http://www.angrygoatapps.com

  6. #6
    Senior Member
    Join Date
    Jul 2005
    Posts
    294
    Quote Originally Posted by wt0 View Post
    Can you try manually specifying a server? I just want to see if it's the server discovery that's causing a problem.

    Sent from my Nexus 5 using Tapatalk
    Same problem either way.

  7. #7
    Senior Member wt0's Avatar
    Join Date
    Jul 2008
    Posts
    560
    Quote Originally Posted by bwaldron View Post
    Same problem either way.
    Disconnecting then connecting doesn't help? Also after you disconnect make sure you have selected the newly specified server. Like the Android app it always tries to connect to the lasted used server first.

    Sent from my Nexus 5 using Tapatalk
    --------------
    Squeezebox apps for webOS, Android and Windows Phone, http://www.angrygoatapps.com

  8. #8
    Senior Member
    Join Date
    Apr 2007
    Location
    Northampton, UK
    Posts
    196
    This doesn't run on my W10 'puter - just presents a red window for about 1 second before disappearing.
    Living room: SB Touch, with coax to: Marantz PM7005, TDL RTL3 speakers.
    Dining room: SB Boom.
    Kitchen: SB Radio (1/3), with battery.
    Bedroom 1: SB Radio (2/3), no battery.
    Bedroom 2: SB3 (1/2), AE 2.1. speakers.
    Bedroom 3: Slim Devices SB3 (2/2), Edirol MA-15D powered monitors.
    Bathroom: SB Radio (3/3) (in white), with (and running on) battery.
    Server: LMS v7.9.0 on WSE 2012 R2, HP Proliant Gen8 G1610T, 2.3GHz, 8GB.

  9. #9
    Senior Member
    Join Date
    Jul 2005
    Posts
    294
    Quote Originally Posted by wt0 View Post
    Disconnecting then connecting doesn't help? Also after you disconnect make sure you have selected the newly specified server. Like the Android app it always tries to connect to the lasted used server first.
    No, doesn't help. I can connect to mysqueezebox, but I don't use that.

    I'm down to one Windows machine at the moment, so I can't test from a different PC as I would usually do.

  10. #10
    Senior Member wt0's Avatar
    Join Date
    Jul 2008
    Posts
    560
    Quote Originally Posted by Furry View Post
    This doesn't run on my W10 'puter - just presents a red window for about 1 second before disappearing.
    It might be something to do with the trial mode, let me check to see what's wrong.
    --------------
    Squeezebox apps for webOS, Android and Windows Phone, http://www.angrygoatapps.com

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •