Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 16 FirstFirst 123412 ... LastLast
Results 11 to 20 of 157
  1. #11
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    2,968
    Quote Originally Posted by clausmuus View Post
    OK, I have found the solution:
    Code:
    echo -e "playlist play youtube:VIDEO_ID\nexit" | nc localhost 9090
    Claus
    I've also added another protocolhander to play a YT playlist or channel if you know their id:
    Code:
    ytplaylist://[channelId | playlistId]=[id]
    (without the [] of course)
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express

  2. #12
    Junior Member
    Join Date
    Mar 2006
    Posts
    13

    Woooohoo!!

    Thank you!!!!!

  3. #13
    Junior Member
    Join Date
    Jul 2016
    Posts
    3
    I've added both repositories, but I actually don't see the youtube plugin in any of them. Has it been removed?

  4. #14
    Junior Member
    Join Date
    Jul 2016
    Posts
    3
    I unchecked "Update plugins automatically" and now I see it at the top under 'Updated plugins available". However when I check the box to enable it and restart it never gets enabled. There are some errors in the log file:

    Code:
    [16-07-30 19:29:22.2399] main::init (384) Starting Logitech Media Server (v7.9.0, 1453144861, Mon Jan 18 19:29:24 UTC 2016) perl 5.010000
    [16-07-30 19:29:22.4301] Slim::Utils::PluginDownloader::extract (102) error loading Archive::Zip Compress::Raw::Zlib object version 2.021 does not match bootstrap parameter 2.033 at /share/MD0_DATA/.qpkg/LogitechMediaServer/var/home/SqueezeboxServer/CPAN/arch/5.10/Compress/Raw/Zlib.pm line 98.
    Compilation failed in require at /share/MD0_DATA/.qpkg/LogitechMediaServer/var/home/SqueezeboxServer/CPAN/Archive/Zip.pm line 11.
    BEGIN failed--compilation aborted at /share/MD0_DATA/.qpkg/LogitechMediaServer/var/home/SqueezeboxServer/CPAN/Archive/Zip.pm line 11.
    Compilation failed in require at /share/MD0_DATA/.qpkg/LogitechMediaServer/var/home/SqueezeboxServer/Slim/Utils/PluginDownloader.pm line 98.
    [16-07-30 19:29:48.4572] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [16-07-30 19:29:51.7749] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [16-07-30 19:29:51.7892] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    A version mismatch on the Zlib CPAN module somewhere. Not quite sure what the correct resolution is though.

  5. #15
    Junior Member
    Join Date
    Jul 2016
    Posts
    3
    I moved /share/MD0_DATA/.qpkg/LogitechMediaServer/var/home/SqueezeboxServer/CPAN/arch/5.10/Compress/Raw/Zlib.pm out of the way and it now works *shrug*

  6. #16
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    2,968

    up

    up
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express

  7. #17
    Junior Member
    Join Date
    May 2014
    Posts
    18
    Thanks Philippe for working on this and pointing me to this updated thread, and your suggestion about the api key.

    I checked and the key I was using seemed to be correct, but I went ahead and created another one following the steps at the start of this thread (apart from enabling it, as it was already enabled - I only had the option to disable it.)

    It still is not working for me.

    It seems that whatever video I try to stream I get the message:
    "Problem: Can't connect to server for: "name of video"

    This is what I see in my logs:
    [16-09-03 23:48:16.1572] main::init (368) Starting Logitech Media Server (v7.8.1, 1401187905, Fri May 30 03:03:20 UTC 2014) perl 5.014002
    [16-09-03 23:54:07.8026] Slim::Utils::Timers::__ANON__ (273) Error: Timer Slim::Web::Cometd::sendResponse failed:
    [16-09-03 23:57:27.8781] Slim::Player::Song:: open (471) Warning: stream failed to open [youtube://www.youtube.com/v/vj63BiNL4ik].
    [16-09-03 23:58:37.5410] Slim::Utils::Timers::__ANON__ (273) Error: Timer Slim::Web::Cometd::sendResponse failed: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /usr/share/perl5/Slim/Networking/IO/Select.pm line 150.
    [16-09-04 00:01:39.5087] Slim::Player::Song:: open (471) Warning: stream failed to open [youtube://www.youtube.com/v/vj63BiNL4ik].
    [16-09-04 00:11:19.8383] Slim::Player::Song:: open (471) Warning: stream failed to open [youtube://xTmIq9xZwks].
    [16-09-04 00:12:06.9735] Slim::Player::Song:: open (471) Warning: stream failed to open [youtube://OB4MsmL2q1A].

    I tried running apt-get install libio-socket-ssl-perl libnet-ssleay-perl
    But it didn't install anything new as I already had it.

    Any ideas what I'm doing wrong and how I can get it working?

    I'm running LMS 7.8.1 with perl 5.014002 on an oldish Raspberry Pi running Squeezplug.

    Thanks.

  8. #18
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    2,968

    ANNOUNCE: YouTube Plugin (API v3)

    You can try to see what's going wrong with SSL and Perl associated part ... or move to a recent version of picoreplayer that will likely work out of the box -or- have you updated max2play to its latest version?
    Last edited by philippe_44; 2016-09-04 at 06:02.
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express

  9. #19
    Have installed the latest plugin and entered the API key. However, all the search boxes return Empty? If I choose recently played this works and plays the audio through my SBT. What am I doing wrong with the search choices?

  10. #20
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    2,968
    Quote Originally Posted by theadmans View Post
    Have installed the latest plugin and entered the API key. However, all the search boxes return Empty? If I choose recently played this works and plays the audio through my SBT. What am I doing wrong with the search choices?
    Can you say precisely how you do your search and give an example of a search? Only webm files are supported, so in case a video is not encoded in that format, it can be played
    Last edited by philippe_44; 2016-09-26 at 21:10.
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •