Home of the Squeezebox™ & Transporter® network music players.
Page 26 of 26 FirstFirst ... 16242526
Results 251 to 252 of 252
  1. #251
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    3,482
    Quote Originally Posted by philippe_44 View Post
    I can have a look, but a little bit of a hint from @pippin would be helpful - if you read this thread

    [edit]: It seems to me that iPeng, when pressed 'play' on a track, puts the whole album in the playlist. I have to look further, but that's likely the problem as there is no notion of "whole album" there. It seems that there is an empty search made (maybe because the album is empty) in which case the YT API returns "whatever" on an empty query and then you have that funny result. Maybe iPeng queries LMS for the whole album associated to a track, then put that as a playlist and tells LMS to play track N where N was the index of the initial track
    This is corrected with version 0.63.0 but this is a workaround for an LMS issue that is corrected in the 7.9.1 nightly of 2018/01/11. Helps as well solving a similar issue with Spotty
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5

  2. #252
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    3,482
    Quote Originally Posted by torob View Post
    Hi and thank you for a great plugin.

    But after upgrade to 0.62 it stopped working. It says "Plugin failed to load" under list over active plugins.

    The log shows a lot of these error messages:

    [18-01-11 12:09:09.6621] Slim::Control::Request::execute (1888) Error: While trying to run function coderef [Slim::Control::Queries::statusQuery]: [Can't locate object method "_pluginDataFor" via package "Plugins::YouTube::Plugin" at /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/YouTube/ProtocolHandler.pm line 605.]
    [18-01-11 12:09:09.6638] Slim::Web::JSONRPC::requestMethod (424) Request failed with error: Bad dispatch!

    I'm using a Raspberry Pi 3 running OSMC. OSMC was updated yesterday to latest version using Debian Stretch. After that Logitech Media Server 7.9.0 refuses to start. Tried reinstall, but same issue. Installed latest nightly, 7.9.1 - 1515516449, and then everything was working perfectly again. Including this plugin. But then I got notified that a new version of the plugin has been installed, and a restart of LMS was needed. I restarted, but then the Youtube plugin would not start anymore.

    Perl Version, if relevant, is: 5.24.1 - arm-linux-gnueabihf-thread-multi-64int

    Any idea how to fix this? I don't know if it's related to the upgrade of OSMC and LMS, since it was working before the plugin was updated.
    Should be solved with 0.63.0
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •