Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 6 123 ... LastLast
Results 1 to 10 of 59
  1. #1

    Announce: Google Music plugin

    [Note: I'm aware that there is already a thread on this, but the first reply is that there isn't a Google Music plugin and never will be, so I'm creating a new thread; also coincides with the fixed version I've just released]

    Hey all,

    I've fixed the search and API version issues in a new fork; details and instructions at:
    https://squeezebox-googlemusic.githu...x-googlemusic/

    I've set this up as a github team, in the interests of preventing further fragmentation when I inevitably stop being able to provide time to support this. If you're interested in helping develop and maintain this, let me know. There are a couple of extra features I want to add, and re-vamp the UI, so any suggestions would be welcome (please add them to the Issues page: https://github.com/squeezebox-google...lemusic/issues)

    Enjoy!

  2. #2
    Member srasher's Avatar
    Join Date
    Jun 2006
    Location
    Bochum, Germany
    Posts
    80
    Thanks, thanks, thanks, thanks, thanks!!!

    Although it (the "old" version of the plugin) works for me (in most cases), I had quite a lot of force and back with login issues or having to re-install after LMS upgrades and so so, so I am extremely happy to read that someone took over the development/maintenance work from hechtus (who unfortunately doesn't seem to have the time to support this).

    I would be extremely happy to help actively but my coding skills and/or insight into the related API stuff is very limited.

    (Again) Thanks a lot anyway, will be a happy user of this!

    Cheers,
    Seb
    "The only word I know is 'Grunt' - and I can't spell it" (R.I.P. D.A.)

  3. #3
    latest update now lets you browse radio genres

  4. #4
    Senior Member
    Join Date
    Feb 2010
    Posts
    336
    Thanks for this...I tried to have a go on a Synology system and no luck. Got pip installed but Google apiece install threw up an error 1 message when it came to :
    unable to execute '/usr/local/arm-unknown-linux-gnueabi/bin/arm-unknown-linux-gnueabi-ccache-gcc': No such file or directory
    unable to execute '/usr/local/arm-unknown-linux-gnueabi/bin/arm-unknown-linux-gnueabi-ccache-gcc': No such file or directory

    No working compiler found, or bogus compiler options
    passed to the compiler from Python's distutils module.
    See the error messages above.
    (If they are about -mno-fused-madd and you are on OS/X 10.8,

    Then the next stage (debien/redhat?? Versions didn't work)

    Think I'm in overt my head without the time to work this out right now...I'll be back though :-)

  5. #5
    Quote Originally Posted by Giza2020 View Post
    Thanks for this...I tried to have a go on a Synology system and no luck. Got pip installed but Google apiece install threw up an error 1 message when it came to :
    unable to execute '/usr/local/arm-unknown-linux-gnueabi/bin/arm-unknown-linux-gnueabi-ccache-gcc': No such file or directory
    unable to execute '/usr/local/arm-unknown-linux-gnueabi/bin/arm-unknown-linux-gnueabi-ccache-gcc': No such file or directory

    No working compiler found, or bogus compiler options
    passed to the compiler from Python's distutils module.
    See the error messages above.
    (If they are about -mno-fused-madd and you are on OS/X 10.8,

    Then the next stage (debien/redhat?? Versions didn't work)

    Think I'm in overt my head without the time to work this out right now...I'll be back though :-)
    No idea about synology systems; looks like your system doesn't have a compiler installed. No idea how to fix that. What stage did you get up to? You'd need to find out how to install software packages on it.

  6. #6
    Junior Member
    Join Date
    Jul 2016
    Posts
    2
    I get the following error when attempting to add the repo:

    Code:
    Bad repository - Redirection limit exceeded

    Any ideas?

  7. #7
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,760

    Announce: Google Music plugin

    > Any ideas?

    With the little information you give I'm going to guess you are running
    LMS on a NAS, and that NAS doesn't have the libraries and/or Perl
    modules required to connect to an SSL protected resource.

    If that's wrong, then you might want to give us some information about
    your system, your server.log file etc.

    --

    Michael

  8. #8
    Hi
    Whats the main difference between this and the 0.4.2 plugin? The fixes mentioned in the first post and that this plugin will be more maintained?
    Can you implement the LastMix functionality by Mherger?

  9. #9
    Any news regarding LastMix?

  10. #10
    Junior Member
    Join Date
    Jul 2016
    Posts
    2
    Quote Originally Posted by mherger View Post
    > Any ideas?

    With the little information you give I'm going to guess you are running
    LMS on a NAS, and that NAS doesn't have the libraries and/or Perl
    modules required to connect to an SSL protected resource.

    If that's wrong, then you might want to give us some information about
    your system, your server.log file etc.

    --

    Michael

    It's just a straight ubuntu install, no NAS or anything special.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •