Home of the Squeezebox™ & Transporter® network music players.
Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 40
  1. #21
    Junior Member
    Join Date
    Sep 2014
    Posts
    10

    Adding title to existing Playlist doesn't work

    Hi,

    I installed two of the Triode Family plugins and they are playing music wonderfully. But when I try to add the current title to an existing Spotify List, I get an error: "Error reading headers: Server closed connection without sending any data back at /usr/share/ ...".

    Log-entry:
    [21:24:16.347569] main:619 req: playlists.json res: (null) par: (null) prot: HTTP/1.0 auth: (null)
    [21:24:16.347958] process_playlists:1155 process playlists: user
    [21:24:16.369160] main:619 req: playlistedit.json res: spotify:user:fblulaylist:3Mty7UfNV8FttXk3S4mATq par: a=add_track&u=spotifyfamily1:track:0f5N14nB8xi0p3o 4BlVvbx prot: HTTP/1.0 auth: (null)
    [21:24:16.369559] main:1557 playlist edit bad params

    I just confirmed that it still works with Triodes original plugin.

    Any suggestions what I can do, or if this is a bug?

    Thanks for your efforts,

    fblu

  2. #22
    Junior Member
    Join Date
    Sep 2014
    Posts
    10

    Adding title to existing Spotify Playlist doesn't work

    Anyone with an idea about this?

  3. #23
    Junior Member
    Join Date
    Nov 2016
    Posts
    4

    multiple restarts necessary + Library not syncing

    Quote Originally Posted by RichieZed View Post
    Update 12/7/2016: SqueezeFamily now available on Linux, Windows and Mac

    ****************************

    Spotify has recently improved the value of the Family Plan. This was fantastic news in our house, but wouldn't provide the full benefit until everybody could access their own account through their SqueezeBox.

    I'm a long time use of the wonderful Triode Plugin, and have extended this to enable six concurrent Spotify streams.

    This is currently Linux only, and has only been tested on i386, but should work on arm processors also (Which should cover most NAS boxes) I'm planning on releasing Windows and Mac version in the next few days.

    All credit to Triode for his work on the original plugin and other contributions to the community over the years. Thanks also to Mika Fisher for showing that side by side plugins were possible and for showing the way.

    First post, so will post the links in the next post.
    For you information: I tried to install multiple spotify accounts for family in one go, and squeeze center (QNAP NAS) kept asking me to restart. It seems that for each spotify account I added the system had to be restarted one or more times. Just so you're aware. In the end I got it working. I am only using 2 accounts at the moment though.

    A question I have: does anyone know why the Library doesn't get synced with Artists, Albums etc. automatically. It seems there is no connection / relation between the Spotify Library and the one in Squeezecenter. Any insights are appreciated.

    have a nice day!

  4. #24
    Junior Member
    Join Date
    Jan 2017
    Posts
    2

    Rename plugin

    Quote Originally Posted by arrikhan View Post
    No more Tay Tay on my Spotify history ! ....and fixes my sync'ing using spotify also.

    Great work Zed.. !

    Would be good if the SpotifyFamily1/2/3.. names could take the name of the logged in spotify user in the sqzbox menu auto-magically.


    Arrikhan
    Hi,

    Not automatic but you can edit the first entry in strings.txt (located in /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/SpotifyFamily<n>, n is 1,2,3,4...) on the LMS server to get the display name that you want.

  5. #25
    Junior Member
    Join Date
    Jan 2017
    Posts
    2

    Slow playlist retrieval

    Hi,

    I noticed that when the playlist "Discover Weekly" (generated by Spotify) is included among my playlists the playlist retrieval on the Squeezebox is very slow, seem to be timing out after 30s.
    Playlists/contents of individual playlists are still displayed, but with a delay of 30 s.
    After removing the "Discover Weekly" list it works as normal, takes a couple of seconds to get playlists.

  6. #26
    Quote Originally Posted by AndJohn69 View Post
    Hi,

    I noticed that when the playlist "Discover Weekly" (generated by Spotify) is included among my playlists the playlist retrieval on the Squeezebox is very slow, seem to be timing out after 30s.
    Playlists/contents of individual playlists are still displayed, but with a delay of 30 s.
    After removing the "Discover Weekly" list it works as normal, takes a couple of seconds to get playlists.
    Sorted mine too!

  7. #27
    Senior Member
    Join Date
    May 2009
    Location
    Austin, Texas
    Posts
    122

    Thanks

    Play lists now load in less than 2 seconds!
    (1) Pi 3 w/ HifiBerry Digi + Pro & piCorePlayer 3.22 LMS 7.9.1, (1) Touch, (1) Transporter, Samba w/ 2 TB USB Drive for files

  8. #28
    Senior Member
    Join Date
    Dec 2009
    Location
    Hilden, Germany
    Posts
    121
    Hi,

    i would like to use your Plugin on my FreeNAS (FreeBSD). At the moment the helper-app is not starting. I am using an Intel Processor but i think there are other problems. What port is meant to be open for the helper? I don't understand the german info...

  9. #29
    Senior Member
    Join Date
    May 2009
    Location
    Austin, Texas
    Posts
    122

    Typically

    when the helper app doesn't start I can fix it by reinstalling the plugin. It should be port 9005 by default.
    (1) Pi 3 w/ HifiBerry Digi + Pro & piCorePlayer 3.22 LMS 7.9.1, (1) Touch, (1) Transporter, Samba w/ 2 TB USB Drive for files

  10. #30
    Senior Member
    Join Date
    Dec 2009
    Location
    Hilden, Germany
    Posts
    121
    i tried to reinstall it more than once.. but its still not running. Port is open.

    What else can i do?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •