Home of the Squeezebox™ & Transporter® network music players.
Page 19 of 20 FirstFirst ... 917181920 LastLast
Results 181 to 190 of 191
  1. #181
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,781
    Quote Originally Posted by nodez View Post
    I turned on all the relevant logging, read the log files, read the source and tried to understand what your plugin does. I also inserted an additional "Data:: Dump::dump($feed)" at Lastmix/Services.pm:158 and think I might have found the point where it fails for me: the answer from http://www.mysqueezebox.com/api/spotify/v1/opml/search... seems to be always "No search results found".
    Now that's interesting: over the past few days I tried to understand an issue where I saw tons of undefined errors on the Spotify API. Many of them were related to searches. Did you double-check your Spotify configuration is correct and all set up? Can you use the Spotify search and play tracks through the Spotify menus?

    An alternative might be trying to use my Spotty plugin instead of the official Spotify implementation. The latter will go away within the next few months anyway :-(.

    http://forums.slimdevices.com/showthread.php?107418

    It's in much better shape than the subject line might make you think :-). I'm probably soon going to make it 1.0.
    Michael

    http://www.herger.net/slim-plugins - Spotty, MusicArtistInfo

  2. #182
    Junior Member
    Join Date
    May 2014
    Posts
    6
    Quote Originally Posted by mherger View Post
    Now that's interesting: over the past few days I tried to understand an issue where I saw tons of undefined errors on the Spotify API. Many of them were related to searches. Did you double-check your Spotify configuration is correct and all set up? Can you use the Spotify search and play tracks through the Spotify menus?
    I feel stupid

    I, again, reinstalled the Spotify app and connected it to my account and now it seems to work! The Spotify search works and also Lastmix gives me what I want.

    Is there anybody maintaining the mysqueezebox api? Maybe they had problems?

    An alternative might be trying to use my Spotty plugin instead of the official Spotify implementation. The latter will go away within the next few months anyway :-(.
    I'll try that for sure, sooner or later. But first I need to enjoy all that last.fm suggestions for a while ;-)

    Thanks a lot!

  3. #183
    Senior Member Pascal Hibon's Avatar
    Join Date
    Oct 2006
    Location
    Belgium
    Posts
    1,509
    Hi Michael,

    I'm preparing a complete streamer system for a friend of mine. The system includes a ReadyNAS 314 NAS which is running LMS. I installed LMS from the apps tab in the ReadyNAS config pages. I think this is not the latest version of LMS because it says: Logitech Media Server Version: 7.9.0 - TRUNK @ UNKNOWN.

    I don't find the Don't Stop The Music plugin in the plugin page. Is there a way to install this plugin "manually"?
    Also, is it possible to upgrade LMS to the latest version on a ReadyNAS 314?

    Thank you for your assistance.
    Cambridge Audio 851D-S -> Focal MP1200 -> Focal Electra 1028 Be
    1 x SB Boom, 1 x SB Radio, 1 x SB Touch and 2 x RPI 2B
    1 x SB3 and 1 x SB Touch in storage
    ReadyNAS NVX running LMS 7.9.0.
    iPeng on iPhone, SqueezePad & iPeng on iPad.
    http://www.last.fm/user/phibon

  4. #184
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,781
    Quote Originally Posted by Pascal Hibon View Post
    I don't find the Don't Stop The Music plugin in the plugin page. Is there a way to install this plugin "manually"?
    Also, is it possible to upgrade LMS to the latest version on a ReadyNAS 314?
    This certainly is possible. The question is: how to do it. And it's a question the ReadyNAS community most likely has a better answer for. Is it using one of the popular package formats?
    Michael

    http://www.herger.net/slim-plugins - Spotty, MusicArtistInfo

  5. #185
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,781

    New in 7.9: "Don't Stop The Music"

    > My Don't Stop the Music Parameter of "Spotty Recommendations (based on
    > the current playlist)"
    > keeps getting unchecked by itself every week or so..... Seems to be
    > happening after switching to Spotty from Spotify Pluggins.


    This has been reported before: the setting wouldn't survive a restart.
    But we've never been able to track the issue down. Are you running the
    latest and greatest 7.9.1? You should, as it comes with a fix for the
    "Spotify playlist on presets button doesn't play" issue.

    --

    Michael

  6. #186

    Error with File/Copy.pm

    Hi there, I am running LMS 7.9.1 without any issues. Just this morning when I updated What's that tune plugin and LMS could not start. When I start it with --d_startup I got the following error:
    [17-08-21 19:16:58.2854] main::changeEffectiveUserAndGroup (1005) Warning: Logitech Media Server must not be run as root! Trying user squeezeboxserver instead.
    Loaded module: [DBD::SQLite] ok!
    [17-08-21 19:16:58.7589] Slim::Schema::throw_exception (302) Error: Can't locate File/Copy.pm: /share/MD0_DATA/homes/janus/lms-perl-5.24/lib/site_perl/5.24.1/i686-linux/File/Copy.pm: Permission denied at /share/MD0_DATA/.qpkg/Optware/lms-7.9.1/CPAN/DBIx/Class/Storage/DBI/SQLite.pm line 10.
    BEGIN failed--compilation aborted at /share/MD0_DATA/.qpkg/Optware/lms-7.9.1/CPAN/DBIx/Class/Storage/DBI/SQLite.pm line 10.
    Compilation failed in require at (eval 720) line 2.
    BEGIN failed--compilation aborted at (eval 720) line 2.
    BEGIN failed--compilation aborted at /share/MD0_DATA/.qpkg/Optware/lms-7.9.1/Slim/Schema/Storage.pm line 26.
    Compilation failed in require at /share/MD0_DATA/.qpkg/Optware/lms-7.9.1/CPAN/Class/C3/Componentised.pm line 128.
    [17-08-21 19:16:58.7599] Slim::Schema::throw_exception (302) Backtrace:

    frame 0: Slim::Utils::Log::logBacktrace (/share/MD0_DATA/.qpkg/Optware/lms-7.9.1/Slim/Schema.pm line 302)
    frame 1: Slim::Schema::throw_exception (/share/MD0_DATA/.qpkg/Optware/lms-7.9.1/CPAN/Class/C3/Componentised.pm line 131)
    frame 2: Class::C3::Componentised::ensure_class_loaded (/share/MD0_DATA/.qpkg/Optware/lms-7.9.1/lib/DBIx/Class/Schema.pm line 817)
    frame 3: (eval) (/share/MD0_DATA/.qpkg/Optware/lms-7.9.1/lib/DBIx/Class/Schema.pm line 817)
    frame 4: DBIx::Class::Schema::connection (/share/MD0_DATA/.qpkg/Optware/lms-7.9.1/Slim/Schema.pm line 283)
    frame 5: Slim::Schema::_connect (/share/MD0_DATA/.qpkg/Optware/lms-7.9.1/Slim/Schema.pm line 130)
    frame 6: Slim::Schema::init (./slimserver.pl line 553)
    frame 7: main::init (./slimserver.pl line 676)
    frame 8: main::main (./slimserver.pl line 1214)

    [17-08-21 19:16:58.7608] DBIx::Class::Schema::connection (821) Warning: Can't locate object method "new" via package "Slim::Schema::Storage" at /share/MD0_DATA/.qpkg/Optware/lms-7.9.1/lib/DBIx/Class/Schema.pm line 821.

    I have checked and File/Copy.pm is in the folder mentioned in the error message. I have chmod 777 for File/Copy but i still get the error. Please help me to resolve this issue. Thank you very much.

    Janus.

  7. #187
    Quote Originally Posted by janus View Post
    Hi there, I am running LMS 7.9.1 without any issues. Just this morning when I updated What's that tune plugin and LMS could not start. When I start it with --d_startup I got the following error:
    [17-08-21 19:16:58.2854] main::changeEffectiveUserAndGroup (1005) Warning: Logitech Media Server must not be run as root! Trying user squeezeboxserver instead.
    Loaded module: [DBD::SQLite] ok!
    [17-08-21 19:16:58.7589] Slim::Schema::throw_exception (302) Error: Can't locate File/Copy.pm: /share/MD0_DATA/homes/janus/lms-perl-5.24/lib/site_perl/5.24.1/i686-linux/File/Copy.pm: Permission denied at /share/MD0_DATA/.qpkg/Optware/lms-7.9.1/CPAN/DBIx/Class/Storage/DBI/SQLite.pm line 10.
    BEGIN failed--compilation aborted at /share/MD0_DATA/.qpkg/Optware/lms-7.9.1/CPAN/DBIx/Class/Storage/DBI/SQLite.pm line 10.
    Compilation failed in require at (eval 720) line 2.
    BEGIN failed--compilation aborted at (eval 720) line 2.
    BEGIN failed--compilation aborted at /share/MD0_DATA/.qpkg/Optware/lms-7.9.1/Slim/Schema/Storage.pm line 26.
    Compilation failed in require at /share/MD0_DATA/.qpkg/Optware/lms-7.9.1/CPAN/Class/C3/Componentised.pm line 128.
    [17-08-21 19:16:58.7599] Slim::Schema::throw_exception (302) Backtrace:

    frame 0: Slim::Utils::Log::logBacktrace (/share/MD0_DATA/.qpkg/Optware/lms-7.9.1/Slim/Schema.pm line 302)
    frame 1: Slim::Schema::throw_exception (/share/MD0_DATA/.qpkg/Optware/lms-7.9.1/CPAN/Class/C3/Componentised.pm line 131)
    frame 2: Class::C3::Componentised::ensure_class_loaded (/share/MD0_DATA/.qpkg/Optware/lms-7.9.1/lib/DBIx/Class/Schema.pm line 817)
    frame 3: (eval) (/share/MD0_DATA/.qpkg/Optware/lms-7.9.1/lib/DBIx/Class/Schema.pm line 817)
    frame 4: DBIx::Class::Schema::connection (/share/MD0_DATA/.qpkg/Optware/lms-7.9.1/Slim/Schema.pm line 283)
    frame 5: Slim::Schema::_connect (/share/MD0_DATA/.qpkg/Optware/lms-7.9.1/Slim/Schema.pm line 130)
    frame 6: Slim::Schema::init (./slimserver.pl line 553)
    frame 7: main::init (./slimserver.pl line 676)
    frame 8: main::main (./slimserver.pl line 1214)

    [17-08-21 19:16:58.7608] DBIx::Class::Schema::connection (821) Warning: Can't locate object method "new" via package "Slim::Schema::Storage" at /share/MD0_DATA/.qpkg/Optware/lms-7.9.1/lib/DBIx/Class/Schema.pm line 821.

    I have checked and File/Copy.pm is in the folder mentioned in the error message. I have chmod 777 for File/Copy but i still get the error. Please help me to resolve this issue. Thank you very much.

    Janus.
    I have resolved the issue by installing ssods4 and then upgraded to version 7.9.1. With a workaround for SSL on qnap I followed the instructions here: http://forums.slimdevices.com/showth...l=1#post810751

    Now I have 7.9.1 with Spotty running without any issues! Thank you Michael for the great plugin!!

    Janus.
    Last edited by janus; 2017-08-25 at 07:29.

  8. #188
    Well after spending way too much time trying to get this to work, it should be said that you have to disable the REPEAT toggle on the player for this to work.

    Hopefully this will save others some time in case they do the same stupid oversight.

    PS I wanted to update to the latest nightly for awhile now so that I could take advantage of the seeking in Spotify tracks

    Cheers

  9. #189
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,781

    New in 7.9: "Don't Stop The Music"

    > Well after spending way too much time trying to get this to work, it
    > should be said that you have to disable the REPEAT toggle on the player
    > for this to work.


    Thanks for the heads up. I thought I had taken care of this. But will
    double-check.

    --

    Michael

  10. #190
    Senior Member DavidBulluss's Avatar
    Join Date
    May 2013
    Location
    ADELAIDE, AUSTRALIA
    Posts
    246
    Hi, am having a problem getting MusicIP plugin to work with DSTM. When I first set it up a month or so ago it worked, but since then it will not provide mixes, I just get the default random mix from my library. I have checked settings in LMS and DSTM is configured correctly for each player, and MusicIP is set to 'Import all song data'. On restart of LMS pCP provides a server log and there is one line in it relating to MIP "[17-11-16 09:08:17.6189] Slim::Plugin::MusicMagic::Plugin::initPlugin (155) Can't connect to port 10002 - MusicIP disabled."

    I do not understand the relevance of the connect to port 10002, especially when the settings info in MIP states " Enter the port number here to match the setting you have chosen in MusicIP Mixer settings."

    What am I doing wrong?

    Cheers, David
    Server pi3 pCP LMS
    Media ReadyNAS DuoV2
    Lounge/dining areas SBT > Denon AVR2113 > Bose Acoustimass10 / Krix Seismix3 18" 300w RMS custom cinema sub (& AR 77XB turntable, Stanton 680MkII / Grado F-1+ > NAD7155 to phono pre-amp > Amp etc)
    Family/kitchen SBT > Denon AVRX3000 zone 1 > Krix Acoustix F, Centrix C, Holographix R & Original Seismix 7 15" 400w RMS sub
    Alfresco as above zone 2 > Krix Tropix
    Others SB Player/androids > Bose Soundlink Mini
    SBT/SB Player Remotes Squeeze Ctrl/androids

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •