Home of the Squeezebox™ & Transporter® network music players.
Page 58 of 60 FirstFirst ... 8485657585960 LastLast
Results 571 to 580 of 595
  1. #571
    Senior Member
    Join Date
    Apr 2008
    Location
    Paris, France
    Posts
    2,005
    Quote Originally Posted by philippe_44 View Post
    I've tried to reproduce that with 2 AirPlay devices in sync but did not succeed.
    It seems to be sensitive to track change, and I was able to reproduce the bug quite quickly:
    - Using the web interface only
    - Start raopbridge, wait for players
    - 2 players are synced, both wifi (strong signal): Loop and Zipp. Power on/off, volume change are not synched
    - Set players to normal volume (30 - 40)
    - Make a playlist of a single album (was FLAC, FWIW), hit start and hear both players at normal volume
    - Select player Zipp in the web interface, in order to see the volume control
    - Skip to next song within 2 - 10 seconds until Zipp's volume slider drops to 0
    - Power off Zipp
    - Stop raopbrdige, copy the log.

    And here it is. Only 15k lines, 120 kB compressed. raopbridge.log.gz
    3 SB 3 • Libratone Loop, Zipp Mini • iPeng (iPhone + iPad) • LMS 7.9 (linux) with plugins: CD Player, WaveInput, Triode's BBC iPlayer by bpa • IRBlaster by Gwendesign (Felix) • Server Power Control by Gordon Harris • Smart Mix, Music Walk With Me, What Was That Tune? by Michael Herger • PowerSave by Jason Holtzapple • Song Info, Song Lyrics by Erland Isaksson • AirPlay Bridge by philippe_44 • WeatherTime by Martin Rehfeld • Auto Dim Display, SaverSwitcher, ContextMenu by Peter Watkins.

  2. #572
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    2,981
    Quote Originally Posted by epoch1970 View Post
    It seems to be sensitive to track change, and I was able to reproduce the bug quite quickly:
    - Using the web interface only
    - Start raopbridge, wait for players
    - 2 players are synced, both wifi (strong signal): Loop and Zipp. Power on/off, volume change are not synched
    - Set players to normal volume (30 - 40)
    - Make a playlist of a single album (was FLAC, FWIW), hit start and hear both players at normal volume
    - Select player Zipp in the web interface, in order to see the volume control
    - Skip to next song within 2 - 10 seconds until Zipp's volume slider drops to 0
    - Power off Zipp
    - Stop raopbrdige, copy the log.

    And here it is. Only 15k lines, 120 kB compressed. raopbridge.log.gz
    Thanks - if this is reasonabiliy easy to reproduce, could you do one version with no addition debugging?

    [edit]: and more important, can you confirm that it does not happen with non-sync'd players?
    Last edited by philippe_44; 2017-05-18 at 18:24.
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express

  3. #573
    Senior Member
    Join Date
    Apr 2008
    Location
    Paris, France
    Posts
    2,005
    Quote Originally Posted by philippe_44 View Post
    Thanks - if this is reasonabiliy easy to reproduce, could you do one version with no addition debugging?

    [edit]: and more important, can you confirm that it does not happen with non-sync'd players?
    1st a response on the "most important" question. I removed logging completely to discard any timing interference, zapped the plugin/players config, restarted the plugin.
    With new Zipp alone on a repeat playlist of one flac album, I was able to skip forward and back every 1-5 secs and go through the playlist something like 5 times, and nothing happened at all.
    Then I powered on player Loop and synched it with Zipp. I set volumes to be sure I would mostly hear Zipp. I resumed rotating through songs on the same playlist. Within something like 1 minute, the Zipp had dropped its volume.
    Demonstrating something does not happen can take a while ... is this report confirmation enough for you?

    I will now set logging on, with "additional none" and re-run the test.

    EDIT: The players were idling a bit while I was doing something else. I decided I would break the silence and started zipp+Loop. After a few seconds in the 1st song, volume on zipp dropped to 0. Short log! raopbridge.log.gz

    EDIT2: This one follows the scenario, I had to skip a few times to get Zipp to drop its volume. raopbridge-1495184894.log.gz

    Let me know if you need more.
    Last edited by epoch1970; 2017-05-19 at 02:21.
    3 SB 3 • Libratone Loop, Zipp Mini • iPeng (iPhone + iPad) • LMS 7.9 (linux) with plugins: CD Player, WaveInput, Triode's BBC iPlayer by bpa • IRBlaster by Gwendesign (Felix) • Server Power Control by Gordon Harris • Smart Mix, Music Walk With Me, What Was That Tune? by Michael Herger • PowerSave by Jason Holtzapple • Song Info, Song Lyrics by Erland Isaksson • AirPlay Bridge by philippe_44 • WeatherTime by Martin Rehfeld • Auto Dim Display, SaverSwitcher, ContextMenu by Peter Watkins.

  4. #574
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    2,981
    Quote Originally Posted by GatuRatz View Post
    Hi philippe,

    yes, I agree in this.
    I have tried it on three computers (NAS, NUC and small desktop computer) using the same binary and the success rate is different: NAS is the worst, then NUC, best is the dektop computer.
    But there is also a variation over time, today it is quite mute.
    For me that is a hint for timing problem. I have also the impression that I have to restart the player sometimes, it seems to get stuck (it does not happen during normal usage).
    The company who sells is sent an answer to my inquiry, but it was not helpfull for this topic.

    Br
    GatuRatz

    EDIT: it seems that it can read posts.... now, after switching to the next song, it started playing... it has a quite nice sound indeed ;-)
    This was a complicated synchronization issue in a piece of the code that I was hopping to never touch again (lots of headaches in the past). The GGMM has a certain (more restrictive) way to interpret the AirPlay spec that did not fit with what I did. Although it's a small code modification, these ones have potentially lots of side effects. You can try the dev 0.2.3.0.1 and let me know
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express

  5. #575
    Junior Member
    Join Date
    Aug 2009
    Posts
    29
    Quote Originally Posted by philippe_44 View Post
    You can try the dev 0.2.3.0.1 and let me know
    Yes, it works now. And it even syncs to the other players :-)
    Sometimes it struggles still a little bit at the beginning (but if I stop and play again it usually gets in sync), I guess that I must play with the sync settings in LMS.
    But someone is sleeping here deeply and I do not want to wake him up now with syncing attempts through the whole appartment, so I will do the finetuning later or tomorrow, else the HAF (=husband aceptance factor) of LMS might suffer ;-)

    Thanks!!! :-)

    Br
    GatuRatz

  6. #576
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    2,981
    Quote Originally Posted by GatuRatz View Post
    Yes, it works now. And it even syncs to the other players :-)
    Sometimes it struggles still a little bit at the beginning (but if I stop and play again it usually gets in sync), I guess that I must play with the sync settings in LMS.
    But someone is sleeping here deeply and I do not want to wake him up now with syncing attempts through the whole appartment, so I will do the finetuning later or tomorrow, else the HAF (=husband aceptance factor) of LMS might suffer ;-)

    Thanks!!! :-)

    Br
    GatuRatz
    I'm glad that for once HAF is taken into account, and not only WAF

    Unfortunately, this version is causing compatibility issues with other AirPlay device and I had to pull it back
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express

  7. #577
    Junior Member
    Join Date
    Aug 2009
    Posts
    29
    Quote Originally Posted by philippe_44 View Post

    Unfortunately, this version is causing compatibility issues with other AirPlay device and I had to pull it back
    In my LMS it is still active, how can I set LMS to avoid that it is pulled back in my installation without disabling other updates? I have no other devices which have Airplay only.
    For now I have disabled automatic update of plugins.
    Is your target to integrate the GGMM-E5 compatibility again?

    I got most issues working with no significative problems remaining.
    The most important thing is to reduce the audio buffer to ~200ms. (I still do not know whether this will cause other problems.)
    I also ticked "send LMS metadata to player", this seems to help for syncronization (?) (and now with the status request I can also see that it is accepted), "compress" and of course "encrypt".
    In some szenarios synchronization seems to depend on the setting of bitrate limitation setting in the player settings but with reducing the audio buffer this got much better (before this it would sync sometimes and sometimes not).
    Usually after pausing and unpausing it was in sync anyway.
    I will try more music files and sources today.

    Thanks and br
    GatuRatz

  8. #578
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    2,981
    Quote Originally Posted by GatuRatz View Post
    In my LMS it is still active, how can I set LMS to avoid that it is pulled back in my installation without disabling other updates? I have no other devices which have Airplay only.
    For now I have disabled automatic update of plugins.
    Is your target to integrate the GGMM-E5 compatibility again?

    I got most issues working with no significative problems remaining.
    The most important thing is to reduce the audio buffer to ~200ms. (I still do not know whether this will cause other problems.)
    I also ticked "send LMS metadata to player", this seems to help for syncronization (?) (and now with the status request I can also see that it is accepted), "compress" and of course "encrypt".
    In some szenarios synchronization seems to depend on the setting of bitrate limitation setting in the player settings but with reducing the audio buffer this got much better (before this it would sync sometimes and sometimes not).
    Usually after pausing and unpausing it was in sync anyway.
    I will try more music files and sources today.

    Thanks and br
    GatuRatz
    I will try to get it back, but unless I find a quick solution, it looks like an important re-write of the sync part, so not an happy thing. The AirPlay is not an official standard, so I don't know if this is my reading which is too liberal or their implementation that is too litteral (it seems to follow exactly what iTunes does, including some taking for a rule something that just happens to be coincidental ... I don't know)
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express

  9. #579
    Junior Member
    Join Date
    Aug 2009
    Posts
    29
    Hi philippe,

    I will stay with 0.2.3.0.1 meanwhile ;-)
    Here it is still active.
    How can I avoid updating or downgrading it without blocking updates of other plugins?
    Can I force a plugin to install or to keep installed to a certain revision?

    Thanks and br
    GatuRatz

  10. #580
    Senior Member
    Join Date
    Apr 2008
    Location
    Paris, France
    Posts
    2,005
    Quote Originally Posted by GatuRatz View Post
    Hi philippe,

    I will stay with 0.2.3.0.1 meanwhile ;-)
    Here it is still active.
    How can I avoid updating or downgrading it without blocking updates of other plugins?
    Can I force a plugin to install or to keep installed to a certain revision?

    Thanks and br
    GatuRatz
    AFAIK you can either untick "Update plugins automatically" in Settings/Plugins, bottom of page (you'll have to tick individual updates to install them),
    or
    remove Philippe_44's repo URL or change it to point to some non-existent/local domain so that you don't get updates for his plugins. E.g. I have in my additional repositories list: "http://freefr.dl.sourceforge.net/project/lms-to-raop/dev/repo-sf.xml" (which resolves) and "http://freefr.dl.sourceforge.invalid/project/lms-plugins-philippe44/repo-sf.xml" (which doesn't, on purpose). I'm not sure you still need some of these URLs to get the plugin, that trick might be obsolete.
    3 SB 3 • Libratone Loop, Zipp Mini • iPeng (iPhone + iPad) • LMS 7.9 (linux) with plugins: CD Player, WaveInput, Triode's BBC iPlayer by bpa • IRBlaster by Gwendesign (Felix) • Server Power Control by Gordon Harris • Smart Mix, Music Walk With Me, What Was That Tune? by Michael Herger • PowerSave by Jason Holtzapple • Song Info, Song Lyrics by Erland Isaksson • AirPlay Bridge by philippe_44 • WeatherTime by Martin Rehfeld • Auto Dim Display, SaverSwitcher, ContextMenu by Peter Watkins.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •