Home of the Squeezebox™ & Transporter® network music players.
Page 67 of 67 FirstFirst ... 1757656667
Results 661 to 666 of 666
  1. #661
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    3,113
    Quote Originally Posted by streampunk View Post
    Philippe,
    I've tested the other two cases now.
    1. Airplay speaker loses network connection/ connects to another WLAN network
    Airplay speaker is powered off, rest of player continue - perfect... well, almost: In an ideal world, perhaps Airplay playback would restart as soon as the speaker gets a network connection again

    2. Playback on iOS device (in my case iPad 4 with iPeng and iPhone 6 with iPeng) is stopped because another iOS application sends sound (e.g. starting a Youtube video or opening a web site with background sound
    All other speakers stop, and this seemes to cause a little bit of chaos, because also the volume settings (as seen in iPeng) are changed "automatically"
    I think this is the log part where it happens (does the plugin get a "set pause" when LMS playback stops?):

    Best regards
    Martin
    I'm not following what's the setup in 2/. Is this correct

    - You are controlling LMS from iPeng
    - You have the local playback extension (squeezelite) in iPeng, on your iPad and iPhone
    - You have another AirPlay device in sync with this iPad & iPhone (using squeezelite on iPeng)
    - On one of the device, you play something locally

    I'm missing the connection between iPeng/squeezelite and AirPlay
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express

  2. #662
    Quote Originally Posted by philippe_44 View Post
    I'm not following what's the setup in 2/. Is this correct

    - You are controlling LMS from iPeng
    - You have the local playback extension (squeezelite) in iPeng, on your iPad and iPhone
    - You have another AirPlay device in sync with this iPad & iPhone (using squeezelite on iPeng)
    Yes. And another squeezlite player running on the piCore Raspi (and some other devices as Kodi with XSqueeze, but they weren't active during the tests).
    - On one of the device, you play something locally
    Well, I'm not sure whether "locally" is the right word. But yes: In iPeng's list of (synched) players, one of the players is the iPad iPeng is running on. So this iPad plays music (coming from the LMS server) "locally" or sends it to a Bluetooth speaker. And while this is happening, whenever you start another sound source on this iPad, LMS playback stops on all players (i.e. not only on the iPad).
    I'm missing the connection between iPeng/squeezelite and AirPlay
    hmm... perhaps you are right... I automatically supposed that this issue was related to the Airplay bridge because the effect was very similar to the one you fixed. I can't find anything related to the sudden stopping of the playback in der server log (or perhaps I haven't found the correct logging options yet), though, only the "pause" command in the AP bridge log.
    PCP (always latest version) on RasPi 3 with PhatDac (player & server)
    PCP on several RasPis 2 +3
    2 Airplay speakers (Sony SA-NS510) integrated via Airplay Bridge Plugin

  3. #663
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    3,113
    Quote Originally Posted by streampunk View Post
    Yes. And another squeezlite player running on the piCore Raspi (and some other devices as Kodi with XSqueeze, but they weren't active during the tests).

    Well, I'm not sure whether "locally" is the right word. But yes: In iPeng's list of (synched) players, one of the players is the iPad iPeng is running on. So this iPad plays music (coming from the LMS server) "locally" or sends it to a Bluetooth speaker. And while this is happening, whenever you start another sound source on this iPad, LMS playback stops on all players (i.e. not only on the iPad).

    hmm... perhaps you are right... I automatically supposed that this issue was related to the Airplay bridge because the effect was very similar to the one you fixed. I can't find anything related to the sudden stopping of the playback in der server log (or perhaps I haven't found the correct logging options yet), though, only the "pause" command in the AP bridge log.
    I will check but I assume this more ipeng doing its job of pausing other players


    EnvoyÚ de mon iPad en utilisant Tapatalk
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express

  4. #664
    Quote Originally Posted by philippe_44 View Post
    I will check but I assume this more ipeng doing its job of pausing other players
    J÷rg just confirmed that iPeng (player) receives a Pause command from iOS when another iOS app takes over the audio on the iOS device. And that iPeng in this case pauses the entire group, and that any alternative would cause a big confusion. I'll have to think this over, but I think that this is probably not the behaviour a normal user would expect.
    Anyway, its not a AP bridge issue (but your comments are highly welcome).
    Best regards
    Martin
    PCP (always latest version) on RasPi 3 with PhatDac (player & server)
    PCP on several RasPis 2 +3
    2 Airplay speakers (Sony SA-NS510) integrated via Airplay Bridge Plugin

  5. #665
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    3,113

    ANNOUNCE: AirPlay Bridge = integrate AirPlay devices with LMS (squeeze2raop)

    It's a very much a user-level preference as you can argue for both behaviors: "I'm playing something else on a player that was part of a group, that means I want to stop the whole group" or "I took my iPad in another room and I want to listen to something else while the rest of the family is continuing ..." I see both opinions valid, hence I put an option in airplay bridge. But at the same time, too many options are confusing (sigh)
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express

  6. #666
    Senior Member
    Join Date
    Aug 2012
    Posts
    165
    Has anybody got this working with the Aether Cone? Great speaker for ú40. It used to work however now they just stutter the audio and volume control has never worked. Phillippe what log would help?

    http://www.laptopsdirect.co.uk/conte...reless-speaker

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •