Home of the Squeezebox™ & Transporter® network music players.
Page 55 of 55 FirstFirst ... 545535455
Results 541 to 547 of 547
  1. #541
    Junior Member
    Join Date
    Jan 2008
    Location
    Toronto, CA
    Posts
    27
    Quote Originally Posted by Man in a van View Post
    I followed these instructions from pinkdot

    http://forums.slimdevices.com/showth...l=1#post784918

    Is it just the Spotify that does not work? If you can stream a radio station or playback some local files then at least (I think/hope/wish/pray) that would resolve the 32/64 bit thing (as we technical numpties call it ).
    The instructions from pinkdot were similar to what I had to do to get the 7.9 update to install, but only adding the '9' to the routines.sh file. I'm not sure if changing line 68 in shipped-binairies would do much to get the plugin working. If anyone can comment on that, would be appreciated.

    And yes, its only spotify that doesn't work. Playing local files or streaming radio stations or podcasts work fine.

    Quote Originally Posted by Man in a van View Post
    Thinking a bit more.......

    when I have had problems with the Helper App not running I have resolved it by re-entering my password for Spotify on the Settings advanced page (and clicking apply, sometimes restarting LMS as well).

    Have you tried deleting the Spotify cache?

    or

    a complete longshot

    un-install the spotify protocol handler on the lms,

    go to mysqbx dot com and un-install the spotiify app,

    then log into your spotify account and log out of spotify everywhere,

    restart the nas and try again.

    I can't think of anything else at the moment.

    Ronnie
    I haven't tried deleting the spotify cache - I'll have to dig around and see how to do that and give it a try.

    I have tried every permutation I can think of though re: clean LMS install (without protocol handler), re-entering password, and uninstalling/reinstalling spotify on mysqzbx.com -- so far, nothing seems to get it to work.

    Appreciate your tips!!

  2. #542
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    1,646
    Hi David

    You should be able to use WinScp to navigate to your Spotify cache, the path is shown on the Settings page Info tab.

    Strongly recommend completing the pinkdot instruction, also, if you decide to stay with LMS on the NAS, perform the security update for SSODS.

    I see that you could use a Spotify app on the NAS for playback, maybe install Philippe's UPnP/DLNA bridge plugin and stream to your players (I think this would work ).

    Otherwise it's LMS on a raspberry pi

    Ronnie

  3. #543
    Junior Member
    Join Date
    Apr 2017
    Posts
    3

    handler won't work with changed password

    Hello there,
    I have been using the built-in Spotify Plugin together with the protocol handler for months and was very satisfied. Now I changed my spotify password and applied it to the settings page. First it's telling me, that I am connected but when I try to use the plugin, I receive a 400er bad request error and am no longer connected.
    I already installed a new lms 7.9 and tried to activate the plugin, but it won't show.

    the spotifyd.log has following lines - don't know if they are relevant

    [20:03:43.513409] main:448 /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/SpotifyProtocolHandler/Bin/arm-linux/spotifydhf 2.3.8 started ( libspotify: 12.1.103.gd51f6226 Release Linux-armv6-bcm2708hardfp )
    [20:05:25.787488] main:619 req: status.json res: (null) par: (null) prot: HTTP/1.0 auth: (null)
    [20:05:25.787695] process_status:1464 process status

    no error in the server.log

    The 3rd party Triode plugin on the other hand works with the new password.

    Are there perhaps issues with the length of the password or with special characters?
    I don't need to enter my credentials on the mysqueezebox.com account, do I?

    Any help would be appreciated!

    Regards
    Didi

  4. #544
    Senior Member Mnyb's Avatar
    Join Date
    Feb 2006
    Location
    Vństerňs Sweden
    Posts
    15,931
    Quote Originally Posted by linndidi View Post
    Hello there,
    I have been using the built-in Spotify Plugin together with the protocol handler for months and was very satisfied. Now I changed my spotify password and applied it to the settings page. First it's telling me, that I am connected but when I try to use the plugin, I receive a 400er bad request error and am no longer connected.
    I already installed a new lms 7.9 and tried to activate the plugin, but it won't show.

    the spotifyd.log has following lines - don't know if they are relevant

    [20:03:43.513409] main:448 /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/SpotifyProtocolHandler/Bin/arm-linux/spotifydhf 2.3.8 started ( libspotify: 12.1.103.gd51f6226 Release Linux-armv6-bcm2708hardfp )
    [20:05:25.787488] main:619 req: status.json res: (null) par: (null) prot: HTTP/1.0 auth: (null)
    [20:05:25.787695] process_status:1464 process status

    no error in the server.log

    The 3rd party Triode plugin on the other hand works with the new password.

    Are there perhaps issues with the length of the password or with special characters?
    I don't need to enter my credentials on the mysqueezebox.com account, do I?

    Any help would be appreciated!

    Regards
    Didi
    But on mysqueezejpx.com you also have to change the spotify password there to .
    --------------------------------------------------------------------
    Main hifi: Touch + CIA PS +MeridianG68J MeridianHD621 MeridianG98DH 2 x MeridianDSP5200 MeridianDSP5200HC 2 xMeridianDSP3100 +Rel Stadium 3 sub.
    Bedroom/Office: Boom
    Kitchen: Touch + powered Fostex PM0.4
    Misc use: Radio (with battery)
    iPad1 with iPengHD & SqueezePad
    (spares Touch, SB3, reciever ,controller )
    server HP proliant micro server N36L with ClearOS Linux

    http://people.xiph.org/~xiphmont/demo/neil-young.html

  5. #545
    Junior Member
    Join Date
    Apr 2017
    Posts
    3
    Quote Originally Posted by Mnyb View Post
    But on mysqueezejpx.com you also have to change the spotify password there to .
    Hi,
    thanx for your quick response.
    I dare not changing the password on mysqueezebox.com
    The background is: My spotify account has been hacked. The hacker could have easily changed all my playlists - wich is a desaster. Fortunately he did not.
    I see that mysqueezebox.com still is an http-Server without ssl-encryption. It should be very easy to sniff any spotify password and do whatever they like.

    If it is the only way to get spotify on lms to work, this option has just died for me.

    Could you please confirm that I am not right and tell me a secure way to get things going.

    Please!

  6. #546
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,488

    [Announce] Spotify Protocol Handler -play Spotify on all your Squeezeboxen

    > I see that mysqueezebox.com still is an http-Server without
    > ssl-encryption. It should be very easy to sniff any spotify password and
    > do whatever they like.


    You can use https://www.mysqueezebox.com. (yes, the certificate still
    listens to the squeezenetwork.com name, but it's there)

    --

    Michael

  7. #547
    Junior Member
    Join Date
    Apr 2017
    Posts
    3
    Quote Originally Posted by mherger View Post
    > I see that mysqueezebox.com still is an http-Server without
    > ssl-encryption. It should be very easy to sniff any spotify password and
    > do whatever they like.


    You can use https://www.mysqueezebox.com. (yes, the certificate still
    listens to the squeezenetwork.com name, but it's there)

    --

    Michael
    ... ah, o.k. I only should have eyes to see
    Thank you so much for your support! I am addicted to your tools!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •