Home of the Squeezebox™ & Transporter® network music players.
Page 53 of 154 FirstFirst ... 343515253545563103153 ... LastLast
Results 521 to 530 of 1538
  1. #521
    Junior Member
    Join Date
    May 2016
    Posts
    2

    BBCiPlayer with DASH support - test version

    Hi All.

    I wonder if someone can point me in the right direction. I recently did a fresh install of my Ubuntu desktop, which had my LMS running on it. I had previously managed to get the BBC iPlayer and Extra plugins working. However, since the install, neither of the plugins work on my install of LMS 7.9.0. Version string:

    Logitech Media Server Version: 7.9.0 - 1469176740 @ Fri Jul 22 08:49:04 UTC 2016
    Currently, if I select a category in the BBCiPlayerExtra plugin (v1.9.3), I get the following:

    There was an error loading the remote feed for : (Failed to parse)
    If I go via the BBCiPlayer plugin (v.1.4.7), I press play on the LMS web front end, and nothing at all happens. On the device, Boom, it says "Nothing to play" on the screen.

    Any pointers gratefully appreciated.

    LMS installed from deb package.

    Thanks

  2. #522
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,142
    Quote Originally Posted by m1geo View Post
    There was an error loading the remote feed for : (Failed to parse)
    This can be associated with network errors or aggressive security measures such as firewalls - other causes included old cache entries especially if system time is not set up correctly..
    To be sure you should stop LMS, delete the cache database and then restart LMS.

    BBciPlayerExtras is an addon to BBCiPlayer - so make sure BBCiPlayer is working first in all respects before even trying the Extras plugin. There is no point trying to debug anything if BBCiPlayer is not working.

    So this deals with BBCiPlayer plugin (1.4.7 and later)

    Do you get the menus populated with the programs titles and the problem occur when you try to play a specific program or you only get the top level menus ?
    What are the settings for BBCiPlayer ?
    You hint ("I managed") you may have had problems with installation - how did you install the plugins ?

  3. #523
    Junior Member
    Join Date
    May 2016
    Posts
    2
    Quote Originally Posted by bpa View Post
    This can be associated with network errors or aggressive security measures such as firewalls - other causes included old cache entries especially if system time is not set up correctly..
    To be sure you should stop LMS, delete the cache database and then restart LMS.
    I understand. Nothing fancy here, and the clock is set correctly.

    Quote Originally Posted by bpa View Post
    BBciPlayerExtras is an addon to BBCiPlayer - so make sure BBCiPlayer is working first in all respects before even trying the Extras plugin. There is no point trying to debug anything if BBCiPlayer is not working.
    Didn't realise that before, now understand.

    Quote Originally Posted by bpa View Post
    So this deals with BBCiPlayer plugin (1.4.7 and later)

    Do you get the menus populated with the programs titles and the problem occur when you try to play a specific program or you only get the top level menus ?
    What are the settings for BBCiPlayer ?
    You hint ("I managed") you may have had problems with installation - how did you install the plugins ?
    Okay, so, I removed cache.db last night before your reply, and it didn't appear to fix anything. But this morning, the BBCiPlayer plugin is working fine.

    However, I still get the "There was an error loading the remote feed for : (Failed to parse)" error with BBCiPlayerExtras.

    Thanks again, and cracking work!

  4. #524
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,142
    Quote Originally Posted by m1geo View Post
    Okay, so, I removed cache.db last night before your reply, and it didn't appear to fix anything. But this morning, the BBCiPlayer plugin is working fine.

    However, I still get the "There was an error loading the remote feed for : (Failed to parse)" error with BBCiPlayerExtras.
    The cache contains somehting entries of a few minutes ago so removing cache last night and then trying again in the morning is not the way forward. If you get a network error (and "Failed to parse" is a network error) then cache will hold the error and will keep it chucking back at you at every successive attempt without even trying the real network. When you get the "Failed to parse" error - NEVER try that menu item(e.g. category) again within 15 minutes.
    Assuming plugin is installed correctly as others including myself have no problem with it on an x86 Ubuntu - the "Failed to parse" error is a network error - the response from BBC so most likely causes of your problem include

    1. Bad installation of plugin
    2. Unusual Ubuntu setup (e.g Ubuntu on PPC)
    3. Category chosen are not used by others and may have been distcontinued by BBC or incorrectly entered in plugin setup.


    So more information please.

    What is your Ubuntu system type - processor, speed, memory, Ubuntu version.
    Are you in the UK or not ?
    If not in the UK are you using a VPN ?
    Is your ISP connection a slow or a satellite link ?
    How did you install the plugin ?
    Where (i.e.path) are the plugins installed ?
    What is the Radio station Timeout settings in WebUI Settings/Advanced/Network ?
    What are the BBCiPlayer settings ?
    What are the BBCiPlayerExtra Settings ?
    What catergories are you choosing ?
    Do all categories show the same problem ? Try each catgeory just once ?

  5. #525

    re-buffering with iplayer plugin - driving my wife (and me) mad

    Hi there, I hope bpa or others might be able to help...

    I recently had to move my LMS (Version: 7.9.0 - 1467729831 @ Fri Jul 8 04:05:20 CUT 2016) to a windows 10 PC as my old WHS 2003 server finally gave up the ghost. PC is i5, 8GB RAM and fast modern drives so way more horse power than my old WHS. All streamers (SB3/Transporter/Touch) are wired on the network. On Virgin Media with highest bandwidth (200MB?)

    Using the DASH plugin, which was working fine on old build. Now get regular re-buffering on all devices with listen live, varies, but mostly every 2-5 mins. Time to recover varies from 0.5 second to a complete stall.

    Replay works fine.

    Looking at Windows 10 resources, tiny CPU use (circa 4%), disk happy (<2% use) network about 6 spikes in download every minute, each about 1-2 Mbps. easily within the bandwidth, but very lumpy traffic (but this may be the way live streaming from BBC works?)

    Just tried listen live (non UK) seemed on a limited trial more stable, but I am in the UK and ideally would like the higher quality. But when using the UK option get regular re-buffering.

    Anyone else had this issue, got ideas on what to try.

    not sure how important the following settings have but I think I have tried them all!

    Radio Station Buffer Seconds (advanced/network) set to 9 seconds - thinking a larger number might help? have set this back to 3 while typing this email and hasn't rebuffered in last few minutes, so maybe this is part of the problem, will report back after more use.
    Streaming method (direct and proxied) tried both for the player. which is recommended?
    Advanced/File types AAC set to native.

    any help gratefully received.

    thanks

  6. #526
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,142
    Quote Originally Posted by davidismynaim View Post
    Radio Station Buffer Seconds (advanced/network) set to 9 seconds - thinking a larger number might help? have set this back to 3 while typing this email and hasn't rebuffered in last few minutes, so maybe this is part of the problem, will report back after more use.
    Streaming method (direct and proxied) tried both for the player. which is recommended?
    Makes no difference with DASH plugin as plugin overrides timings for DASH and uses its own settings. Direct/Proxied only relevant for http stream which play directly on player - so again no difference for DASH.

    "Advanced/File types AAC set to native" - also no real difference since SB3/Transporter require trasnscoding and you have a decent system.

    1. What are your BBcIplayerplugin settings.
    2. Any message in the LMS log file.

  7. #527

  8. #528
    looking at log file, I have lots and lots of this:-

    [16-08-02 14:52:26.3093] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Web::HTTP::sendStreamingResponse: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Networking/IO/Select.pm line 134.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0xc00fc44)
    [16-08-02 14:52:26.3096] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Web::HTTP::sendStreamingResponse: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Networking/IO/Select.pm line 134.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0xc00fc44)
    [16-08-02 14:52:26.3098] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Web::HTTP::sendStreamingResponse: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Networking/IO/Select.pm line 134.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0xc00fc44)
    [16-08-02 14:52:26.3100] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Web::HTTP::sendStreamingResponse: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Networking/IO/Select.pm line 134.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0xc00fc44)
    [16-08-02 14:52:26.3103] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Web::HTTP::sendStreamingResponse: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Networking/IO/Select.pm line 134.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0xc00fc44)
    [16-08-02 14:52:26.3106] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Web::HTTP::sendStreamingResponse: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Networking/IO/Select.pm line 134.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0xc00fc44)
    [16-08-02 14:52:26.3108] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Web::HTTP::sendStreamingResponse: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Networking/IO/Select.pm line 134.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0xc00fc44)
    [16-08-02 14:52:26.3110] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Web::HTTP::sendStreamingResponse: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Networking/IO/Select.pm line 134.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0xc00fc44)
    [16-08-02 14:52:26.3112] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Web::HTTP::sendStreamingResponse: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Networking/IO/Select.pm line 134.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0xc00fc44)
    [16-08-02 14:52:26.3115] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Web::HTTP::sendStreamingResponse: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Networking/IO/Select.pm line 134.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0xc00fc44)
    [16-08-02 14:52:26.3117] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Web::HTTP::sendStreamingResponse: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Networking/IO/Select.pm line 134.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0xc00fc44)
    [16-08-02 14:52:26.3120] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Web::HTTP::sendStreamingResponse: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Networking/IO/Select.pm line 134.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0xc00fc44)
    [16-08-02 14:52:26.3122] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Web::HTTP::sendStreamingResponse: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Networking/IO/Select.pm line 134.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0xc00fc44)
    [16-08-02 14:52:26.3125] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Web::HTTP::sendStreamingResponse: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Networking/IO/Select.pm line 134.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0xc00fc44)
    [16-08-02 14:52:26.3128] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Web::HTTP::sendStreamingResponse: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Networking/IO/Select.pm line 134.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0xc00fc44)
    [16-08-02 14:52:26.3130] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Web::HTTP::sendStreamingResponse: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Networking/IO/Select.pm line 134.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0xc00fc44)
    [16-08-02 14:52:26.3132] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Web::HTTP::sendStreamingResponse: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Networking/IO/Select.pm line 134.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0xc00fc44)
    [16-08-02 14:52:26.3134] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Web::HTTP::sendStreamingResponse: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Networking/IO/Select.pm line 134.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0xc00fc44)
    [16-08-02 14:52:26.3141] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Web::HTTP::sendStreamingResponse: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Networking/IO/Select.pm line 134.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0xc00fc44)
    [16-08-02 14:52:26.3144] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Web::HTTP::sendStreamingResponse: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Networking/IO/Select.pm line 134.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0xc00fc44)
    [16-08-02 14:52:26.3146] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Web::HTTP::sendStreamingResponse: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Networking/IO/Select.pm line 134.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0xc00fc44)
    [16-08-02 14:52:26.3149] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Web::HTTP::sendStreamingResponse: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Networking/IO/Select.pm line 134.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0xc00fc44)


    No idea what this is, possibly the root cause.

    PS. rebuffered again, gone back to Non-Uk and stable again ??

  9. #529
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,142
    Quote Originally Posted by davidismynaim View Post
    No idea what this is, possibly the root cause.
    This is "normal" for BBCiPlayer plugin playing HLS or DASH protocols but htis many usually indicates a BBC problem.

    WHy are you playing HLS for on demand but DASH for Live ?

    If you are making comparisons - do like with like. Use HLS for live and see if you get the problem and any other messages in log.

    This "feels" like a BBC server issue.

  10. #530
    no reason re the different options, here, just tried all combinations, and I don't have problem with play back, so I have been playing with the live settings most. This evening playing R2 without any issues on Non-UK setting, I will tell my Wife to use that tomorrow and give it a proper test (she has the radio on all day) to see if this is more stable.

    Thanks for your help.

    When all this works it is an amazing system! And thank you for taking on this amazing job, post Triode!

    David

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •