Home of the Squeezebox™ & Transporter® network music players.
Page 117 of 147 FirstFirst ... 1767107115116117118119127 ... LastLast
Results 1,161 to 1,170 of 1465
  1. #1161
    Junior Member
    Join Date
    May 2015
    Posts
    8
    Quote Originally Posted by bpa View Post
    These are the 404 errors and I have a fix for this. The temporary measure is to increase the "live stream delay " setting to to 2 mins or higher it is occurs.
    2 minutes delay dropped out after 5 minutes or so, 3 minutes delay has been running stably for an hour now.

    To be honest I am very grateful for what has been done already, working FLAC or not. A bit of a delay is a very minor point in the context of getting an experimental stream working in a different context.

  2. #1162
    Member
    Join Date
    Oct 2007
    Location
    Anglesey, UK
    Posts
    72
    Thanks, that worked. Now on 1.5.3.

  3. #1163
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,019
    Quote Originally Posted by MrKettle View Post
    2 minutes delay dropped out after 5 minutes or so, 3 minutes delay has been running stably for an hour now.

    To be honest I am very grateful for what has been done already, working FLAC or not. A bit of a delay is a very minor point in the context of getting an experimental stream working in a different context.
    If you want better quality to continue to be streamed - give BBC feedback - http://www.bbc.co.uk/taster/projects...ert-sound/rate

  4. #1164
    Senior Member
    Join Date
    Sep 2006
    Location
    Newbury, UK
    Posts
    138
    Still working really well here with no dropouts across a range of players. Another, probably minor advantage for me is that it provides a high quality stream to my older SB3s and Boom end-end with no transcoding (albeit with the DASH processing in LMS, and can't honestly say that the difference would ever be audible on a Boom!), so slightly lower load on the Server and just seems more elegant. Have given the BBC positive feedback and hope they continue to offer it.

    Thanks, again...!
    4x Slim Devices SB3 (White)
    1x Boom, 1x Radio
    1x Joggler + Squeezeplay / Squeezelite + Topping TP30

  5. #1165
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,019

    BBC DASH Flac support - V1.5.4.1 update

    I've just released the V1.5.4.1 which should fix the "404" aka "Stream stops playing after a couple of minutes" problem when playing Flac streams. If running 1.5.4 then LMS should show update is available in Plugins tab.

    This mean the "live stream delay" could probably be set to a low value without fear of stream stopping with a 404 error - can't guarantee no gaps at low value though.
    Last edited by bpa; 2017-04-22 at 08:58.

  6. #1166
    Senior Member
    Join Date
    Sep 2006
    Location
    Newbury, UK
    Posts
    138
    Hi - still working well. For interest, does this also change the "edge" behaviour of the DASH/AAC Live streams?

    Regards

    Phil
    4x Slim Devices SB3 (White)
    1x Boom, 1x Radio
    1x Joggler + Squeezeplay / Squeezelite + Topping TP30

  7. #1167
    Senior Member
    Join Date
    Dec 2005
    Location
    Sutton Coldfield, UK
    Posts
    500
    Seems to be working well here. on troublesome USB DAC now directly connected to PiCore again. 12 minutes played, "no delay" for start of live stream.

    Will give it a try on troublesome chromecasts tomorrow and report again.

    Thanks as always.
    LMS: 7.9.0 - 1488878280 @ Tue Mar 7 09:28:02 UTC 2017 on Raspberry Pi 3B piCorePlayer v3.20 Server/IQAudio DAC+/Amp+/ Synology DS216J Network Music Store
    Homeplug LAN Players:
    Squeezelite on Windows 10 PC
    Raspberry Pi 3B piCorePlayer v3.20/Topping VX2 DAC/Amp
    Wifi Players:
    UPnP Wifi Players: 2 x Chromecast Audio, 2 x Chromecast Video, Revo Super-Connect, GGMM-E5

  8. #1168
    Senior Member
    Join Date
    Dec 2005
    Location
    Sutton Coldfield, UK
    Posts
    500
    Stream on USB DAC has been running for 32 minutes and chromecast stream, both served from same PiCore LMS, has been running for 15 minutes.

    Hope the BBC read these columns.

    Strange of them to test on a classical music channel, which according to the BBC, is only received on a web browser on a desktop PC and then ask for objective comments.

    I have sent in my positive comments in the hope that this may eventually become a standard.

    Well done bpa.
    LMS: 7.9.0 - 1488878280 @ Tue Mar 7 09:28:02 UTC 2017 on Raspberry Pi 3B piCorePlayer v3.20 Server/IQAudio DAC+/Amp+/ Synology DS216J Network Music Store
    Homeplug LAN Players:
    Squeezelite on Windows 10 PC
    Raspberry Pi 3B piCorePlayer v3.20/Topping VX2 DAC/Amp
    Wifi Players:
    UPnP Wifi Players: 2 x Chromecast Audio, 2 x Chromecast Video, Revo Super-Connect, GGMM-E5

  9. #1169
    Senior Member
    Join Date
    Dec 2005
    Location
    Sutton Coldfield, UK
    Posts
    500
    Just noted the streams are still running but are about 5 minutes behind FM. Not a problem but is that part of how your resolved the 404 issue?
    LMS: 7.9.0 - 1488878280 @ Tue Mar 7 09:28:02 UTC 2017 on Raspberry Pi 3B piCorePlayer v3.20 Server/IQAudio DAC+/Amp+/ Synology DS216J Network Music Store
    Homeplug LAN Players:
    Squeezelite on Windows 10 PC
    Raspberry Pi 3B piCorePlayer v3.20/Topping VX2 DAC/Amp
    Wifi Players:
    UPnP Wifi Players: 2 x Chromecast Audio, 2 x Chromecast Video, Revo Super-Connect, GGMM-E5

  10. #1170
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,019
    Quote Originally Posted by florca View Post
    Hi - still working well. For interest, does this also change the "edge" behaviour of the DASH/AAC Live streams?
    Theoretically yes but AAC doesn't have the problem because the BBC uses different settings for AAC stream.

    Quote Originally Posted by ian_heys View Post
    Hope the BBC read these columns.
    Somebody does as they posted comments about about my 1.4.* implementation which gave them grief (so muych so they suppressed error messages).

    Strange of them to test on a classical music channel, which according to the BBC, is only received on a web browser on a desktop PC and then ask for objective comments.
    BBC treat classical special. R3 is the only stream which still has http/ AAC at 320kbs (Reminds me a bit about Yes Minister and why civil servants ensure Covent garden got funding). BBC also said gstreamer could play the stream on RPi - getting the niche RPi using classical music lover or perhaps they were baiting the SB users.

    Quote Originally Posted by ian_heys View Post
    Just noted the streams are still running but are about 5 minutes behind FM. Not a problem but is that part of how your resolved the 404 issue?
    The stream does run about 1-2 mins behind FM (and even behind AAC). The "fix" to 404 was becuase there is an adjustment number to indicate the time difference between realtime and timestamp of lates available segment - I got it mixed up in 1.5.4 and looked for segments ahead of realtime instead of behind realtime.

    Now plugin is correct and if "Live stream delay" is set to zero (and perhaps bufferthreshold 100) you can get "No delay" showing on metadata. However the audio in the stream is always behind FM. The "delay" shown in metadata is based on the time stamp of last segment sent to player compared to PC realtime (adjuested to BBC's timeclock used for the segments) so if player has a big buffer (typically soft player have bigger buffers than h/w SB players) there will be a bigger time delay estimated as player will not have played the audio even though it has a segment.
    Last edited by bpa; 2017-04-22 at 12:45.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •