Home of the Squeezebox™ & Transporter® network music players.
Page 147 of 147 FirstFirst ... 4797137145146147
Results 1,461 to 1,465 of 1465
  1. #1461
    Senior Member
    Join Date
    Sep 2015
    Posts
    126
    I do use C3PO.

    Here is the last command:

    Code:
    LAST EXECUTED COMMAND
     
    At: 2017/08/10 20:29:51
    
     
    Profile:
    
     
    
    flc-pcm-*-fe:c6:a1:a2:3a:bf
    
     
    Command:
    
     
    
    [flac] -dcs --totally-silent $START$ $END$ -- $FILE$ | [sox] -q -t wav - -t wav -b 32 --buffer 32768 --multi-threaded - gain -h rate -v -I -b 90.7 384000
    
     
    Tokenized command:
    
     
    
    "/usr/share/squeezeboxserver/Bin/x86_64-linux/flac" -dcs --totally-silent -- - | "/usr/share/squeezeboxserver/Bin/x86_64-linux/sox" -q -t wav - -t wav -b 32 --buffer 32768 --multi-threaded - gain -h rate -v -I -b 90.7 384000

    and here's the player log:
    Code:
    [20:58:42.820969] decode_flush:190 decode flush
    [20:58:42.821193] output_flush:423 flush output buffer
    [20:58:42.863624] codec_open:218 codec open: 'f'
    [20:58:42.863892] stream_sock:384 connecting to 192.168.253.80:9000
    [20:58:42.864332] stream_sock:413 header: GET /stream.mp3?player=fe:c6:a1:a2:3a:bf HTTP/1.0
    
    
    [20:58:42.915445] stream_thread:176 headers: len: 118
    HTTP/1.1 200 OK
    Server: Logitech Media Server (7.9.1 - 1501791870)
    Connection: close
    Content-Type: audio/x-flac
    
    
    [20:58:43.733820] decode_flush:190 decode flush
    [20:58:43.734036] output_flush:423 flush output buffer
    [20:59:39.077315] decode_flush:190 decode flush
    [20:59:39.077537] output_flush:423 flush output buffer
    [20:59:39.126967] codec_open:218 codec open: 'f'
    [20:59:39.127291] stream_sock:384 connecting to 192.168.253.80:9000
    [20:59:39.127786] stream_sock:413 header: GET /stream.mp3?player=fe:c6:a1:a2:3a:bf HTTP/1.0
    
    
    [20:59:39.175384] stream_thread:176 headers: len: 118
    HTTP/1.1 200 OK
    Server: Logitech Media Server (7.9.1 - 1501791870)
    Connection: close
    Content-Type: audio/x-flac
    
    
    [20:59:40.389777] decode_flush:190 decode flush
    [20:59:40.389918] output_flush:423 flush output buffer

  2. #1462
    Senior Member
    Join Date
    Sep 2015
    Posts
    126
    I disabled C3PO for the player and now the stream plays, I deally I would like to upsample some of the lower bitrate material to get the best out of my dac (easier/better filtering). But at least the stream plays now.

    Thanks so much for your help!

    BR.

    Marius

  3. #1463
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,031
    Quote Originally Posted by Learnincurve View Post
    I disabled C3PO for the player and now the stream plays, I deally I would like to upsample some of the lower bitrate material to get the best out of my dac (easier/better filtering). But at least the stream plays now.
    There is no problem resampling - just you need to set it up correctly. I don't knwo C3PO except that is doesn't always work. I think it makes assumptions which are not always correct.

    edit:

    Looking at the C3PO command - it is strange why is it using flac to decode when sox can accept flac as input - there is no need for the flac part of the process.
    Last edited by bpa; 2017-08-10 at 13:35.

  4. #1464
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,031
    Looking at the logs somehting doesn't make sense:

    The log says squeezelite sends audio/x-flac but you squeezelite log says it send audio/L16. At a guess you posted the wrong section of squeezelite log. Eitrher way - C3PO is the root cause. It may be easier/simpler just to add resampling to a custom-convert.conf file.

    Code:
    17-08-10 20:59:39.1734] Slim::Player::Squeezebox2::directHeaders (471) Processing headers for direct streaming:
    HTTP/1.1 200 OK
    Server: Logitech Media Server (7.9.1 - 1501791870)
    Connection: close
    Content-Type: audio/x-flac
    
    [17-08-10 20:59:39.2489] Slim::Player::Player::_buffering (1140) Buffering... 0 / 261120

  5. #1465
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,031
    Assuming resampling is being done for all formats and not just Flac - to determine what C3PO is doing "wrong" - you should compare the transcode chain used for normal R3 AAC against thge one used for R3 Flac.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •