Home of the Squeezebox™ & Transporter® network music players.
Page 139 of 154 FirstFirst ... 3989129137138139140141149 ... LastLast
Results 1,381 to 1,390 of 1536
  1. #1381
    Junior Member
    Join Date
    Jun 2017
    Posts
    4
    Quote Originally Posted by philippe_44 View Post
    Post a log here that contains the issue. Please indicate the song name when it happened. Logs are found on the plugin setting page (LMS settings, advanced tab)
    Part 3:

    [10:30:10.248375] sq_read:982 [0x5b970]: read 1048576 (a:1048576 r:1048576 w:1200)
    [10:30:10.554290] sq_read:982 [0x5b970]: read 1048576 (a:1048576 r:1048576 w:1200)
    [10:30:14.933991] sq_read:982 [0x5b970]: read 1048576 (a:1048576 r:1048576 w:1200)
    [10:30:19.291249] sq_read:982 [0x5b970]: read 1048576 (a:1048576 r:1048576 w:1200)
    [10:30:20.397123] slimproto_run:601 [0x5b970] Closing CLI socket 15
    [10:30:20.399277] process_strm:216 [0x5b970] strm command u
    [10:30:20.435679] process_strm:262 [0x5b970] unpause at: 0 now: 503739041
    [10:30:20.435793] sendSTAT:143 [0x5b970]: STAT:[STMr] msplayed 10000
    [10:30:27.651213] sq_read:982 [0x5b970]: read 1048576 (a:1048576 r:1048576 w:1200)
    [10:30:32.107680] sq_read:982 [0x5b970]: read 1048576 (a:1048576 r:1048576 w:1200)
    [10:30:36.432473] sq_read:982 [0x5b970]: read 1048576 (a:1048576 r:1048576 w:1200)
    [10:30:40.734729] CtrlSetMute:274 uPNP mute 1 for http://192.168.90.20:49154/RenderingControl/ctrl (cookie 0x452c)
    [10:30:40.736442] process_strm:216 [0x5b970] strm command p
    [10:30:40.736547] AVTBasic:203 uPNP Pause for http://192.168.90.20:49154/AVTransport/ctrl (cookie 0x452d)
    [10:30:40.737090] sendSTAT:143 [0x5b970]: STAT:[STMp] msplayed 31000
    [10:30:40.737227] process_strm:248 [0x5b970] pause interval: 0
    [10:30:40.809932] ProcessVolume:564 [0xb9f78]: UPnP Volume local change 59
    [10:30:40.810538] cli_open_socket:223 [0x5b970]: opened CLI socket 14
    [10:30:41.202617] SyncNotifState:516 Family Room: uPNP pause
    [10:30:52.006099] slimproto_run:601 [0x5b970] Closing CLI socket 14

  2. #1382
    Junior Member
    Join Date
    Dec 2016
    Posts
    19
    Hi Philippe,
    with the latest production version of the plugin, I am seeing an error that has never happened before. The TIDAL track (track 3 of 11) no sound is produced.

    Here is the log:

    [08:37:55.450279] sq_read:980 [0x8095880]: read 1048576 (a:1048576 r:1048576 w:1200)
    [08:38:08.076099] sq_read:980 [0x8095880]: read 1048576 (a:1048576 r:1048576 w:1200)
    [08:38:19.225059] sq_read:980 [0x8095880]: read 1048576 (a:1048576 r:1048576 w:1200)
    [08:38:34.274889] sq_read:980 [0x8095880]: read 1048576 (a:1048576 r:1048576 w:1200)
    [08:38:45.324711] sq_read:980 [0x8095880]: read 1048576 (a:1048576 r:964250 w:1200)
    [08:38:53.513626] sq_read:980 [0x8095880]: read 1048576 (a:1048576 r:0 w:1200)
    [08:38:53.513769] sq_read:1028 [0x8095880]: read (end of track) w:1200
    [08:38:54.181135] sq_callback:281 [0x80f3f40]: codec:f, ch:255, s:255, r:255
    [08:38:54.181416] cli_open_socket:223 [0x8095880]: opened CLI socket 17
    [08:38:54.283259] sq_get_metadata:603 [0x8095880]: idx 2
    artist:Sol Gabetta
    album:Prayer
    title:From Jewish Life - III. Jewish Song
    genre:[no genre]
    duration:161.000
    size:0
    cover:http://resources.tidal.com/images/e4.../1280x1280.jpg
    [08:38:54.283418] sq_callback:316 [0x80f3f40]: next URI gapped http://192.168.1.65:49153/LMS2UPNP/b...-b4-idx-0.flac
    [08:38:55.838525] sq_close:869 [0x8095880]: read total:12498586
    [08:40:03.574580] AVTSetURI:92 uPNP setURI http://192.168.1.65:49153/LMS2UPNP/b...-b4-idx-0.flac for http://192.168.1.70:2870/control/AVTransport (cookie 0x2883)
    [08:40:03.575312] AVTPlay:152 uPNP play for http://192.168.1.70:2870/control/AVTransport (cookie 0x2884)
    [08:40:03.575440] SyncNotifState:465 [0x80f3f40]: no gapless http://192.168.1.65:49153/LMS2UPNP/b...-b4-idx-0.flac
    [08:40:03.575486] sq_notify:1127 [0x8095880] End of track by track change
    [08:40:48.082997] CallbackActionHandler:732 Error in action callback -- -204 (cookie 0x288e)
    [08:41:04.096473] CallbackActionHandler:732 Error in action callback -- -207 (cookie 0x2885)
    [08:41:05.096758] CallbackActionHandler:732 Error in action callback -- -207 (cookie 0x2886)
    [08:41:06.097705] CallbackActionHandler:732 Error in action callback -- -207 (cookie 0x2887)
    [08:41:07.098546] CallbackActionHandler:732 Error in action callback -- -207 (cookie 0x2888)
    [08:41:08.103472] CallbackActionHandler:732 Error in action callback -- -207 (cookie 0x2889)
    [08:41:09.108840] CallbackActionHandler:732 Error in action callback -- -207 (cookie 0x288a)
    [08:41:10.087951] CallbackActionHandler:732 Error in action callback -- -207 (cookie 0x288b)
    [08:41:11.101772] CallbackActionHandler:732 Error in action callback -- -207 (cookie 0x288c)
    [08:41:12.103950] CallbackActionHandler:732 Error in action callback -- -204 (cookie 0x2894)
    [08:41:14.114176] CallbackActionHandler:732 Error in action callback -- -204 (cookie 0x2896)
    [08:41:15.105246] CallbackActionHandler:732 Error in action callback -- -207 (cookie 0x288d)
    [08:41:15.109323] CallbackActionHandler:732 Error in action callback -- -207 (cookie 0x288f)
    [08:41:15.383141] CallbackActionHandler:732 Error in action callback -- -208 (cookie 0x2890)
    [08:41:16.106205] CallbackActionHandler:732 Error in action callback -- -204 (cookie 0x2898)
    [08:41:19.119490] CallbackActionHandler:732 Error in action callback -- -204 (cookie 0x289a)
    [08:41:20.383879] CallbackActionHandler:732 Error in action callback -- -204 (cookie 0x289d)
    [08:41:21.110241] CallbackActionHandler:732 Error in action callback -- -204 (cookie 0x289e)
    [08:41:24.124871] CallbackActionHandler:732 Error in action callback -- -204 (cookie 0x289f)
    [08:41:30.391037] CallbackActionHandler:732 Error in action callback -- -208 (cookie 0x2891)
    [08:41:35.122119] CallbackActionHandler:732 Error in action callback -- -207 (cookie 0x2892)
    [08:41:35.415078] CallbackActionHandler:732 Error in action callback -- -208 (cookie 0x2895)
    [08:41:35.415077] CallbackActionHandler:732 Error in action callback -- -208 (cookie 0x2893)
    [08:41:40.421503] CallbackActionHandler:732 Error in action callback -- -204 (cookie 0x28a6)
    [08:41:43.095260] CallbackActionHandler:732 Error in action callback -- -207 (cookie 0x2897)
    [08:41:43.128813] CallbackActionHandler:732 Error in action callback -- -207 (cookie 0x2899)
    [08:41:44.407203] CallbackActionHandler:732 Error in action callback -- -208 (cookie 0x289b)
    [08:41:44.407239] CallbackActionHandler:732 Error in action callback -- -208 (cookie 0x289c)
    [08:41:52.136336] CallbackActionHandler:732 Error in action callback -- -207 (cookie 0x28a1)
    [08:41:53.421141] CallbackActionHandler:732 Error in action callback -- -207 (cookie 0x28a0)
    [08:41:53.431119] CallbackActionHandler:732 Error in action callback -- -208 (cookie 0x28a2)
    [08:41:56.695031] CallbackActionHandler:732 Error in action callback -- -208 (cookie 0x28a3)
    [08:42:01.303022] CallbackActionHandler:732 Error in action callback -- -208 (cookie 0x28a4)
    [08:42:01.591030] CallbackActionHandler:732 Error in action callback -- -208 (cookie 0x28a5)
    [08:42:10.451856] CallbackActionHandler:732 Error in action callback -- -207 (cookie 0x28a7)
    [08:42:13.125844] CallbackActionHandler:732 Error in action callback -- -207 (cookie 0x28a8)
    [08:42:14.155012] CallbackActionHandler:732 Error in action callback -- -207 (cookie 0x28a9)
    [08:42:47.451997] CallbackEventHandler:849 [0x80f3f40]: Auto-renewal failed, cannot re-subscribe
    [08:42:56.131527] UpdateMRThread:1058 [0x80f3f40]: removing renderer (752BD)

  3. #1383
    Senior Member
    Join Date
    Jan 2008
    Posts
    352
    Is it possible to use the UPNP bridge with an LMS password? Can I do it by allowing certain IP addresses in the LMS security settings?

    I've turned on the password and my UPNP player has disapppeared...

  4. #1384
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    2,591
    Quote Originally Posted by Wigster View Post
    Is it possible to use the UPNP bridge with an LMS password? Can I do it by allowing certain IP addresses in the LMS security settings?

    I've turned on the password and my UPNP player has disapppeared...
    Several things won't work if a password is set. See the UPNP settings page user guide and search for password.
    LMS 7.9.1 on VortexBox Midi box, Xubuntu 17.10, FLACs 16->24 bit, 44.1->192kbps. Touch & EDO. 2nd Touch standard.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (to A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Alternatively Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 17.10 laptop firefox/upplay or Android 'phone with Squeeze-Commander/BubbleUPnP controls LMS/Minimserver.

  5. #1385
    Senior Member
    Join Date
    Jan 2008
    Posts
    352
    I must have changed somethign in my config and I've broken UPnP Bridge. It seems my UPNP radio is detected, it is configured in the UPnP Bridge settings page, but it never appears as a player in LMS. THis is what I get in the log, the same sequence repeats over and over. The bb:bb is the proper mac address of my digital readio device (a Medion), which used to work with LMS problem free. (as far as I know, I adde and then removed a password from the LMS security pages, so it should be back to what it was)

    Code:
    [12:08:14.471] slimproto_run:576 [004C3B68] error reading from socket: Unknown error
    
    [12:08:14.487] slimproto:867 [004C3B68] connected
    [12:08:14.487] sendHELO:109 [004C3B68] mac: bb:bb:61:c3:c6:fc
    [12:08:14.487] sendHELO:110 [004C3B68] cap: Model=squeezelite,ModelName=SqueezeLite,AccuratePlayPoints=0,HasDigitalOut=0,MaxSampleRate=48000,pcm,flc,mp3
    [12:08:14.487] send_packet:86 failed writing to socket: 10053, Unknown error
    
    [12:08:14.487] send_packet:86 failed writing to socket: 10053, Unknown error
    
    [12:08:14.487] slimproto_run:576 [004C3B68] error reading from socket: Unknown error

  6. #1386
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    3,342
    Quote Originally Posted by Wigster View Post
    I must have changed somethign in my config and I've broken UPnP Bridge. It seems my UPNP radio is detected, it is configured in the UPnP Bridge settings page, but it never appears as a player in LMS. THis is what I get in the log, the same sequence repeats over and over. The bb:bb is the proper mac address of my digital readio device (a Medion), which used to work with LMS problem free. (as far as I know, I adde and then removed a password from the LMS security pages, so it should be back to what it was)

    Code:
    [12:08:14.471] slimproto_run:576 [004C3B68] error reading from socket: Unknown error
    
    [12:08:14.487] slimproto:867 [004C3B68] connected
    [12:08:14.487] sendHELO:109 [004C3B68] mac: bb:bb:61:c3:c6:fc
    [12:08:14.487] sendHELO:110 [004C3B68] cap: Model=squeezelite,ModelName=SqueezeLite,AccuratePlayPoints=0,HasDigitalOut=0,MaxSampleRate=48000,pcm,flc,mp3
    [12:08:14.487] send_packet:86 failed writing to socket: 10053, Unknown error
    
    [12:08:14.487] send_packet:86 failed writing to socket: 10053, Unknown error
    
    [12:08:14.487] slimproto_run:576 [004C3B68] error reading from socket: Unknown error
    Make sure you don't have 2 instances of the bridge running across your network
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5

  7. #1387
    Junior Member
    Join Date
    Jun 2017
    Posts
    2

    Problem compiling squeeze2upnp

    I'm trying to compile squeeze2upnp on Linux 64 (ubuntu) still I have some problem :

    ubuntu@ubuntudev:~/squeeze2upnp/LMS-to-uPnP/application$ cc -Wall -fPIC -ggdb -m64 -O2 -I/usr/include/x86_64-linux-gnu -I. -I../valgrind/memcheck -I../valgrind/include -I./squeezetiny -I./tools -I./squeeze2upnp -I./squeeze2upnp/inc -I../libupnp/1.6.19/ixml/inc -I../libupnp/1.6.19/upnp/inc -I../libupnp/1.6.19/build/inc -I../libupnp/1.6.19/threadutil/inc -D_FILE_OFFSET_BITS=64 -DNO_CODEC -I. -I../valgrind/memcheck -I../valgrind/include -I./squeezetiny -I./tools -I./squeeze2upnp -I./squeeze2upnp/inc -I../libupnp/1.6.19/ixml/inc -I../libupnp/1.6.19/upnp/inc -I../libupnp/1.6.19/build/inc -I../libupnp/1.6.19/threadutil/inc ./squeeze2upnp/webserver.c -c -o bin/x86-64/webserver.o
    In file included from ./squeeze2upnp/webserver.c:25:0:
    ./squeeze2upnp/inc/webserver.h:34:53: warning: ‘struct Extra_Headers’ declared inside parameter list
    int WebSetExtraHeaders(const char *FileName, struct Extra_Headers *Headers);
    ^
    ./squeeze2upnp/inc/webserver.h:34:53: warning: its scope is only this definition or declaration, which is probably not what you want
    ./squeeze2upnp/webserver.c: In function ‘WebGetInfo’:
    ./squeeze2upnp/webserver.c:38:38: error: ‘struct File_Info’ has no member named ‘extra_headers’
    struct Extra_Headers *Headers = Info->extra_headers;
    ^
    ./squeeze2upnp/webserver.c:40:16: error: dereferencing pointer to incomplete type ‘struct Extra_Headers’
    while (Headers->name) {
    ^
    ./squeeze2upnp/webserver.c:77:10: error: increment of pointer to an incomplete type ‘struct Extra_Headers’
    Headers++;

    Any Idea ?

    I need to compile this because I have some problem for connecting squeeze2upnp to upmpdcli for playing music (need to see what's going on putting more logs)

    squeeze2upnp log side
    [17:59:14.952347] process_strm:216 [0x730d70] strm command s
    [17:59:14.952436] process_strm:290 [0x730d70], strm s autostart: 1 transition period: 0 transition type: 0 codec: p
    [17:59:14.952482] sendSTAT:143 [0x730d70]: STAT:[STMf] msplayed 0
    [17:59:14.952884] sq_callback:281 [0x78f770]: codec, ch:2, s:16, r:44100
    [17:59:14.953003] sq_callback:296 [0x78f770]: no matching codec in player
    [17:59:14.953046] sendSTAT:143 [0x730d70]: STAT:[STMn] msplayed 0
    [17:59:15.100224] XMLGetFirstDocumentItem:69 (BUG) ixmlNode_getFirstChild(tmpNode) returned NULL
    [17:59:15.100292] XMLGetFirstDocumentItem:69 (BUG) ixmlNode_getFirstChild(tmpNode) returned NULL
    [17:59:15.102009] SyncNotifState:479 UpMpd: uPNP stop
    [17:59:15.102043] sq_notify:1098 [0x730d70] notify STOP

    Thanks and Best Regards

  8. #1388
    Junior Member
    Join Date
    May 2017
    Posts
    12
    Hi philippe,

    Your link from post 1 to the userguide for upnp bridge is not reachable.
    Please can you check it
    Best regards

  9. #1389
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    2,591
    Quote Originally Posted by kusselin View Post
    Hi philippe,

    Your link from post 1 to the userguide for upnp bridge is not reachable.
    Please can you check it
    Best regards
    Works for me in the UK at 13:50 GMT on 21st June (version 0.2.12.2 but I doubt that matters).
    LMS 7.9.1 on VortexBox Midi box, Xubuntu 17.10, FLACs 16->24 bit, 44.1->192kbps. Touch & EDO. 2nd Touch standard.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (to A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Alternatively Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 17.10 laptop firefox/upplay or Android 'phone with Squeeze-Commander/BubbleUPnP controls LMS/Minimserver.

  10. #1390
    Junior Member
    Join Date
    Jun 2017
    Posts
    2
    Hi there,

    Is someone already face this issue ?

    I cannot discover anything on my network with LMS-to-upnp but I can see my 2 Xiaomi Network Speaker by using gssdp-discover -i eth0

    Here is the LMS-to-Upnp log

    Starting Squeeze2upnp: /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/UPnPBridge/Bin/squeeze2upnp-x86-64-static -Z -I -f /var/log/squeezeboxserver/upnpbridge.log -d all=debug -x /var/lib/squeezeboxserver/prefs/upnpbridge.xml
    [13:43:18.820648] main:1579 Starting squeeze2upnp version: v0.2.12.2 (May 19 2017 @ 17:33:31)
    [13:43:18.821339] uPNPInitialize:1172 uPNP init success - 192.168.1.109:49152
    [13:43:18.821364] uPNPInitialize:1183 ControlPoint registered
    [13:43:18.821373] uPNPInitialize:1194 WebServer enabled
    [13:43:18.821381] uPNPInitialize:1205 VirtualDir set for Squeezelite
    [13:43:18.821388] uPNPInitialize:1222 Callbacks registered for VirtualDir
    [13:43:20.025562] CallbackEventHandler:757 Answer to uPNP search -671084040
    [13:43:20.515317] CallbackEventHandler:757 Answer to uPNP search -603975176
    [13:43:20.936638] CallbackEventHandler:757 Answer to uPNP search -671082376
    [13:43:21.127986] CallbackEventHandler:757 Answer to uPNP search -603975000
    [13:43:33.003754] UpdateMRThread:978 Begin UPnP devices update
    [13:43:33.027851] UpdateMRThread:1065 Updating configuration /var/lib/squeezeboxserver/prefs/upnpbridge.xml

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •