Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 91 1231151 ... LastLast
Results 1 to 10 of 901
  1. #1
    Senior Member pinkdot's Avatar
    Join Date
    Nov 2009
    Location
    The Netherlands
    Posts
    842

    LmsUpdate: up-to-date Synology packages

    Hello all,

    LmsUpdate is a 1 on 1 copy of the Synology beta LMS package with additional updates from Slimdevices.
    You can either install this as an update over your existing Synology LMS installation, or as a fresh install. Only DSM5/6 and DSM4 (some arch's) are supported.
    Make sure that no SSODS or LmsRepack instances are running/active. If so remove these first and reboot your nas before continuing.

    Port 9002 is used (same as Synology package).
    - LmsUpdate = 7.9.0 = offical slimdevices community release status = no longer receiving updates. This includes all architectures. LmsUpdate will only see new light when Synology decides to update their current Beta package to the 7.9.1 branch! -


    Greetings,

    Martin


    You can also find a thread on the Dutch Synology Forum: http://www.synology-forum.nl/overige...0-voor-dsm-5-*

    -----------Download location-----------

    -----------Current version-----------
    • DSM6* - 7.9.0.164.1150
    • DSM5* - 7.9.0.062.1150 (DSx10 series)
    • DSM4* - 7.9.0.023.1150 (DSx09 series)


    ----------- Installation-----------
    First: deinstall any other instances running.
    • Deinstall all running SSODS or stop LmsRepack instances.
    • Reboot the nas.

    Second install the Synology Logitech Media Server 7.9.0 beta package (if you haven't already installed it)
    • In Package Center: go to ->settings -> activate the beta channel.
    • Refresh the package list and install the Logitech Media Server 7.9.0 beta.
    • Open the webui (port 9002) and configure LMS.

    Then, install LmsUpdate.
    • Download the correct LmsUpdate package to your computer. (Make sure the file extension is .spk! Some browsers change the file extension during download for no reason.)
    • In Package Center: go to ->settings -> set trust level to 'all pubishers'.
    • In Package Center: go to -> manual Install, and install your downloaded package.
    • Report any issues.
    • Enjoy your music.



    ----------- Additional Repo for DSDplayer plugin (intel nas only, on DSM5 or DSM6) -----------


    ----------- Additional LmsUpdate skin -----------


    ----------- Lame -----------
    Lame is only needed for downsampling a mp3-stream. It is not needed for MP3 playback!
    Lame is included in the DSM5 packages of the following architectures:
    • Avoton, Bromolow, Braswell, Cederview, X86
    • Armade370, Armada375
    • Evansport
    • From version 062.0008 -> 88f6281, ppc854x, Armadaxp



    ----------- Disclaimer -----------
    The usual ;-) Use at your own risk, I won't be responsible for any damages caused to your Synology Nas or to yourself. In most cases if something breaks, removing LmsUpdate from your Nas should fix it.
    Last edited by pinkdot; 2017-04-13 at 11:50.
    -Synology nas DS115 - (LmsUpdate) + (LmsRepack)
    -RPI 3 (Moode 3.6 + LibreSpot), IQaudIO Pi-DAC PRO - Exposure 3010S2 - PMC GB1i
    -2x Radio
    -Laptop - openSUSE Leap - LMS/Squeezelite

  2. #2
    Installed on DS214+ (DSM 5.2-5565), using SBC and Squeezebox Radio with frontend iPeng on iPad.
    Quick test successful. Can play music.

    Many thanks and regards

    Jacob

  3. #3

    [Test] Repo for LMS 7.9.0 on Synology DSM 5.*

    Hello,
    Installed on DS214 with DSM5.2, using SBT + iPeng on Ipad, with Qobuz and Ickstream plugins.
    Everything fine !
    (Just had some trouble to install it, 1st because I had no Perl package previously installed, and next because Previous LMS was not properly removed (i had to remove it using SSODS option to "uninstall LMS" since my 1st attempt through DSM5.2 upgrade (which killed SSODS and LMS) + SSODS directory erased not efficient !)

    Thank a lot Pinkdot !

    Can you just confirm that next LMS update will be automatic (if option selected on DSM) and that my settings will be kept even if package updated ?
    Last edited by axelwin; 2015-05-14 at 03:56.

  4. #4
    Senior Member pinkdot's Avatar
    Join Date
    Nov 2009
    Location
    The Netherlands
    Posts
    842
    Yes, next update will keep all prefs and libraries! Good to hear it worked out fine!
    -Synology nas DS115 - (LmsUpdate) + (LmsRepack)
    -RPI 3 (Moode 3.6 + LibreSpot), IQaudIO Pi-DAC PRO - Exposure 3010S2 - PMC GB1i
    -2x Radio
    -Laptop - openSUSE Leap - LMS/Squeezelite

  5. #5

    Worked for me

    Worked perfect on my 710+, did an update from 7.8

    Thx for your work!

    Quote Originally Posted by pinkdot View Post
    Hello all,

    Just created a repository for Logitech Media Server on Synology nas. I repacked the latest official version of LMS provided by Synology. So updated the package from 7.7.3 to 7.9.0. Most architectures are supported. Just add the repo to your Package Center in DSM 5.0 or higher.
    Make sure before installing the new package to remove any version of LMS (outside the repository) on your nas,

  6. #6
    Martin

    Thanks so much for doing this. I was running SSODS on my 214play very successfuly but thought I'd give this a go. The installation was painless and the plugin updates allowed me to do some tidying up. The whole library scan was a great deal faster.

    I really appreciate the work.

    Cheers!

    Richard

  7. #7
    Junior Member
    Join Date
    Mar 2009
    Posts
    2

    Worked!

    Yep worked for me too.
    DS 1513+, DSM 5.2
    Thanks Pinky.

  8. #8
    Junior Member
    Join Date
    Sep 2005
    Location
    Dorset, UK
    Posts
    13
    Does NOT work on my DS412+
    Package does not appear on list things that can be installed

  9. #9
    Senior Member pinkdot's Avatar
    Join Date
    Nov 2009
    Location
    The Netherlands
    Posts
    842
    Quote Originally Posted by bilko2 View Post
    Does NOT work on my DS412+
    Package does not appear on list things that can be installed
    The DS412+ is supported as long as you're running DSM 5.*
    If you do make sure you entered the repo to the Package Center, and did a refresh afterwards. Is the repo added in the Package Center?

    (You can always download and install the package manually by entering the repo url into your browser)
    -Synology nas DS115 - (LmsUpdate) + (LmsRepack)
    -RPI 3 (Moode 3.6 + LibreSpot), IQaudIO Pi-DAC PRO - Exposure 3010S2 - PMC GB1i
    -2x Radio
    -Laptop - openSUSE Leap - LMS/Squeezelite

  10. #10
    Quote Originally Posted by bilko2 View Post
    Does NOT work on my DS412+
    Package does not appear on list things that can be installed
    I was also confused on my DS214+. Package does not show up under 'All', I consider this as a non critical usability bug.

    These were my steps to be successful:
    1. Package Center -> Settings -> Trust Level 'Any publisher'
    2. Package Center -> Settings -> Package Sources -> Add -> Name 'LMS Repack', Location 'http://lms-repack.pinkdot.nl/'
    3. Package Center -> Explore -> 'Community' (not 'All'!) -> look for 'LMS Repack 7.9.0' -> Install (after having deinstalled previous version of LMS)

    Regards
    Jacob

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •