Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36
  1. #1

    Compilation Tag causing Artist/Album Artist problems

    Hi, I’m having major problems when the “Compilation” tag is set to 1 for an album, LMS appears to go very wrong in handling Artist information.

    For instance, consider a FLAC album where the files are all tagged with Album Artist = Soundtrack, Artist = individual song artists, Compilation = 1
    I have created a small test folder of the above in case it is useful (the tags are from a real compilation album, the files are just silence): https://www.dropbox.com/sh/ug4dk8l2j...oLOQWce4a?dl=0

    The 1st issue is when using LMS 7.9 configured to use the (excellent) new feature of two separate lists for Artist and Album Artist. We should expect the Album Artist eg Soundtrack to appear under the Album Artists list. However, nothing at all from the album appears under this list. I see this using both Windows and Mac servers (latest nightly builds), and on both iPeng and Logitech Web Remote. If the compilation tag is removed or set to 0, it works fine.



    The 2nd issue is a long-standing one well before LMS 7.9, it results in iPeng incorrectly displaying the Album Artist in situations where it should display the Artist (individual track artist). For example using LMS 7.9 Win or Mac, configured to use two separate lists for Artist and Album Artist or configured to use one artist list + List compilation albums under each artist:

    - in iPeng > Artist > Select the Album Artist e.g. Soundtrack > Select the Album. The tracks are all listed with the Album Artist, e.g. Soundtrack, not the individual track artist.
    - However if you go to Artist > Select an Individual Artist on the compilation e.g. Brian Eno > Select the album. The track is correctly listed with the individual track artist.

    In addition on LMS Mac but not on LMS Win:

    - in iPeng > Albums > Select the album. Strangely, some of the tracks are listed with the Album Artist, some aren’t. (On Windows all the tracks are listed correctly with individual artist)
    - if the server is configured to use one artist list ad to group compilations under ‘Various Artists’, then in iPeng > Albums > Select the album OR in iPeng > Artist > Select the Album Artist e.g. Soundtrack > Select the Album, the same - some of the tracks are listed with the Album Artist, some aren’t. (On Windows all the tracks are listed correctly with individual artist)



    I raised the 2nd issue back in 2013 where Michael and Joerg had some discussion, turns out I misunderstood that it was going to be fixed on the iPeng-side and have now been corrected that it still needs fixing on the server-side.

    This is a major issue imo, almost everyone has compilation albums in their collection, and artist browsing and artist information is as fundamental as it gets. Hoping this can be fixed once and for all!

    Thanks.

  2. #2
    Senior Member
    Join Date
    Mar 2008
    Posts
    500
    Quote Originally Posted by flimflam View Post
    For instance, consider a FLAC album where the files are all tagged with Album Artist = Soundtrack, Artist = individual song artists, Compilation = 1
    I have it in my head that the general advice has always been to code an Album Artist or a Compilation but never both.

  3. #3
    Senior Member JJZolx's Avatar
    Join Date
    Apr 2005
    Location
    Colorado
    Posts
    11,469
    Quote Originally Posted by atrocity View Post
    I have it in my head that the general advice has always been to code an Album Artist or a Compilation but never both.
    If you want the compilation to appear under the pseudo-album artist named 'Various Artists', that's true. However, it doesn't hurt anything to do so and have the album listed under another album artist's name.

  4. #4
    Senior Member Mnyb's Avatar
    Join Date
    Feb 2006
    Location
    Västerås Sweden
    Posts
    16,159
    I'm getting a somewhat different results with Logitech Media Server Version: 7.9.0 - 1426769055 @ Fri Mar 20 04:00:50 UTC 2015 .

    On web-UI i see the intended artist .

    On iPeng ( on iPad it actually also works fine to begin with except that on the currently playing track I get the "artist, soundtrack" and also after i played it .

    So before i play track 6 i iPeng I have Iggy Pop Nightclubbing Trainspotting

    Afte i play the track it displays Iggy Pop, soundtrack Nightclubbing Trainspotting untill next time I play the album .

    So I do see the artist as intended with LMS7.9 and iPeng . On a LInux server if that matters, audioscan 0.95
    --------------------------------------------------------------------
    Main hifi: Touch + CIA PS +MeridianG68J MeridianHD621 MeridianG98DH 2 x MeridianDSP5200 MeridianDSP5200HC 2 xMeridianDSP3100 +Rel Stadium 3 sub.
    Bedroom/Office: Boom
    Kitchen: Touch + powered Fostex PM0.4
    Misc use: Radio (with battery)
    iPad1 with iPengHD & SqueezePad
    (spares Touch, SB3, reciever ,controller )
    server HP proliant micro server N36L with ClearOS Linux

    http://people.xiph.org/~xiphmont/demo/neil-young.html

  5. #5
    Senior Member JJZolx's Avatar
    Join Date
    Apr 2005
    Location
    Colorado
    Posts
    11,469
    Damn. I just tested this and it sure is broken.

    If I set COMPILATION=1 and ALBUMARTIST=Various Artists, it picks up that album artist. But no others.

    Closest bug that I can find on file in the bug database is this one, but it's virtually the opposite of the behavior we're seeing, so it probably doesn't apply in 7.9.

    http://bugs.slimdevices.com/show_bug.cgi?id=9523

    If you examine any of the albums tagged as described (e.g., in the web interface), it clearly shows the correct album artist. So the bug must be in the code to retrieve the list of album artists. It appears to be suppressing those having compilation albums, except for the one named 'Various Artists'.

  6. #6
    Senior Member JJZolx's Avatar
    Join Date
    Apr 2005
    Location
    Colorado
    Posts
    11,469
    Looks like I found this bug back in July, but never filed a bug report.

    http://forums.slimdevices.com/showth...l=1#post786680

    Bug report filed. Add comments, if you like.

    http://bugs.slimdevices.com/show_bug.cgi?id=18130

  7. #7
    JJZolx - many thanks, you are exactly right about 'problem 1' (or Bug 18130 as it is now known!)

    Mnyb - you won't see 'problem 2' in Logitech's Web UI, because iPeng queries the information differently. It also sounds like in iPeng you may be looking at the tracks in the playlist section, not in the 'browsing library' section? It is the 'browsing' section where the problem arises, i.e. before anything is even added to the playlist or played whatsoever. This is what my screen grab shows, but I probably should have been clearer in my text: when I said 'select album' I meant select to browse, not select to start playing. Would you be able to have another look and check again? Many thanks.

  8. #8
    Senior Member Mnyb's Avatar
    Join Date
    Feb 2006
    Location
    Västerås Sweden
    Posts
    16,159
    Quote Originally Posted by flimflam View Post
    JJZolx - many thanks, you are exactly right about 'problem 1' (or Bug 18130 as it is now known!)

    Mnyb - you won't see 'problem 2' in Logitech's Web UI, because iPeng queries the information differently. It also sounds like in iPeng you may be looking at the tracks in the playlist section, not in the 'browsing library' section? It is the 'browsing' section where the problem arises, i.e. before anything is even added to the playlist or played whatsoever. This is what my screen grab shows, but I probably should have been clearer in my text: when I said 'select album' I meant select to browse, not select to start playing. Would you be able to have another look and check again? Many thanks.
    In iPeng:

    If i browse thougth the "album" or the "new music" or the "compilations" menu i see the track artist for every song . Works as expected .

    If i browse thougth artist menu and the artist "soundtrack" i get the album trainspotting ,but here only the artist soundtrack is presented for every track , but is this really wrong ? I specifically browsed to the artist soundtrack and got an album by that artist . If I browse through artist Iggy Pop to the album trainspotting I see the 2 songs he's on in this album .
    So browsing by artist gives you songs by that artist ,seems right to me .

    I would not use an albumartist on this album but rather the genre "soundtrack" but that's me

    But the bug that the albumartist is surpressed by the compilation=1 tag remains , that's a very clear bug to me .
    --------------------------------------------------------------------
    Main hifi: Touch + CIA PS +MeridianG68J MeridianHD621 MeridianG98DH 2 x MeridianDSP5200 MeridianDSP5200HC 2 xMeridianDSP3100 +Rel Stadium 3 sub.
    Bedroom/Office: Boom
    Kitchen: Touch + powered Fostex PM0.4
    Misc use: Radio (with battery)
    iPad1 with iPengHD & SqueezePad
    (spares Touch, SB3, reciever ,controller )
    server HP proliant micro server N36L with ClearOS Linux

    http://people.xiph.org/~xiphmont/demo/neil-young.html

  9. #9
    Thank you Mnyb - so, you have reproduced the behaviour of 'problem 2' (using LMS Linux & iPeng on iPad, where it acts in similar fashion to LMS Windows & iPeng for iPhone).

    It is obviously a bug imo: when there is a list of albums, the album title and the album artist should be displayed..... and when there is a list of tracks, the track title and the track artist should be displayed, simple as that. Displaying the album artist instead of the track artist is useless and perverse, you need to see the track artist at this stage. It's no different if you then go on to add the same tracks to the playlist - you want to see the track artist with the track title don't you? And if you browsed to the album directly through the Album list instead of through the Artist list - again you want to see the track artist with the track title, there is no difference. You are right that the server is behaving correctly in filtering songs by the artist selected, but that is not the problem (we have filtered by Album Artist and all the songs on the album correctly show up). The problem is we then have track titles displayed accompanied by album artist not track artist, and that can't be right.

    I raised it to Joerg (iPeng) and Michael Herger in 2013, they both agreed it was a problem. Hopefully Michael can come to the rescue again!! Please!

    (As for tagging, I deliberately chose an Album Artist tag which would be easy to follow for testing, it's just an example. Although I do actually use it as well and believe it is valid, whereas Soundtrack to me is not a genre of music. It is a useful way of organising my compilations for access, other Album Artist names I use are things like Wire Magazine CDs, Soul Jazz Records Compilations and so on)

  10. #10
    Senior Member Mnyb's Avatar
    Join Date
    Feb 2006
    Location
    Västerås Sweden
    Posts
    16,159
    Quote Originally Posted by flimflam View Post
    Thank you Mnyb - so, you have reproduced the behaviour of 'problem 2' (using LMS Linux & iPeng on iPad, where it acts in similar fashion to LMS Windows & iPeng for iPhone).

    It is obviously a bug imo: when there is a list of albums, the album title and the album artist should be displayed..... and when there is a list of tracks, the track title and the track artist should be displayed, simple as that. Displaying the album artist instead of the track artist is useless and perverse, you need to see the track artist at this stage. It's no different if you then go on to add the same tracks to the playlist - you want to see the track artist with the track title don't you? And if you browsed to the album directly through the Album list instead of through the Artist list - again you want to see the track artist with the track title, there is no difference. You are right that the server is behaving correctly in filtering songs by the artist selected, but that is not the problem (we have filtered by Album Artist and all the songs on the album correctly show up). The problem is we then have track titles displayed accompanied by album artist not track artist, and that can't be right.

    I raised it to Joerg (iPeng) and Michael Herger in 2013, they both agreed it was a problem. Hopefully Michael can come to the rescue again!! Please!

    (As for tagging, I deliberately chose an Album Artist tag which would be easy to follow for testing, it's just an example. Although I do actually use it as well and believe it is valid, whereas Soundtrack to me is not a genre of music. It is a useful way of organising my compilations for access, other Album Artist names I use are things like Wire Magazine CDs, Soul Jazz Records Compilations and so on)
    Album menu works its only in the artist menu I see this behaviour , that’s the only one and it differs from the web-UI . all other menus worked for me

    There are these settings in LMS :

    Filter Genres at the Album & Track Level.

    Filter Contributor Roles at the Album & Track Level

    They do nothing for me rigth now ? they should offer some control ? are they also broken ?
    --------------------------------------------------------------------
    Main hifi: Touch + CIA PS +MeridianG68J MeridianHD621 MeridianG98DH 2 x MeridianDSP5200 MeridianDSP5200HC 2 xMeridianDSP3100 +Rel Stadium 3 sub.
    Bedroom/Office: Boom
    Kitchen: Touch + powered Fostex PM0.4
    Misc use: Radio (with battery)
    iPad1 with iPengHD & SqueezePad
    (spares Touch, SB3, reciever ,controller )
    server HP proliant micro server N36L with ClearOS Linux

    http://people.xiph.org/~xiphmont/demo/neil-young.html

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •