Home of the Squeezebox™ & Transporter® network music players.
Page 3 of 16 FirstFirst 1234513 ... LastLast
Results 21 to 30 of 157
  1. #21
    Senior Member Apesbrain's Avatar
    Join Date
    Jun 2005
    Location
    East Coast, USA
    Posts
    1,145
    Quote Originally Posted by reinholdk View Post
    Does this mean, adding the parameter manually to the imagepath value in the Registry didn't work?
    Correct, added this way the parameter is ignored. I've tried various other ways of adding the parameter via new registry keys/subkeys and by starting an alternative service via NSSM and none have worked so far. I was able to schedule a task to run at Windows start that runs LMS --nomysqueezebox.

    Whenever I upgrade LMS I'll need to remember to disable the service it installs so only the "task" version is running. It can wait but eventually this is something that will need to be solved better if it is going to work for most Windows users.

  2. #22
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    2,452
    Quote Originally Posted by Apesbrain View Post
    I was able to schedule a task to run at Windows start that runs LMS --nomysqueezebox.
    I'd be grateful if you could describe with word and gesture just what you've done to run without MSB
    Study/Server - LMS 7.9.1 - Pi3/Pi screen/HiFiBerry DAC+/piCorePlayer 3.22/jivelite, 25K library on WDMyCloud, cache and playlists on a USB stick (formatted ntfs).
    Lounge - Pi 2/Max2Play > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Pi3 > HiFiBerry AMP+/retro radio
    Garage - Pi3/Pi screen/HiFiBerry DAC+/piCorePlayer 3.22 > Edifier R980T
    In car - LMS 7.9.1 > RPi3/Max2Play > HiFiBerry DAC+ > car's hifi (files on a 2TB portable USB drive)
    Spares - 1xTouch, 1xSB3, 1xRadio, 1xBoom

  3. #23
    Junior Member
    Join Date
    Jan 2013
    Location
    USA-Wisconsin
    Posts
    27

    What about TuneIn Radio?

    Michael, Hi.

    I understand that all of the MSB apps will go away except for the 3rd party ones but I seem to remember that one of the changes to LMS 7.8 was the ability to run the TuneIn application without the need for MSB. Is this still the case? If so, how would a user go about doing this?

    Also, is it safe to assume that the UE to SB conversion will also go away when MSB is shut down?

    Thanks,

    Bill
    Server: HP Pavilion (AMD E-450 CPU) running Vortexbox v2.4 and LMS v7.9.1
    Family Room: Touch > Pioneer AV Receiver > Infinity Reference Speakers
    Living Room: Squeezebox Radio x2 (configured as separate left and right)
    Master Bedroom: UE Squeezebox Radio x2 (configured as separate left and right)
    Media Room: Touch > Sony AV Receiver > Infinity Reference Speakers
    Home Office: UE Squeezebox Radio
    Controller: Nextbook HD8 tablet, Orange Squeeze. Streaming: Spotify Spares: Touch x1, Radio x3

  4. #24
    Senior Member Apesbrain's Avatar
    Join Date
    Jun 2005
    Location
    East Coast, USA
    Posts
    1,145
    Quote Originally Posted by kidstypike View Post
    I'd be grateful if you could describe with word and gesture just what you've done to run without MSB
    Sure, first disable the normal LMS service start:
    Start > Run > Services (%windir%\system32\services.msc); scroll down to "Logitech Media Server", right-click to "Properties", then "Stop" and "Disable"

    Now create a scheduled task to run LMS --nomysqueezebox at Windows start:
    Start > Run > Task Scheduler (%windir%\system32\taskschd.msc /s); "Create task":
    GENERAL: give it a name and description, "Run whether user is logged on or not", "Run with highest privileges"
    TRIGGERS: "At startup"
    ACTIONS: "Start a program" > enter path to squeezesvr.exe; enter --nomysqueezebox in "Arguments"
    Set CONDITIONS and SETTINGS as you wish.

    Reboot and LMS should be started without the "MySqueezebox" Settings tab.

    EDIT: A few things are not ideal about this solution but it's all we have for now:
    1. You need to remember to repeat the "disable normal LMS service start" whenever you update your LMS version
    2. Windows can monitor running services and restart them if they crash; a task at startup can't do the same.
    Last edited by Apesbrain; 2015-02-25 at 12:46.

  5. #25
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    2,452
    Quote Originally Posted by Apesbrain View Post
    Sure, first disable the normal LMS service start:
    Start > Run > Services (%windir%\system32\services.msc); scroll down to "Logitech Media Server", right-click to "Properties", then "Stop" and "Disable"

    Now create a scheduled task to run LMS --nomysqueezebox at Windows start:
    Start > Run > Task Scheduler (%windir%\system32\taskschd.msc /s); "Create task":
    GENERAL: give it a name and description, "Run whether user is logged on or not", "Run with highest privileges"
    TRIGGERS: "At startup"
    ACTIONS: "Start a program" > enter path to squeezesvr.exe; enter --nomysqueezebox in "Arguments"
    Set CONDITIONS and SETTINGS as you wish.

    Reboot and LMS should be started without the "MySqueezebox" Settings tab.

    EDIT: A few things are not ideal about this solution but it's all we have for now:
    1. You need to remember to repeat the "disable normal LMS service start" whenever you update your LMS version
    2. Windows can monitor running services and restart them if they crash; a task at startup can't do the same.
    Thanks for the detailed instructions, but I've struggled to get it to work.

    I disabled LMS in services, created a new task as you described, but it will not run at startup, I can start it manually, but a prompt box sits on the desktop, as soon as I close this, LMS stops. Plus the mysqueezebox tab is still there.
    I'll have another bash at this tomorrow

    Thanks again.
    Study/Server - LMS 7.9.1 - Pi3/Pi screen/HiFiBerry DAC+/piCorePlayer 3.22/jivelite, 25K library on WDMyCloud, cache and playlists on a USB stick (formatted ntfs).
    Lounge - Pi 2/Max2Play > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Pi3 > HiFiBerry AMP+/retro radio
    Garage - Pi3/Pi screen/HiFiBerry DAC+/piCorePlayer 3.22 > Edifier R980T
    In car - LMS 7.9.1 > RPi3/Max2Play > HiFiBerry DAC+ > car's hifi (files on a 2TB portable USB drive)
    Spares - 1xTouch, 1xSB3, 1xRadio, 1xBoom

  6. #26
    Senior Member Apesbrain's Avatar
    Join Date
    Jun 2005
    Location
    East Coast, USA
    Posts
    1,145
    Quote Originally Posted by kidstypike View Post
    Thanks again.
    I took some screenshots and attached them if helpful. In the end I don't think this is a good solution anyway. Twice today I found my server unresponsive because LMS had shutdown. It never does that when started normally.

    NoMySB Task.pdf

  7. #27
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,872

    --nomysqueezebox: disable allmysb.comintegration in LMS 7.9

    > What about the "Sounds and Effects" files? How are those MP3 files
    > licensed? Can they be placed on the wiki or somewhere else so users who
    > want to download and use them locally can do so?


    No idea... I'll try to figure out by the time this becomes serious.

    --

    Michael

  8. #28
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,872

    --nomysqueezebox: disable allmysb.comintegration in LMS 7.9

    > I took some screenshots and attached them if helpful. In the end I
    > don't think this is a good solution anyway. Twice today I found my
    > server unresponsive because LMS had shutdown. It never does that when
    > started normally.


    Hmm... have to see a crash yet. Did you check the log file for any hint
    about the cause of the crash?

    --

    Michael

  9. #29
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,872

    --nomysqueezebox: disable allmysb.comintegration in LMS 7.9

    > I understand that all of the MSB apps will go away except for the 3rd
    > party ones but I seem to remember that one of the changes to LMS 7.8 was
    > the ability to run the TuneIn application without the need for MSB. Is
    > this still the case? If so, how would a user go about doing this?


    Nothing to do there. By default LMS 7.8+ doesn't use mysb's Radios menu
    any more. Only if the user has the TuneIn app installed and his username
    defined it'll use that additional information. But you can enter this in
    LMS too.

    > Also, is it safe to assume that the UE to SB conversion will also go
    > away when MSB is shut down?


    No, not safe to assume. Because there are no plans yet. But I'll do my
    best to make this not happen. I'd rather push decision makers to force
    migration of UE Smart Radios to SB Radios. This would require an
    absolute minimum infrastructure.

    --

    Michael

  10. #30
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    2,452
    Quote Originally Posted by Apesbrain View Post
    I took some screenshots and attached them if helpful. In the end I don't think this is a good solution anyway. Twice today I found my server unresponsive because LMS had shutdown. It never does that when started normally.

    NoMySB Task.pdf
    Thanks for taking the trouble.

    I still can't get it to run at startup, and if I start the task manually LMS starts and works normally but leaves a prompt box open, if I close this box LMS stops instantly.

    Server log last few lines from today:

    Code:
        ...propagated at /<C:\PROGRA~2\SQUEEZ~1\server\SQUEEZ~3.EXE>Net/HTTP/NB.pm line 32.[15-02-26 08:40:30.2929] main::init (370) Starting Logitech Media Server (v7.9.0, 1423815993, Sat Feb 14 04:05:19 CUT 2015) perl 5.014001
    [15-02-26 08:41:10.0884] Slim::Formats::XML::gotErrorViaHTTP (311) Error: getting http://opml.radiotime.com/Index.aspx?partnerId=16
    Timed out waiting for data
    [15-02-26 08:41:10.0889] Slim::Plugin::InternetRadio::Plugin::_gotRadioError (65) Unable to retrieve radio directory from SN: Timed out waiting for data
    [15-02-26 08:41:10.0899] Slim::Networking::SqueezeNetwork::Players::_players_error (337) Unable to get players from SN: Connect timed out: Bad file descriptor, retrying in 60 seconds
    [15-02-26 08:41:14.7777] Slim::Networking::UPnP::ControlPoint::_gotError (281) Error retrieving device description: Error reading headers: Server closed connection without sending any data back at /<C:\Program Files (x86)\Squeezebox\server\SqueezeSvr.exe>Net/HTTP/Methods.pm line 306.
        ...propagated at /<C:\Program Files (x86)\Squeezebox\server\SqueezeSvr.exe>Net/HTTP/NB.pm line 32.
    [15-02-26 08:43:39.8795] main::init (370) Starting Logitech Media Server (v7.9.0, 1423815993, Sat Feb 14 04:05:19 CUT 2015) perl 5.014001 [15-02-26 08:43:45.5298] Slim::Web::Cometd::handler (422) errorNeedsClient: 00:04:20:26:19:be, status, -, 10, menu:menu, useContextMenu:1, subscribe:600
    Attached Images Attached Images  
    Study/Server - LMS 7.9.1 - Pi3/Pi screen/HiFiBerry DAC+/piCorePlayer 3.22/jivelite, 25K library on WDMyCloud, cache and playlists on a USB stick (formatted ntfs).
    Lounge - Pi 2/Max2Play > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Pi3 > HiFiBerry AMP+/retro radio
    Garage - Pi3/Pi screen/HiFiBerry DAC+/piCorePlayer 3.22 > Edifier R980T
    In car - LMS 7.9.1 > RPi3/Max2Play > HiFiBerry DAC+ > car's hifi (files on a 2TB portable USB drive)
    Spares - 1xTouch, 1xSB3, 1xRadio, 1xBoom

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •