Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 16 FirstFirst 123412 ... LastLast
Results 11 to 20 of 157
  1. #11
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,872

    --nomysqueezebox: disable allmysb.comintegration in LMS 7.9

    > I've installed the Image Proxy Plugin and setup the TimThumb PHP resizer
    > on a local apache webserver and selected it from
    > Settings->Advanced->Performance->Artwork resizing. See screenshots.


    FWIW: I've removed the TimThumb default configuration from the plugin,
    as it has been discontinued due to known security issues. Please don't
    use it any more...

    http://www.binarymoon.co.uk/2014/09/timthumb-end-life/

    Oh, and considering these issues you probably shouldn't post your
    TimThumb URL here either :-P.

    > Should the scanner be using the resizer during the pre-caching artwork
    > step?


    No, the image proxy is only being used to resize _external_ artwork. Eg.
    when browsing radio stations, playing music from an online music service
    etc. Would be kind of backwards to upload local artwork to some external
    host for the resizing.

    --

    Michael

  2. #12
    Senior Member Apesbrain's Avatar
    Join Date
    Jun 2005
    Location
    East Coast, USA
    Posts
    1,145
    I am still seeing the "MySqueezebox" tab in Settings. Is this a sign that I've not succeeded in starting the server with this new switch enabled?

    Trying to figure out how to apply the switch when LMS starting as Windows service. I've added the switch onto end of ImagePath:
    HKLM\SYSTEM\CurrentControlSet\Services\squeezesvc\ ImagePath

    But I'm not sure this is working.

  3. #13
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,872

    --nomysqueezebox: disable allmysb.comintegration in LMS 7.9

    > I am still seeing the "MySqueezebox" tab in Settings. Is this a sign
    > that I've not succeeded in starting the server with this new switch
    > enabled?


    Yes, sounds like it didn't work. I'll have to check how things are done
    on Windows... haven't used it in a while. Maybe JJZolx or some of the
    other Windows expert can chime in?

    --

    Michael

  4. #14
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    1,858
    Quote Originally Posted by mherger View Post
    > I've installed the Image Proxy Plugin and setup the TimThumb PHP resizer
    > on a local apache webserver and selected it from
    > Settings->Advanced->Performance->Artwork resizing. See screenshots.


    FWIW: I've removed the TimThumb default configuration from the plugin,
    as it has been discontinued due to known security issues. Please don't
    use it any more...

    http://www.binarymoon.co.uk/2014/09/timthumb-end-life/

    Oh, and considering these issues you probably shouldn't post your
    TimThumb URL here either :-P.

    > Should the scanner be using the resizer during the pre-caching artwork
    > step?


    No, the image proxy is only being used to resize _external_ artwork. Eg.
    when browsing radio stations, playing music from an online music service
    etc. Would be kind of backwards to upload local artwork to some external
    host for the resizing.

    --

    Michael
    Thanks for the clarification. I kind of figured I didn't understand the image proxy usage case. Playing an internet stream with artwork does indeed call the local proxy.

    No worries on the url, it's only available on my private network.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 1-UE Radio
    Squeezebox client builds donations always appreciated.

  5. #15
    Junior Member
    Join Date
    Oct 2013
    Posts
    10
    If the shutdown of mysb.com is indeed inevitable, what will happen with all the plugins, like Wimp etc, that use mysb?

  6. #16
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,872

    --nomysqueezebox: disable allmysb.comintegration in LMS 7.9

    > No worries on the url, it's only available on my private network.

    That's actually a use case which might make sense even on a single
    computer (without web host): LMS is single threaded, but even cheap mini
    computers like the Pi are multi-core nowadays. By offloading the image
    proxy to another task on the same computer, we could take advantage of
    those additional cores. Single-threaded but multi-tasking.

    --

    Michael

  7. #17
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,872

    --nomysqueezebox: disable allmysb.comintegration in LMS 7.9

    > If the shutdown of mysb.com is indeed inevitable, what will happen with
    > all the plugins, like Wimp etc, that use mysb?


    They will no longer be available. You'll have to use some 3rd party
    solution like Triode's Spotify plugin, or ickStream.

    --

    Michael

  8. #18
    formerly known as Fletch
    Join Date
    May 2005
    Posts
    2,240
    What about the "Sounds and Effects" files? How are those MP3 files licensed? Can they be placed on the wiki or somewhere else so users who want to download and use them locally can do so?

  9. #19
    Senior Member Apesbrain's Avatar
    Join Date
    Jun 2005
    Location
    East Coast, USA
    Posts
    1,145
    Quote Originally Posted by mherger View Post
    > I am still seeing the "MySqueezebox" tab in Settings. Is this a sign
    > that I've not succeeded in starting the server with this new switch
    > enabled?


    Yes, sounds like it didn't work. I'll have to check how things are done
    on Windows... haven't used it in a while. Maybe JJZolx or some of the
    other Windows expert can chime in?

    --

    Michael
    I got it to work on a manual service stop/restart but haven't figured out to have it stick during a server/system reboot.

    EDIT: Trying to use NSSM to install this as a service but getting a "The parameter is incorrect" error. Any ideas on that would be appreciated.
    Last edited by Apesbrain; 2015-02-24 at 13:52.

  10. #20
    Senior Member
    Join Date
    Jan 2010
    Posts
    537
    Quote Originally Posted by Apesbrain View Post
    I got it to work on a manual service stop/restart but haven't figured out to have it stick during a server/system reboot.

    EDIT: Trying to use NSSM to install this as a service but getting a "The parameter is incorrect" error. Any ideas on that would be appreciated.
    Does this mean, adding the parameter manually to the imagepath value in the Registry didn't work?
    See also here.

    EDIT: this is an example of the imagepath value of a certain Windows service (note that the path can include environment variables) :
    %SystemRoot%\System32\svchost.exe -k NetworkService
    Last edited by reinholdk; 2015-02-25 at 05:40.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •