Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 92 FirstFirst 12341252 ... LastLast
Results 11 to 20 of 915
  1. #11
    Senior Member flysurfer's Avatar
    Join Date
    Aug 2013
    Location
    Leipzig - Germany
    Posts
    303
    Hi slartibartfast,

    automounted USB-Disks should appear under "/media/usb" even after restart. If you use the desktop environment then you can also mount as user odroid and then the mountpoint is little different. UTF-8 should also work and the mountpoints of the USB-drives are managed by usbmount (program). You can use the "filesystem mount"-tab on the webinterface to share the data to other network users via samba OR mount network resources (e.g. from a NAS).

    XBMC: remote access is enabled by default as you have seen - black screen with console may appear if you boot the device and it is NOT connected via HDMI (then it is not possible to start the X-Server and you have to reboot).

    LMS: the max2play-image has some configs from the LMS left on the SD-card. There is the radio station in the configs that I used to test with - just delete it if you don't like it
    2 x Max2Play on ODROID U2/U3 with LMS, Squeezelite, Shairport, XBMC
    1 x Squeezebox Receiver
    1 x Denon 1713 AVR + Nubert 5.1 System
    iPeng

    Max2Play Webinterface and SD-Image: http://www.max2play.com/
    Max2Play Shop: http://shop.max2play.com/

  2. #12
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    1,121
    Quote Originally Posted by flysurfer View Post
    Hi slartibartfast,

    automounted USB-Disks should appear under "/media/usb" even after restart. If you use the desktop environment then you can also mount as user odroid and then the mountpoint is little different. UTF-8 should also work and the mountpoints of the USB-drives are managed by usbmount (program). You can use the "filesystem mount"-tab on the webinterface to share the data to other network users via samba OR mount network resources (e.g. from a NAS).

    XBMC: remote access is enabled by default as you have seen - black screen with console may appear if you boot the device and it is NOT connected via HDMI (then it is not possible to start the X-Server and you have to reboot).

    LMS: the max2play-image has some configs from the LMS left on the SD-card. There is the radio station in the configs that I used to test with - just delete it if you don't like it
    Hi,
    UTF8 is indeed working now, my problem showed up when I copied the contents of my old external HDD to a new WD elements external HDD using windows. When I plugged the new drive into the ODROID and viewed it over SAMBA accented characters etc showed incorrectly so I assumed the drive was not mounted with UTF8 compatibility. After deleting all the incorrectly displayed files and recopying them over the SAMBA share everything is fine with UTF8.

    I think the automount problem may be related to the WD Elements HDD. Googling this produced lots of results. I can get it mounted again by unplugging and replugging the usb cable and the ODROID power but I have not found the optimum sequence for doing this yet. Maybe a Cron job would solve this since from what I've read manual mounting works when automounting fails but that is going to take a bit more research as Ubuntu is still a bit of a mystery to me.

    Rebooting did solve the XBMC issue.

    Overall I'm very pleased with the way it is performing, a complete scan of 32000 tracks takes about 20 mins now rather than well over 90 mins on my Goflex net.

    Is it advisable to update Ubuntu? (Just updates to 13.10 not to 14)

  3. #13
    Senior Member flysurfer's Avatar
    Join Date
    Aug 2013
    Location
    Leipzig - Germany
    Posts
    303
    Good to hear that its working! You should not update the max2play-image to Ubuntu 14 as there are a lot of changes that might crash the functionality.
    2 x Max2Play on ODROID U2/U3 with LMS, Squeezelite, Shairport, XBMC
    1 x Squeezebox Receiver
    1 x Denon 1713 AVR + Nubert 5.1 System
    iPeng

    Max2Play Webinterface and SD-Image: http://www.max2play.com/
    Max2Play Shop: http://shop.max2play.com/

  4. #14
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    1,121
    Quote Originally Posted by flysurfer View Post
    Good to hear that its working! You should not update the max2play-image to Ubuntu 14 as there are a lot of changes that might crash the functionality.
    What about security updates to Ubuntu 13.10?

  5. #15
    Senior Member
    Join Date
    Mar 2013
    Posts
    652
    @Max2Play

    I just moved my Server over to your image from Squeezeplug 7. I like the webinterface (although I did a have a few hassles installing the latest 7.9 nightly...it chose an older one for some reason and I had to manually switch to the latest Nightly).
    Also, is there a way to update to latest Squeezelite (Ralphys version if possible) from the Web-GUI? That would be neat. Just like in PiCorePlayer. Some control over Squeezelite settings would be helpful as well, like asla buffer, resampling and so on.
    I think the "extended options" section could be filled with quite a few additions...

    I could not find a way to resized the filesystem to the full size of my SD card. Is this done automatically or do I have to do this manually via SSH?

    Thanks.
    Last edited by CommanderROR; 2014-08-02 at 08:17.

  6. #16
    Senior Member bakker_be's Avatar
    Join Date
    May 2009
    Location
    Westerlo, Belgium
    Posts
    603
    Hi,
    in the German thread I read that the Odroid with Max2Play doesn't output 5.1 without external soundcard. What do you mean exactly by that:

    • It doesn't do analog 5.1 over HDMI
    • It doesn't do DTS/ Dolby Digital passthrough over HDMI
    • no 5.1 at all over HDMI
    • something else entirely
    Main System: Touch; Marantz SR-5004; TMA Premium 905; TMA Premium 901; BK Monolith+ FF; HDI Dune Smart D1; Pioneer PDP-LX5090H
    Workshop: iPad 32GB Wifi + Squeezepad (local playback activated)
    Wherever needed: Acer Iconia Tab A700 + Squeezeplayer
    Car: BananaPi LMS + Squeezeplayer on Android phone - Controller TBD ...

  7. #17
    Senior Member flysurfer's Avatar
    Join Date
    Aug 2013
    Location
    Leipzig - Germany
    Posts
    303
    Hi bakker_be,

    the ODROID cannot 5.1 at all over HDMI. If you want 5.1 you always have to connect a external soundcard via USB. This is not a limitiation from Max2Play.

    @CommanderROR:
    To expand the filesystem you have to use SSH. There is no function for this yet.

    To configure Squeezelite and other things in detail (buffer, etc.) you also have to use ssh right now. If anyone likes to support me in adding this to the webinterface -> I don't know which settings would be usefull as I am happy to use it "as it comes" without much additional settings.
    2 x Max2Play on ODROID U2/U3 with LMS, Squeezelite, Shairport, XBMC
    1 x Squeezebox Receiver
    1 x Denon 1713 AVR + Nubert 5.1 System
    iPeng

    Max2Play Webinterface and SD-Image: http://www.max2play.com/
    Max2Play Shop: http://shop.max2play.com/

  8. #18
    Senior Member
    Join Date
    Mar 2013
    Posts
    652
    @flysurfer

    maybe you can contact the guy that created PiCorePlayer. He has somebody why helped him with the webinterface.
    Configuring Squeezelite and expanding rootfs are essential IMHO.

    Another idea: webinterface could give us a choice to do scheduled updates. I'd like to see an auto-update every week. It should update to latest webinterface, latest LMS nightly, latest Ralphy release of Squeezelite, and then reboot to make sure everything is up to date, including the LMS plugins.

    Also, there are still bugs in your webinterface, especially when stopping and starting LMS it always gives me errors even though it actually works...

    Still, it's a good start. Squeezeplug is great, but a webinterface is so much nicer to use...
    Last edited by CommanderROR; 2014-08-06 at 05:39.

  9. #19
    Senior Member
    Join Date
    Mar 2013
    Posts
    652
    @flysurfer

    I updated to your 1.01 release yesterday and like the new features. Sadly it seems the webinterface is still buggy, at least on Chrome browser, it installed LMS 7.7.0 when I chose "latest 7.9.0 nightly". Entering the link manually works fine. I'm not sure what went wrong, but I repeated the process twice, and got the same result both times.

  10. #20
    Senior Member flysurfer's Avatar
    Join Date
    Aug 2013
    Location
    Leipzig - Germany
    Posts
    303
    @CommanderROR
    thanks for your feedback!
    I just tested the squeezeserver install in chrome and everything works as expected - I cannot reproduce the problem. It is necessary that you have javascript in your browser enabled for this installation. The link from the package that you choose from the select-box will be copied to the input box right obove the "start installation"-button with javascript. Can you confirm that the link is correct after you choose the package?
    2 x Max2Play on ODROID U2/U3 with LMS, Squeezelite, Shairport, XBMC
    1 x Squeezebox Receiver
    1 x Denon 1713 AVR + Nubert 5.1 System
    iPeng

    Max2Play Webinterface and SD-Image: http://www.max2play.com/
    Max2Play Shop: http://shop.max2play.com/

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •