Home of the Squeezebox™ & Transporter® network music players.
Page 11 of 11 FirstFirst ... 91011
Results 101 to 109 of 109
  1. #101
    Junior Member
    Join Date
    May 2014
    Posts
    11
    Quote Originally Posted by castalla View Post
    Try with nfs.

    But you seem to be stabbing at various combinations almost randomly.

    You bet I am, have no idea what Im doing.

    Will try the above and check back in awhile.

    Quote Originally Posted by castalla View Post
    username=guest,password=,sec=ntlm
    So user= guest and pass = (blank)?

    Thanks



    Thanks
    Bill
    Last edited by billm555; 2014-05-13 at 09:51.

  2. #102
    Senior Member
    Join Date
    Feb 2008
    Posts
    4,181
    Quote Originally Posted by billm555 View Post
    You bet I am, have no idea what Im doing.

    Will try the above and check back in awhile.



    So user= guest and pass = (blank)?

    Thanks



    Thanks
    Bill
    Type exactly what I wrote above - or you can copy it in windows then go to fstab edit and insert. Make sure any other refs to the nas address are removed
    Touch, Logitech Radio, Logitech UE Radio, O2 Joggler + SqpOS
    UPnPBridge - 2 paired Sonos Play1 speakers; Rocki - Sony SRS-BTM8 speaker; Pioneer WX-SMA1 speaker; - PURE One Flow internet radio: PURE Jongo S3x ; Jongo T2; Libratone Zipp
    Castbridge - Chromecast 1 + Chromecast Audio
    AirplayBridge - Loewe Airspeaker
    SB Player - Fire TV
    ------------------------------------------------------------------------------------

  3. #103
    Junior Member
    Join Date
    May 2014
    Posts
    11
    Ok did exactly as you wrote, did mkdir /mnt/samba/music 1st
    if i do lst /mnt/samba/ it shows up with a few other folders, itunes, backup, media, etc

    then did the fstab line
    then mount -a

    got no such file /directory exists

    Sorry about the random things I tried. Did a little googling. Hate to bother people but I'm starting to get fustrated.

    Im done for today. Start up again tomorrow.

    Im almost tempted to just use a usb drive in the PI, only have like 20g of music. But I hate to let this beat me.

    Have a good night, thanks again for the help.

    Bill

  4. #104
    Senior Member
    Join Date
    Feb 2008
    Posts
    4,181
    Don't give up - it will work!

    cifs:

    Maybe you don't have guest or anonymous access set on the nas. Then just change the user and pass to what you know are correct for the nas. If possible, switch off the nfs feature - let's start with what we know should work!

    nfs:

    //nas-address:/public/nfs /mnt/samba/music nfs username=name,password=pass


    All the refs. I've found include the : after the ip-address and before the directory.
    Not sure if ,sec=ntlm is necessary for nfs

    It's trial & error I'm afraid.
    Last edited by castalla; 2014-05-14 at 08:24.
    Touch, Logitech Radio, Logitech UE Radio, O2 Joggler + SqpOS
    UPnPBridge - 2 paired Sonos Play1 speakers; Rocki - Sony SRS-BTM8 speaker; Pioneer WX-SMA1 speaker; - PURE One Flow internet radio: PURE Jongo S3x ; Jongo T2; Libratone Zipp
    Castbridge - Chromecast 1 + Chromecast Audio
    AirplayBridge - Loewe Airspeaker
    SB Player - Fire TV
    ------------------------------------------------------------------------------------

  5. #105
    Junior Member
    Join Date
    May 2014
    Posts
    11

    Success

    Well thanks to the help of Castalla I finally got my NAS mounted. Not sure what did the trick but I believe it was an issue with my NAS itself. Made a few changes but unfortunatly all at once so Im not sure what actually fixed it.

    I made a new user and pass on the NAS, also turned off all the services that I wasnt using.

    I used this in my fstab:

    //192.168.0.102/public/music /mnt/samba/ cifs password=pass,_netdev


    Thanks again,
    Bill

    ps my NAS is a WD Mybookworld (few years old)

  6. #106
    Senior Member
    Join Date
    Feb 2008
    Posts
    4,181
    Quote Originally Posted by billm555 View Post
    Well thanks to the help of Castalla I finally got my NAS mounted. Not sure what did the trick but I believe it was an issue with my NAS itself. Made a few changes but unfortunatly all at once so Im not sure what actually fixed it.

    I made a new user and pass on the NAS, also turned off all the services that I wasnt using.

    I used this in my fstab:

    //192.168.0.102/public/music /mnt/samba/ cifs password=pass,_netdev


    Thanks again,
    Bill

    ps my NAS is a WD Mybookworld (few years old)
    Excellent! Bear in mind that the ip-address should be static (not dhcp assigned)
    Touch, Logitech Radio, Logitech UE Radio, O2 Joggler + SqpOS
    UPnPBridge - 2 paired Sonos Play1 speakers; Rocki - Sony SRS-BTM8 speaker; Pioneer WX-SMA1 speaker; - PURE One Flow internet radio: PURE Jongo S3x ; Jongo T2; Libratone Zipp
    Castbridge - Chromecast 1 + Chromecast Audio
    AirplayBridge - Loewe Airspeaker
    SB Player - Fire TV
    ------------------------------------------------------------------------------------

  7. #107
    Junior Member
    Join Date
    May 2014
    Posts
    11
    Quote Originally Posted by castalla View Post
    Excellent! Bear in mind that the ip-address should be static (not dhcp assigned)
    Ive been meaning to go and assign static to my NAS and PI.

    Will keep that in mind. Thanks.


    Bill

  8. #108
    Senior Member
    Join Date
    Feb 2008
    Posts
    4,181
    Quote Originally Posted by billm555 View Post
    Ive been meaning to go and assign static to my NAS and PI.

    Will keep that in mind. Thanks.


    Bill
    At some point unless you fix the ip-address of both then your router will likely give them new addresses. Do it asap and it's one less headache you've avoided!

    You can assign the Pi a fixed address in the squeezeplug setup - the NAS admin must have something similar.

    Good luck!
    Last edited by castalla; 2014-05-14 at 14:46.
    Touch, Logitech Radio, Logitech UE Radio, O2 Joggler + SqpOS
    UPnPBridge - 2 paired Sonos Play1 speakers; Rocki - Sony SRS-BTM8 speaker; Pioneer WX-SMA1 speaker; - PURE One Flow internet radio: PURE Jongo S3x ; Jongo T2; Libratone Zipp
    Castbridge - Chromecast 1 + Chromecast Audio
    AirplayBridge - Loewe Airspeaker
    SB Player - Fire TV
    ------------------------------------------------------------------------------------

  9. #109
    Junior Member
    Join Date
    Feb 2015
    Posts
    1

    NAS and Squeezeplug

    Hi There!
    I've installed squeezeplug v.7.50 on my RPI B+ in order to have a low power consuming squeezebox server.
    Squeezebox is succesfully connected to it, but with empty music library.
    My problem is how to set-up the media folder. Music files are stored on NAS (Iomega StorCenter ix2-200)
    I enabled NFS service on it, but can't find the way to make files visible by the squeezebox server.

    IP of the NAS is 192.168.1.100
    In Windows, the music files directory location is seen as: \\BUKOW\Music

    Please help!

    .............................................

    Second day....
    Reinstalled squeezeplug 3 times, turned off NFS on NAS and tried with Samba... still nothig
    Still empty library.
    I won't make it without your help :/

    # /mnt/hd1/itunes
    # /mnt/hd1/media
    # /mnt/hd1/media/audio
    # /mnt/hd1/media/pictures
    # /mnt/hd1/media/playlists
    # /mnt/hd1/media/video
    # /mnt/hd1/media/misc
    # /mnt/hd2/...
    # /mnt/hdx/...
    # /mnt/nfs/...
    # /mnt/samba/...
    #
    # Your manual setting should start here:
    #
    # For USB Fat/Fat32/Ext2/Ext3/Ext4 drives edit the next line e.g.:
    # /dev/sdx /mnt/hd1 auto rw,user,auto 0 0
    #
    # For USB NTFS drives edit the next line e.g.:
    # /dev/sdx //mnt/hd1 ntfs-3g defaults,locale=en_US.utf8 0 0
    #
    # For NFS shares edit the next line e.g.:
    # 192.168.2.100:/raid/data/iTunes_music /mnt/nfs nfs defaults 0 0
    #
    # For Samba Client shares edit the next line e.g.:
    # //192.168.2.10/samba /mnt/samba/ cifs username=<username>,password=<password>
    #
    # Automatic settings from SqueezePlug scripts starts here:
    //192.168.1.100/bukow/Music /mnt/samba/ cifs username=,password=
    Last edited by bukow; 2015-02-26 at 14:40.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •