PDA

View Full Version : Slimserver bug with .m3u playlist format



Pascal Herczog
2004-11-22, 05:27
Using Slimserver 5.3.1, and previous versions, on WinXP, there appears to be a
bug in the way that .m3u playlist files are handled.

Normally, all MP3 songs would correctly display in the Slimserver browser as
'title' by 'artist' from 'album', using the ID3 tag info.

However, I found that playlists created by WinAMP as .m3u files would cause the
song titles for those referenced by the playlist to appear as 'artist-title' by
'artist' from 'album', in both the left pane of Fishbone and the player's right
hand pane. This obviously also affects the Slimp3/squeezebox display of the now
playing status.

In comparing the .m3u from WinAMP, with a test created directly in Slimserver,
they look as follows:

Winamp .m3u file:
#EXTM3U
#EXTINF:270,Coldplay - Yellow
\My Music\MP3\Coldplay\Parachutes\Coldplay - 05 - Yellow - 192 kbps.mp3

Slimserver .m3u file:
#EXTM3U
#EXTINF:-1,Axel F
D:\My Music\Vinyl\12inch Singles\Harold Faltermeyer - Axel F.flac

So, it would appear that Slimserver reads the EXTINF fields and for some reason
decides to alter the title tag information that is stored about those songs in
its database.

Has anyone found the same thing? Seems like a bug to me.

Pascal

kdf
2004-11-22, 12:23
Quoting Pascal Herczog <pascal.herczog (AT) ttpcom (DOT) com>:


> So, it would appear that Slimserver reads the EXTINF fields and for some
> reason
> decides to alter the title tag information that is stored about those songs
> in
> its database.
>
> Has anyone found the same thing? Seems like a bug to me.

sounds like this bug:
http://bugs.slimdevices.com/show_bug.cgi?id=198
-kdf