PDA

View Full Version : Proxy configuration?



Craig, James (IT)
2004-10-28, 02:11
Hello Robin,
I added that code but I don't think it's the problem in my case.
The error message indicates SlimServer is talking to the proxy but not
giving it what it's looking for - the 'host' header.

I assume you've had success with configuring a proxy and hence it's just
the one here being difficult?

James


-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of Richard
Titmuss
Sent: 27 October 2004 18:41
To: Slim Devices Discussion
Subject: [slim] Proxy configuration?

James,

See http://bugs.slimdevices.com/show_bug.cgi?id=271. Only some parts of
the slimserver use the proxy at the moment, the second patch attached to

the bug report sets the proxy for all lwp requests, but it requires a
server restart to take effect. The patch is old, so may not apply
cleanly to the latest slimserver builds.

Regards,
Richard


Craig, James (IT) wrote:

>Ah now I am sure it doesn't work! I get this in the log (with suitable
>debugging turned on)
>
>2004-10-27 16:41:13.5358 Opening connection to
>http://update.slimdevices.com/update/picks.pls: [update.slimdevices.com
>on port 80 with path http://update.slimdevices.com:80/update/picks.pls
>with timeout 5]
>2004-10-27 16:41:13.5391 Request: GET /update/picks.pls HTTP/1.0
>Host: update.slimdevices.com:80
>User-Agent: iTunes/3.0 (MSWin32; SlimServer 5.4.0)
>Accept: */*
>Cache-Control: no-cache
>Connection: close
>Icy-MetaData:1
>2004-10-27 16:41:13.5432 Response: HTTP/1.0 400 Host Required In
Request
>
>2004-10-27 16:41:13.5434 Invalid response code (400) from remote stream
>http://update.slimdevices.com/update/picks.pls
>cannot connect to http daemon to get playlist at
>/PerlApp/Slim/Utils/Scan.pm line 357.
>
>I also get this text when I open the proxy address in a browser:
>Description: Your browser did not send a "Host" HTTP header field and
>therefore the virtual host being requested could not be determined. To
>access this web site correctly, you will need to upgrade to a browser
>that supports the HTTP "Host" header field.
>
>But I can see what looks like it might be a "Host header field" in the
>debug output...
>Does anyone else use a proxy?
>
>
>James
>
>-----Original Message-----
>From: Craig, James (IT)
>Sent: 27 October 2004 16:18
>To: 'Slim Devices Discussion'
>Subject: [slim] Proxy configuration?
>
>Oh dear now I feel stupid. It's in the server settings!
>
>-----Original Message-----
>From: discuss-bounces (AT) lists (DOT) slimdevices.com
>[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of Craig,
James
>(IT)
>Sent: 27 October 2004 14:27
>To: Slim Devices Discussion
>Subject: [slim] Proxy configuration?
>
>Hi all,
>I've searched the groups etc but I can't see any mention of this
>Is it possible to configure SlimServer's internet access to go via a
web
>proxy?
>I can't try any streams or the new Slim Devices picks at work because
of
>this (I think)
>
>Thanks
>
>James
>--------------------------------------------------------
>
>NOTICE: If received in error, please destroy and notify sender. Sender
>does not waive confidentiality or privilege, and use is prohibited.
>
>
>

rtitmuss
2004-10-28, 12:14
James,

I need to use the proxy configuration for a while to bypass my isp's
transparent proxy, it was broken and did not play shoutcast streams
correctly. Thankfully that got fixed so I have not tried using a proxy
recently.

The headers shown in your request do look correct, seems strange it does
not work.

Regards,
Richard


Craig, James (IT) wrote:

>Hello Robin,
>I added that code but I don't think it's the problem in my case.
>The error message indicates SlimServer is talking to the proxy but not
>giving it what it's looking for - the 'host' header.
>
>I assume you've had success with configuring a proxy and hence it's just
>the one here being difficult?
>
>James
>
>
>-----Original Message-----
>From: discuss-bounces (AT) lists (DOT) slimdevices.com
>[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of Richard
>Titmuss
>Sent: 27 October 2004 18:41
>To: Slim Devices Discussion
>Subject: [slim] Proxy configuration?
>
>James,
>
>See http://bugs.slimdevices.com/show_bug.cgi?id=271. Only some parts of
>the slimserver use the proxy at the moment, the second patch attached to
>
>the bug report sets the proxy for all lwp requests, but it requires a
>server restart to take effect. The patch is old, so may not apply
>cleanly to the latest slimserver builds.
>
>Regards,
>Richard
>
>
>Craig, James (IT) wrote:
>
>
>
>>Ah now I am sure it doesn't work! I get this in the log (with suitable
>>debugging turned on)
>>
>>2004-10-27 16:41:13.5358 Opening connection to
>>http://update.slimdevices.com/update/picks.pls: [update.slimdevices.com
>>on port 80 with path http://update.slimdevices.com:80/update/picks.pls
>>with timeout 5]
>>2004-10-27 16:41:13.5391 Request: GET /update/picks.pls HTTP/1.0
>>Host: update.slimdevices.com:80
>>User-Agent: iTunes/3.0 (MSWin32; SlimServer 5.4.0)
>>Accept: */*
>>Cache-Control: no-cache
>>Connection: close
>>Icy-MetaData:1
>>2004-10-27 16:41:13.5432 Response: HTTP/1.0 400 Host Required In
>>
>>
>Request
>
>
>>2004-10-27 16:41:13.5434 Invalid response code (400) from remote stream
>>http://update.slimdevices.com/update/picks.pls
>>cannot connect to http daemon to get playlist at
>>/PerlApp/Slim/Utils/Scan.pm line 357.
>>
>>I also get this text when I open the proxy address in a browser:
>>Description: Your browser did not send a "Host" HTTP header field and
>>therefore the virtual host being requested could not be determined. To
>>access this web site correctly, you will need to upgrade to a browser
>>that supports the HTTP "Host" header field.
>>
>>But I can see what looks like it might be a "Host header field" in the
>>debug output...
>>Does anyone else use a proxy?
>>
>>
>>James
>>
>>-----Original Message-----
>>From: Craig, James (IT)
>>Sent: 27 October 2004 16:18
>>To: 'Slim Devices Discussion'
>>Subject: [slim] Proxy configuration?
>>
>>Oh dear now I feel stupid. It's in the server settings!
>>
>>-----Original Message-----
>>From: discuss-bounces (AT) lists (DOT) slimdevices.com
>>[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of Craig,
>>
>>
>James
>
>
>>(IT)
>>Sent: 27 October 2004 14:27
>>To: Slim Devices Discussion
>>Subject: [slim] Proxy configuration?
>>
>>Hi all,
>>I've searched the groups etc but I can't see any mention of this
>>Is it possible to configure SlimServer's internet access to go via a
>>
>>
>web
>
>
>>proxy?
>>I can't try any streams or the new Slim Devices picks at work because
>>
>>
>of
>
>
>>this (I think)
>>
>>Thanks
>>
>>James
>>--------------------------------------------------------
>>
>>NOTICE: If received in error, please destroy and notify sender. Sender
>>does not waive confidentiality or privilege, and use is prohibited.
>>
>>
>>