PDA

View Full Version : Serverlast durch MySQL



jherbert
2009-11-30, 09:14
Ich betreibe den neuesten Nightly-Built von SqueezeServer auf einem easyStore H340 unter Windows Home Server. Der MySQL-Dienst verursacht eine kontinuierliche Prozessorlast zwischen zehn und 50 Prozent, auch wenn Squeezeserver nicht aktiv ist. Ist das normal so, oder kann ich das irgendwie minimieren?

Ich habe den Eindruck, dass dieser Prozess mit daran schuld ist, dass sich der WHS nicht in Standby oder Ruhezustand begibt oder die Platten herunterfährt, wenn keine Requests vorliegen.

Ich hatte SqueezeServer zuvor auf einer Infrant ReadyNAS, und die die ging brav in Standby, wenn nichts anlag.

Ausserdem ist es mir noch nicht gelungen, SqueezeServer beim Hochfahren des WHS automatisch zu starten. Das entsprechende Häkchen habe ich gesetzt, aber es bleibt leider ohne Wirkung.

Auf sachdienliche Hinweise gespannt, Joachim.

mfie
2009-11-30, 10:24
Ich betreibe den neuesten Nightly-Built von SqueezeServer auf einem easyStore H340 unter Windows Home Server. Der MySQL-Dienst verursacht eine kontinuierliche Prozessorlast zwischen zehn und 50 Prozent, auch wenn Squeezeserver nicht aktiv ist. Ist das normal so, oder kann ich das irgendwie minimieren?


Ich würde zunächst mal mit der normalen Version 7.4.1 probieren. Wenn das Problem dann immer noch besteht, kann man weiter Ursachenforschung betreiben.

jo-wie
2009-11-30, 11:07
Ist den das Durchsuchen der Musiksammlung beendet? Weiß ja nicht, wieviel Dateien du da scannst. ;-)

jherbert
2009-11-30, 11:07
Die geschilderten Effekte (von Poblemen will ich nicht sprechen) traten auch bei der Release-Version auf. Ich habe die Nightly installiert, weil in ihr ja auch bekannte Fehler gefixt sind, und nur von der 7.5 abgeraten wird, nicht aber von der 7.4.2.

Von daher freue ich mich weiter über Sachdienliches.

jo-wie
2009-11-30, 11:31
Das war ernst gemeint, nicht das irgendwo der Scanner hängt und sich einen Wolf sucht. Man soll ja nicht das Unmögliche ausschließen. Vielleicht kannst du auch die Logs mal posten.

mfie
2009-11-30, 11:38
Ich hab hier im Forum auch schon öfters von Problemen in Zusammenhang mit Virenscannern gelesen. Die scheinen sich gern mal mit mysql zu beharken. Eine Möglichkeit wäre noch den WHS zu killen und auf ein Linux umzusteigen. ;)

jherbert
2009-11-30, 12:12
@jo-wie: Ja, das Scannen ist abgeschlossen. Und die Frage ist natürlich berechtigt.

@mfie: Den vorinstallierten Mcaffee-Scanner habe ich schon deinstalliert. Momentan ist ein Avast aktiv, aber den werde ich testweise auch mal abklemmen.

Ich verstehe das richtig, dass mySQL bei euch die Füße still hält, wenn es nichts zu serven gibt?

mfie
2009-11-30, 12:17
Ich verstehe das richtig, dass mySQL bei euch die Füße still hält, wenn es nichts zu serven gibt?

Ja, ich hab den SB Server aber unter Linux laufen.

moinmoin
2009-11-30, 12:25
Ja, ich hab den SB Server aber unter Linux laufen.

dito, solange keine größeren Abfragen laufen, hat der MySQL Prozess eigentlich immer < 1% CPU Auslastung.

Mojo1604
2009-11-30, 12:42
dito, solange keine größeren Abfragen laufen, hat der MySQL Prozess eigentlich immer < 1% CPU Auslastung.

Ich betreibe auch den H340 allerdings mit der 7.4.1 und bei mir ist der MySQL Prozess auch immer unter 1%.
Irgendwas scheint bei dir noch zu laufen, was hast du noch installiert? Avast habe ich auch drauf, wobei ich nur die für mich relevanten Teile laufen habe...
Gruß
Jan

jherbert
2009-11-30, 13:06
Avast habe ich eben runter genommen - war nicht so einfach, weil die Deinstallation über die installierten Plugins nicht ging (= Avast nicht in der Liste) und über control panel software nur eine Fehlermeldung kam.

Es gibt aber bei avast ein Deinstallationsprogramm, und damit ging es dann.

Nach Neustart ist war mySQL jetzt im Leerlauf, und nach dem Start von SB-Server geht das Theater wieder los. Das File I/O von mySQL liegt in der Spitze bei 15 MB/s.

edit: Und jetzt ist Ruhe.Ich habe den Process Explorer von Systernals geladen, der mich zunächst anmeckerte, ich möge zur Darstellung der Threads eines Prozesses bitte eine dll aus dem MS-Debugger installieren. Den (dbg_x86_6.11.1.404.msi) habe ich eben installiert, und jetzt herrscht wie gesagt relative Ruhe. Hat wahrscheinlich nichts mit dem Debugger zu tun. Aber vielleicht ist bei der Installation Segensreiches auf die Platte gekommen. Who knows.

ZX81
2009-11-30, 13:52
Nach Neustart ist war mySQL jetzt im Leerlauf, und nach dem Start von SB-Server geht das Theater wieder los.
Installier doch mal den MySQL Administrator und verbinde dich damit mit dem Dinest auf dem DB Server.
In der Administrator Anwendung kanst Du villeicht erkennen was gerade in der DB vor sich geht.