PDA

View Full Version : Debian Tag cache problem



P McDowell
2004-05-11, 14:14
Hi
I'm running 5.1.5 on Debian testing
When I enable the tag cache, and restart the server, the library shows one
album with no songs
When I press wipe cache the server dies
When I start it again, I can rescan OK, then the server dies.
I can restart it and change it back to no cache and everything is OK
I'm guessing that I need a file location for the cache and the right
permissions.
I tried chmod 777 for the Cache file in SlimServer and that didn't do it.
Can anybody assist ?

Pete

P McDowell
2004-05-13, 15:45
Can anybody help me out with this ?
What is the tag cache file called, and where should it be ?

"P McDowell" <pmcdowell (AT) paradise (DOT) net.nz> wrote in
message news:c7rfog$sco$1 (AT) sea (DOT) gmane.org...
> Hi
> I'm running 5.1.5 on Debian testing
> When I enable the tag cache, and restart the server, the library shows one
> album with no songs
> When I press wipe cache the server dies
> When I start it again, I can rescan OK, then the server dies.
> I can restart it and change it back to no cache and everything is OK
> I'm guessing that I need a file location for the cache and the right
> permissions.
> I tried chmod 777 for the Cache file in SlimServer and that didn't do it.
> Can anybody assist ?
>
> Pete

dean
2004-05-13, 15:55
By default, the cache directory is in the same directory as the
slimserver.pl executable on all platforms besides Macintosh.

You can specify a different cache directory from the command line with
the --cachedir option if you wanted to specify a new place for it (in
/var, for example).

You should be able to make it writable by the slimserver process and
then it should work.

-dean


On May 13, 2004, at 3:45 PM, P McDowell wrote:

> Can anybody help me out with this ?
> What is the tag cache file called, and where should it be ?
>
> "P McDowell" <pmcdowell (AT) paradise (DOT) net.nz> wrote in
> message news:c7rfog$sco$1 (AT) sea (DOT) gmane.org...
>> Hi
>> I'm running 5.1.5 on Debian testing
>> When I enable the tag cache, and restart the server, the library
>> shows one
>> album with no songs
>> When I press wipe cache the server dies
>> When I start it again, I can rescan OK, then the server dies.
>> I can restart it and change it back to no cache and everything is OK
>> I'm guessing that I need a file location for the cache and the right
>> permissions.
>> I tried chmod 777 for the Cache file in SlimServer and that didn't do
>> it.
>> Can anybody assist ?
>>
>> Pete
>
>
>
>

kdf
2004-05-13, 15:56
..slimserver.db, and it should be found in the home directory of the user running
slimserver.

also, try running the server from the command line like so:

/usr/local/slimserver/slimserver.pl --d_info

this will give you debug output in the console, which will help you see what is
going on wiht the db file and the music scan.

-kdf

Quoting P McDowell <pmcdowell (AT) paradise (DOT) net.nz>:

> Can anybody help me out with this ?
> What is the tag cache file called, and where should it be ?
>
> "P McDowell" <pmcdowell (AT) paradise (DOT) net.nz> wrote in
> message news:c7rfog$sco$1 (AT) sea (DOT) gmane.org...
> > Hi
> > I'm running 5.1.5 on Debian testing
> > When I enable the tag cache, and restart the server, the library shows one
> > album with no songs
> > When I press wipe cache the server dies
> > When I start it again, I can rescan OK, then the server dies.
> > I can restart it and change it back to no cache and everything is OK
> > I'm guessing that I need a file location for the cache and the right
> > permissions.
> > I tried chmod 777 for the Cache file in SlimServer and that didn't do it.
> > Can anybody assist ?
> >
> > Pete
>
>
>
>

P McDowell
2004-05-13, 17:37
Thanks dean
"dean blackketter" <dean (AT) slimdevices (DOT) com> wrote in
message news:9B371BB8-A530-11D8-8E04-000393DB3CFA (AT) slimdevices (DOT) com...
> By default, the cache directory is in the same directory as the
> slimserver.pl executable on all platforms besides Macintosh.
>
> You can specify a different cache directory from the command line with
> the --cachedir option if you wanted to specify a new place for it (in
> /var, for example).
>
> You should be able to make it writable by the slimserver process and
> then it should work.
>
> -dean
>
>
> On May 13, 2004, at 3:45 PM, P McDowell wrote:
>
> > Can anybody help me out with this ?
> > What is the tag cache file called, and where should it be ?
> >
> > "P McDowell" <pmcdowell (AT) paradise (DOT) net.nz> wrote
in
> > message news:c7rfog$sco$1 (AT) sea (DOT) gmane.org...
> >> Hi
> >> I'm running 5.1.5 on Debian testing
> >> When I enable the tag cache, and restart the server, the library
> >> shows one
> >> album with no songs
> >> When I press wipe cache the server dies
> >> When I start it again, I can rescan OK, then the server dies.
> >> I can restart it and change it back to no cache and everything is OK
> >> I'm guessing that I need a file location for the cache and the right
> >> permissions.
> >> I tried chmod 777 for the Cache file in SlimServer and that didn't do
> >> it.
> >> Can anybody assist ?
> >>
> >> Pete
> >
> >
> >
> >

P McDowell
2004-05-13, 17:38
thanks kdf
"kdf" <slim-mail (AT) deane-freeman (DOT) com> wrote in
message news:1084489015.40a3fd3726d98 (AT) callisto (DOT) deane-freeman.com...
> .slimserver.db, and it should be found in the home directory of the user
running
> slimserver.
>
> also, try running the server from the command line like so:
>
> /usr/local/slimserver/slimserver.pl --d_info
>
> this will give you debug output in the console, which will help you see
what is
> going on wiht the db file and the music scan.
>
> -kdf
>
> Quoting P McDowell <pmcdowell (AT) paradise (DOT) net.nz>:
>
> > Can anybody help me out with this ?
> > What is the tag cache file called, and where should it be ?
> >
> > "P McDowell" <pmcdowell (AT) paradise (DOT) net.nz> wrote
in
> > message news:c7rfog$sco$1 (AT) sea (DOT) gmane.org...
> > > Hi
> > > I'm running 5.1.5 on Debian testing
> > > When I enable the tag cache, and restart the server, the library shows
one
> > > album with no songs
> > > When I press wipe cache the server dies
> > > When I start it again, I can rescan OK, then the server dies.
> > > I can restart it and change it back to no cache and everything is OK
> > > I'm guessing that I need a file location for the cache and the right
> > > permissions.
> > > I tried chmod 777 for the Cache file in SlimServer and that didn't do
it.
> > > Can anybody assist ?
> > >
> > > Pete
> >
> >
> >
> >