PDA

View Full Version : Problems with slimserver and flac on Linux



David Brittain
2004-05-03, 02:09
Hi

I have been running slimserver 5.1.5 under Windows for a while with no problems. I would like to serve from Linux instead. I have a machine running Mandrake 10.0 (official) and have installed the same version of slimserver. The slimbox attaches to the server and I can browse and select a track to play. The track starts playing but after maybe 20-30 seconds it just stops. The CPU meter on the PC goes from a spiky 10-20% to 100% with all time being spent in the slimserver process. The slimbox then loses contact with the server. To get thing working again the slimserver has to be restarted. All audio files are encoded with flac (through EAC under Windows). And I am using flac 1.1.0 built myself on the server.

If I turn on the verbose debug messgaes the last few lines read:

2004-05-03 09:44:15.0286 Read 20480 bytes from source
2004-05-03 09:44:15.1497 Read 16384 bytes from source
2004-05-03 09:44:15.2408 Read 20480 bytes from source
2004-05-03 09:44:15.3530 Read 16384 bytes from source
2004-05-03 09:44:15.4487 Read 20480 bytes from source
2004-05-03 09:44:15.5568 Read 16384 bytes from source
2004-05-03 09:44:15.6626 Read 20480 bytes from source
2004-05-03 09:44:15.7721 Read 16384 bytes from source

01 - Rainy Day Women #12 & 35.flac: ERROR while decoding data
state = 3:FLAC__STREAM_DECODER_READ_FRAME

If I test or decode the flac files from the command line everything seems to be OK, i.e. I get no errors.

Does anyone have any ideas as to what is going wrong?

Thanks

Dave