PDA

View Full Version : 5.1.4 broke WMA on Fedora



Pat Farrell
2004-04-20, 19:22
I don't think this has been covered already, if it has, sorry for the noise.

In general, the install of 5.1.4 was wonderful, went every smoothly.
But, it broke my WMA to Wav playing.

Fedora 1 is the OS.

I used to have ffmpeg in the convert.conf
and it appears that the default installation (from RPM)
changed the $ffmpeg$ line
to
wma wav squeezebox *
[wmadec] -r 44100 -b 16 -n 2 $FILE$

Which would probably be cool, but it didn't install wmadec in a place that
it can find. I had ffmpeg version 0.4.8 on the system path in /usr/bin

So, was wmadec supposed to be in the RPM?
I see that its source is in the CVS tree, are we supposed to get it
from there and compile it? etc.?

Thanks
Pat


Pat Farrell pfarrell (AT) pfarrell (DOT) com
http://www.pfarrell.com

Dan Sully
2004-04-20, 19:41
* Pat Farrell <pfarrell (AT) pfarrell (DOT) com> shaped the electrons to say...

>Fedora 1 is the OS.
>
>Which would probably be cool, but it didn't install wmadec in a place that
>it can find. I had ffmpeg version 0.4.8 on the system path in /usr/bin
>
>So, was wmadec supposed to be in the RPM?
>I see that its source is in the CVS tree, are we supposed to get it
>from there and compile it? etc.?

wmadec only works on Windows, as it's compiled against the Windows Media library files.

You'll want to override the wma line with ffmpeg in your own slimserver-convert.conf

-D
--
"You can usually recover from production flaws...but you can never recover from a bad design".

kdf
2004-04-20, 19:46
Unfortunately, it isn't broken; it is by design. For the default installation,
WMA to WAV conversion is for Windows only now. wmadec.exe is included in the
Bin/MSWin32-x86-multi-thread/ subdirectory. In order to continue using wma
under linux, you'll have to create a custom-convert.conf and put the ffmpeg
lines in there. The new file types settings in Server Settings, Additional,
will allow you to disable the default line and enable your custom one. By
putting the lines in custom-convert.conf, you avoid having them overwritten in
future updates to convert.conf.

-kdf

Quoting Pat Farrell <pfarrell (AT) pfarrell (DOT) com>:

> I don't think this has been covered already, if it has, sorry for the noise.
>
> In general, the install of 5.1.4 was wonderful, went every smoothly.
> But, it broke my WMA to Wav playing.
>
> Fedora 1 is the OS.
>
> I used to have ffmpeg in the convert.conf
> and it appears that the default installation (from RPM)
> changed the $ffmpeg$ line
> to
> wma wav squeezebox *
> [wmadec] -r 44100 -b 16 -n 2 $FILE$
>
> Which would probably be cool, but it didn't install wmadec in a place that
> it can find. I had ffmpeg version 0.4.8 on the system path in /usr/bin
>
> So, was wmadec supposed to be in the RPM?
> I see that its source is in the CVS tree, are we supposed to get it
> from there and compile it? etc.?
>
> Thanks
> Pat
>
>
> Pat Farrell pfarrell (AT) pfarrell (DOT) com
> http://www.pfarrell.com
>

Pat Farrell
2004-04-20, 19:55
At 10:46 PM 4/20/2004, kdf wrote:
>Unfortunately, it isn't broken; it is by design.

bletch, clobbering a working system without warning,
or even saving the old file to convert.conf.old or convert.conf~

>WMA to WAV conversion is for Windows only now.

OK, I don't speak Windows. It used to work...

> In order to continue using wma
>under linux, you'll have to create a custom-convert.conf and put the ffmpeg
>lines in there.

In another message, Dan Sully <daniel (AT) electricrain (DOT) com> wrote:
>You'll want to override the wma line with ffmpeg in your own
>slimserver-convert.conf

OK, you both are smarter and better looking than me.
Which is it? slimserver-convert.conf or custom-convert.conf ???
are they the same? one prefered over the other?

And does someone have the $ffmpeg$ lines from the old file
that i can put in the appropriate file?

Thanks
Pat

kevin
2004-04-20, 20:18
> Which is it? slimserver-convert.conf or custom-convert.conf ???
> are they the same? one prefered over the other?

Looks like slimserver-convert.conf or .slimserver-convert.conf (in
Source.pm)

> And does someone have the $ffmpeg$ lines from the old file
> that i can put in the appropriate file?

Uncompressed for Squeezebox:
---
wma wav squeezebox *
$ffmpeg$ -v 0 -i $FILE$ -f wav -
---
and mp3 for everything else...:
---
wma mp3 * *
$ffmpeg$ -v 0 -i $FILE$ -f wav - | $lame$ --silent -b $BITRATE$
- -
---

However...those lines are from v5.1.1. convert.conf in 5.1.2+ now
uses [binaryname] instead of $binaryname$, I'm not sure if this will
make a difference?

Regards,
Kevin P.

kdf
2004-04-20, 20:26
Quoting Kevin Pearsall <kevin (AT) slimdevices (DOT) com>:

> > Which is it? slimserver-convert.conf or custom-convert.conf ???
> > are they the same? one prefered over the other?
>
> Looks like slimserver-convert.conf or .slimserver-convert.conf (in
> Source.pm)
>

sorry, my bad. yes. I got mixed up myself with other files that could be
slimserver- or custom-.
-kdf

Pat Farrell
2004-04-20, 21:02
At 11:26 PM 4/20/2004, kdf wrote:
> > Looks like slimserver-convert.conf or .slimserver-convert.conf (in
> > Source.pm)
>sorry, my bad. yes. I got mixed up myself with other files that could be
>slimserver- or custom-.

OK, I assume that the format of this file is the same as
for the convert.conf. (with square brackets instead of the $ of yore

So I made a sutable file in /usr/local/slimserver
[root@beatles slimserver]# cat slimserver-convert.conf
wma wav squeezebox *
[ffmpeg] -v 0 -i $FILE$ -f wav -


And then started up the server, let it scan my library, and then
turned off the default WMA -> MP3 for *
selection and left on
the WMA -> Wav for SqueezeBox

the command shows the proper [ffmpeg] -v 0 -i $FILE$ -f wav -
altho I got this from an earlier post, and may have incorrect
switches. Still, we should get further.

Yet it doesn't play and the log file shows... as below in the p.s.

Thanks
Pat


and the log says
004-04-20 23:56:11.6781 Checking to see if wma-mp3-*-* is enabled
2004-04-20 23:56:11.6793 There are 0 disabled formats...
2004-04-20 23:56:11.6804 Testing wma-mp3-*-* vs wma-mp3-*-*
2004-04-20 23:56:11.6814 !! wma-mp3-*-* Disabled!!
2004-04-20 23:56:11.6825 ******* Error: Didn't find any command matches
for type: wma format: mp3 ******
2004-04-20 23:56:11.6836 openSong: this is an wma file: /songs/newage/Mars
Lasar/Escape/Unity.wma
2004-04-20 23:56:11.6848 file type: wma format: mp3 inrate: 0.16 maxRate: 0
Use of uninitialized value in concatenation (.) or string at
Slim/Player/Source.pm line 768.
2004-04-20 23:56:11.6859 command:
Use of uninitialized value in concatenation (.) or string at
Slim/Player/Source.pm line 851.
2004-04-20 23:56:11.6871 Couldn't create command line for wma playback
(command: ) for /songs/newage/Mars Lasar/Escape/Unity.wma
2004-04-20 23:56:11.6893 Backtrace:

frame 0: Slim::Player::Source::playmode (Slim/Player/Source.pm line 534)
frame 1: Slim::Player::Source::openNext (Slim/Player/Source.pm line 239)
frame 2: Slim::Player::Source::playmode (Slim/Control/Command.pm line 213)
frame 3: Slim::Control::Command::execute (Slim/Web/HTTP.pm line 550)
frame 4: Slim::Web::HTTP::processURL (Slim/Web/HTTP.pm line 430)
frame 5: Slim::Web::HTTP::processHTTP (Slim/Networking/Select.pm line 78)
frame 6: Slim::Networking::Select::select
(/usr/local/slimserver/slimserver.pl line 420)
frame 7: main::idle (/usr/local/slimserver/slimserver.pl line 362)
frame 8: main::main (/usr/local/slimserver/slimserver.pl line 807)

2004-04-20 23:56:11.6909 172.16.4.99: Switching to mode stop from stop