PDA

View Full Version : Receiver/SB3 needed for SqueezePlay development?



dengamle
2008-05-14, 01:30
Hi,

I have a fairly simple question which I couldn't find an answer for in the wikis/forums.

Do I need the actual hardware Receiver/SB3 in order to connect to SqueezeNetwork from the Desktop-version of SqueezePlay(jive)?

I have successfully built the SqueezePlay application on Linux (Jive 7.1 r2434), but running the app (build/linux/bin/jive) on my virtual ubuntu image doesn't allow me to do a
"Settings->Music Source->SqueezeNetwork". Since I haven't connected the SqueezePlay app with a player device on my local network, I'm guessing this is the cause?

Could I do this with a purely software based solution (ie. use a software player such as SoftSqueeze)?
How much do I need in order to accomplish connecting to SqueezeNetwork using the desktop SqueezePlay app?

The reason for this is of course that I'm rarely connected to my local network where my Receiver hardware is located.

Best regards

dengamle.

bklaas
2008-05-14, 05:15
Run softsqueeze on the same Ubuntu machine, and connect it to SqueezeNetwork, then connect your Squeezeplay to the softsqueeze player. Squeezeplay will eventually be a "player" as well, but currently is not one.

cheers,
#!/ben

dean
2008-05-14, 07:21
On May 14, 2008, at 1:30 AM, dengamle wrote:
> Do I need the actual hardware Receiver/SB3 in order to connect to
> SqueezeNetwork from the Desktop-version of SqueezePlay(jive)?
Not at this time, though the specifics of that policy are being
discussed. We may require the purchase of hardware to use SN, but I'd
like to keep it as free and easy as possible.

> I have successfully built the SqueezePlay application on Linux (Jive
> 7.1 r2434), but running the app (build/linux/bin/jive) on my virtual
> ubuntu image doesn't allow me to do a
> "Settings->Music Source->SqueezeNetwork". Since I haven't connected
> the
> SqueezePlay app with a player device on my local network, I'm guessing
> this is the cause?
I think that this is a technical problem, not a policy issue.

dengamle
2008-05-14, 07:39
Hi Dean and Ben,

Thank you very much for you reply!

I did try to install the SoftSqueeze app (3.5), but running it gives me the following error output:


dengamle@dengamle-ubuntu-desktop:/usr/java/jre1.6.0_05/bin$ java -jar /home/dengamle/Applications/softsqueeze_3.5/SoftSqueeze.jar
log4j:ERROR Parsing error on line 2 and column 48
log4j:ERROR null
log4j:ERROR Could not parse input source [org.xml.sax.InputSource@8d1adc0].
gnu.xml.dom.ls.DomLSException
at gnu.xml.dom.ls.DomLSParser.doParse(DomLSParser.jav a:311)
at gnu.xml.dom.ls.DomLSParser.parse(DomLSParser.java: 159)
at gnu.xml.dom.DomDocumentBuilder.parse(DomDocumentBu ilder.java:179)
at org.apache.log4j.xml.DOMConfigurator.doConfigure(D OMConfigurator.java:665)
at org.apache.log4j.xml.DOMConfigurator.doConfigure(D OMConfigurator.java:616)
at org.apache.log4j.xml.DOMConfigurator.doConfigure(D OMConfigurator.java:602)
at org.apache.log4j.helpers.OptionConverter.selectAnd Configure(OptionConverter.java:460)
at org.apache.log4j.LogManager.<clinit>(LogManager.java:113)
at org.apache.log4j.Logger.getLogger(Logger.java:85)
at org.titmuss.softsqueeze.platform.Platform.<clinit>(Platform.java:46)
at org.titmuss.softsqueeze.Application.main(Applicati on.java:52)
Caused by: org.xml.sax.SAXParseException
at gnu.xml.stream.SAXParser.parse(SAXParser.java:660)
at gnu.xml.dom.ls.DomLSParser.doParse(DomLSParser.jav a:299)
...10 more
Caused by: javax.xml.stream.XMLStreamException
at gnu.xml.stream.XMLParser.next(XMLParser.java:1218)
at gnu.xml.stream.XMLParser.hasNext(XMLParser.java:10 18)
at gnu.xml.stream.SAXParser.parse(SAXParser.java:377)
...11 more
Caused by: java.net.MalformedURLException: Protocol handler not found: dummy
at java.net.URL.<init>(URL.java:470)
at java.net.URL.<init>(URL.java:325)
at gnu.xml.stream.XMLParser.absolutize(XMLParser.java :1625)
at gnu.xml.stream.XMLParser.readExternalIds(XMLParser .java:2580)
at gnu.xml.stream.XMLParser.readDoctypeDecl(XMLParser .java:1774)
at gnu.xml.stream.XMLParser.next(XMLParser.java:1164)
...13 more
log4j:WARN No appenders could be found for logger (platform).
log4j:WARN Please initialize the log4j system properly.
Error starting Softsqueeze: mixer not found
javax.sound.sampled.AudioSystem.getMixer(AudioSyst em.java:411)
org.titmuss.softsqueeze.audio.AudioMixer.getDefaul tJavaSoundMixer(AudioMixer.java:620)
org.titmuss.softsqueeze.config.Config._loadProp(Co nfig.java:318)
org.titmuss.softsqueeze.config.Config.<init>(Config.java:264)
org.titmuss.softsqueeze.config.Config.init(Config. java:76)
org.titmuss.softsqueeze.config.Config.init(Config. java:71)
org.titmuss.softsqueeze.Softsqueeze.main(Softsquee ze.java:491)
org.titmuss.softsqueeze.Application.main(Applicati on.java:55)

align: javax.swing.text.html.NullView@9012ca0
dengamle@dengamle-ubuntu-desktop:/usr/java/jre1.6.0_05/bin$



Do you know what might be the problem here?

I have tried playing music on my Ubuntu system and it works (just using wave files). I thought the might be problems accessing the soundcard or something. (Maybe there still are?).

Hope you can help on this one :)

Best regards

dengamle.

bhaagensen
2008-05-14, 09:04
dengamle@dengamle-ubuntu-desktop:/usr/java/jre1.6.0_05/bin$ java -jar /home/dengamle/Applications/softsqueeze_3.5/SoftSqueeze.jar


try:

'cd /home/dengamle/Applications/softsqueeze_3.5'

and then

'/usr/java/jre1.6.0_05/bin/java -jar Softsqueeze.jar'

dengamle
2008-05-14, 13:57
Hi bhaagensen,

Thank you very much for your comment. I assume you're danish by the name :)

(damn!) annoying that I didn't think of trying your suggestion before posting here, but yes now it works:) at least now I can run the application. And the SoftSqueeze app can connect to SqueezeNetwork (although it prompts me at startup to upgrade) and start playback of internet radio stations.

There seems to be some problems with accessing the SoftSqueeze player/SqueezeNetwork from the SqueezePlay (v7.1 r2434) application. Possibly this is due to version incompatibilities between the different apps.

I'm running SqueezePlay 7.1 optimized for SqueezeCenter 7.1
Softsqueeze says that it's optimized for SqueezeCenter 7.0
SqueezeNetwork server is running SqueezeCenter 7.0-sn?

It doesn't seem like a good mix :)

-dengamle.