PDA

View Full Version : Firmware version



jotap_66
2007-02-22, 03:21
Hello:

I have just bought a SB3....When I configured, it was installed a new firmware version (I think 48)...I read that there are new versions of firmware...My question is if the firmware version depends on the slimserver version...For example, I am using 6.2.2 but I read that last version is 6.5.1...If I install 6.5.1, SB3 will update to a new version of firmware? What happens if later I downgrade the slimserver...to 6.2.2?


Thanks


JP

jeremy
2007-02-22, 03:39
It pretty much sorts itself out. If you go back to an earlier version of the server software the squeezebox will prompt you to 'update' the firmware to the appropriate earlier version. The guys at SD are great at making this sort of stuff easy for users & this forum and wiki are a mine of useful info

jotap_66
2007-02-22, 03:44
It pretty much sorts itself out. If you go back to an earlier version of the server software the squeezebox will prompt you to 'update' the firmware to the appropriate earlier version. The guys at SD are great at making this sort of stuff easy for users & this forum and wiki are a mine of useful info


If I understand you, you are telling me that firmware version depends on the slimserver version used?

Thank you

JP

oreillymj
2007-02-22, 03:54
The firmware and Slimserver software are pretty independent of each other, but there have been times in the past where a FW upgrade depended on a certain version of the Server software being present.

e.g I think FW54 or later requires SS6.5x.

Slim recommends that users upgrade Server software and FW together as they are tested as a unit. It would involve too much work to test server upgrades for compatibility with several older FW version.
Similarly, Slim don't go back and update 6.2 or 6.3 to work with the current FW as well as the version bundled with the release.

So if you upgrade to 6.5 the FW will automatically bee updated.
If you go back to 6.2 or 6.3 you'll be prompted to downgrade.

You can edit the squeezebox2.version file in C:\Program Files\SlimServer\server\Firmware to avoid a downgrade, but you won't get any support if your system breaks.

mherger
2007-02-22, 03:58
> My question is if the firmware version depends on the
> slimserver version...

Correct

> What happens if later I downgrade the slimserver...

The firmware will be downgraded as well.

--

Michael

-----------------------------------------------------------------
http://www.herger.net/SlimCD - your SlimServer on a CD
http://www.herger.net/slim - AlbumReview, Biography, MusicInfoSCR

jotap_66
2007-02-22, 04:00
The firmware and Slimserver software are pretty independent of each other, but there have been times in the past where a FW upgrade depended on a certain version of the Server software being present.

e.g I think FW54 or later requires SS6.5x.

Slim recommends that users upgrade Server software and FW together as they are tested as a unit. It would involve too much work to test server upgrades for compatibility with several older FW version.
Similarly, Slim don't go back and update 6.2 or 6.3 to work with the current FW as well as the version bundled with the release.

So if you upgrade to 6.5 the FW will automatically bee updated.
If you go back to 6.2 or 6.3 you'll be prompted to downgrade.

You can edit the squeezebox2.version file in C:\Program Files\SlimServer\server\Firmware to avoid a downgrade, but you won't get any support if your system breaks.


Now, I understand all...

Thank you very much

JP

jotap_66
2007-02-22, 10:43
> My question is if the firmware version depends on the
> slimserver version...

Correct

> What happens if later I downgrade the slimserver...

The firmware will be downgraded as well.

--

Michael

-----------------------------------------------------------------
http://www.herger.net/SlimCD - your SlimServer on a CD
http://www.herger.net/slim - AlbumReview, Biography, MusicInfoSCR


Thank you very much Michael...

JP