PDA

View Full Version : playing .wav files on Linux-based slimserver



Andreas Huster
2005-02-17, 21:17
I have slimserver running on Linux (RH9) in anticipation of getting a
squeezebox. For now, I'm testing it with Windows media player running on
another computer. So far, I can play .mp3 files.

The whole thing fails when I want to play .wav files using lame. lame is
installed on the system and I can run lame using the same command as the
server and as the same user as the server.

However, when the server tries to do it, it reports:

2005-02-16 22:36:20.6942 Checking to see if wav-mp3-*-* is enabled
2005-02-16 22:36:20.6951 enabled
2005-02-16 22:36:20.6960 Found command: [lame] --resample 44100 --silent
-q 9 -b $BITRATE$ $FILE$ -
2005-02-16 22:36:20.6996 Matched Format: mp3 Type: wav Command: [lame]
--resample 44100 --silent -q 9 -b $BITRATE$ $FILE$ -
2005-02-16 22:36:20.7010 opening next song (old format: mp3, new: mp3)
current playmode: stop
2005-02-16 22:36:20.7025 openSong on:
file:///home/huster/music/Mozart/test.wav
2005-02-16 22:36:20.7057 openSong: getting duration 0, size 0, endian and
offset for file:///home/huster/music/Mozart/test.wav
2005-02-16 22:36:20.7068 openSong: not bothering opening file with zero
size or duration
2005-02-16 22:36:20.7106 Backtrace:

frame 0: Slim::Player::Source::playmode
(/usr/local/slimserver/Slim/Player/Source.pm line 691)
frame 1: Slim::Player::Source::openNext
(/usr/local/slimserver/Slim/Player/Source.pm line 345)
frame 2: Slim::Player::Source::playmode
(/usr/local/slimserver/Slim/Control/Command.pm line 216)
frame 3: Slim::Control::Command::execute
(/usr/local/slimserver/Slim/Web/HTTP.pm line 580)
frame 4: Slim::Web::HTTP::processURL
(/usr/local/slimserver/Slim/Web/HTTP.pm line 460)
frame 5: Slim::Web::HTTP::processHTTP
(/usr/local/slimserver/Slim/Networking/Select.pm line 116)
frame 6: Slim::Networking::Select::select
(/usr/local/slimserver/slimserver.pl line 455)
frame 7: main::idle (/usr/local/slimserver/slimserver.pl line 398)
frame 8: main::main (/usr/local/slimserver/slimserver.pl line 870)

So I thought that a great way to proceed is to remove the --silent option
from the lame command. I edited the convert.conf file in
/usr/local/slimserver. I then went to file types in the server and pressed
'change'. The error log now shows the server examining all the conversion
options, but the wav-to-mp3 command still has the --silent option. Not
that this is a big deal, but where is the server getting that information?
From the convert.conf file or somewhere else? Do I need to restart the
server? Is there a way for the server to show this information in the log?

Apart from my limited debugging attempts, can anyone suggest what else to
do?

Thanks.

--Andreas

kdf
2005-02-17, 22:10
Quoting Andreas Huster <huster (AT) gmail (DOT) com>:

> So I thought that a great way to proceed is to remove the --silent option
> from the lame command. I edited the convert.conf file in
> /usr/local/slimserver. I then went to file types in the server and pressed
> 'change'. The error log now shows the server examining all the conversion
> options, but the wav-to-mp3 command still has the --silent option. Not

> Apart from my limited debugging attempts, can anyone suggest what else to
> do?

editing the convert.conf file requires a restart of the server to take effect.
-kdf